Download

Strange problem with mouse pointing

I am watching this video https://www.youtube.com/watch?v=WwfsWr4A894&list=PLoJ1QVW2Xa7QYlCR5xO9EvFOCRrCPMEko&index=54 and in the first part I did the same things, I think the trace lines was fine made at 3:00 when I tested them. Once I finished the blueprint until 4:30 my mouse point is moved up from the middle, I mean I shoot somewhere but the trace line is shot up from the middle and also doesnt trigger the light box change color unless I aim somewhere down from it. On the picture I shoot straight line and you can see the trace vector hits up from the aim. I tried to delete the blueprint back to how it was in 3:00 but aim is still broken
blueprints I made are absolutely the same as in the video

I started a new project and only did the trace vector and its the same, trace line goes up from aim

The trace is fine, it’s the crosshair that is drawn with an offset. Open the *FirstPersonHUD *blueprint and adjust for its size like so:

Thank you very much. How do you know the middle is minus 8 and minus 8, is it because the picture is 16x16 pixels?

Precisely! Offsetting it by -half would centre it.
[HR][/HR]
Technically the barrel is aiming more like this, but you know how games are…

I believe the 1st person template was updated at some point and the discrepancy between the YT tut and the way it works now may stem from that update. Hardly anyone is using the HUD class anymore.