Download

Static Mesh from Blender to UE4

i keep seeing this quoted as a fact, but i’d like to know what exactly is wrong with using lightmap pack? what does UE not like about it?

its not that EU4 doesn’t like it (it should technically work), its more to do with the fact it wont give you a good (or optimized) lightmap, to be more specific using the lightmap pack splits every face into its own UV island witch means 1:you would need to set the lightmap res in UE4 really high even on fairly small models for them to have decent shadows 2:if you have lots of meshes in your scene (witch you often will) it would take forever to build the lighting even in quite small scenes 3:there would be a performance cost.

for most lightmaps you want to have as few UV islands as possible with 3 or 4 (I prefer 4) pixels of padding between UV islands witch then allows you to set the lightmap res lower while still having good looking shadows, its basically a balancing act between shadow quality/ light build time and performance, blenders lightmap pack doesn’t really do any of those.

hope that helps:)

This is a great thread. Thanks to everyone for all the info. Wouldn’t it be better to make video tutorials on a lot of these subjects. The wiki is great, don’t get me wrong there. It’s just I know that some people can get what you guys are talking about. But, if this is for people that are total noobs in the Blender/UE4 world. Reading on the wiki and a few screenshots is not enough to get the point across. No disrespect intended. Thank you for the Wiki. I just thought I would throw that out there. There isn’t any detailed video tutorials on this subject. If there is I haven’t found them. There are however tutorials in video form that the person trying to teach always cuts short by saying “I am not gonna show you that.” or “I am not going to do that.” I would make the tutorials myself, But I am just learning UE4 too. So from the outside looking in or vice versa. It would be cool to see someone make some detailed video tutorials about these subjects.

Thanks to all for the very useful wiki!

I’ve setup my Blender units as instructed and it works well in UE4, however I observed one problem - if I set the clip end-range in Blender to the value suggested in the wiki (1km) Blender starts producing see-through artifacts even if "Limit selection to visible’ is turned on. Even for lower values such as 500m or even 50m this occurs. Looking at some old threads on the Blender forums it seems this is expected behavior when the clip is set to large values. Any idea how this can be fixed?

My current models are pretty smallish (couple of metres max) so I manage to get away with setting the clip max to 10m, but the setup starts to get a bit unpredictable for larger objects. Also once Blender supports UE4 style navigation controls I’m probably going to be doing larger pieces of my scene here so there’s that.

7043390f591e3191627b88cc7dc9dbf2c267262a.png

Here’s an image with one such example.

Note the shaded artifacts on the sides of the mesh in Edit mode and the see-through like behavior even though ‘Limit selection to visible’ is on.

UE4 style navigation? You mean like an FPS camera? If you press Shift + F you get an FPS type camera and then when you’ve moved to wherever you wanted you press the left mouse button.

I’ve used Shift-F before but I just tried Blender 2.71 and woah! Shift-F here works just like the UE style navigation controls including Q/E for up/down/etc. I had no idea this was already released so thank you for reminding me to check Shift-F! In previous Blender versions the FPS cam was arguably clunky to use but 2.71 feels like the real deal.

BTW does anyone have any idea on the see-through artifacts I alluded to in my previous post?

I wanted to understand how the scale correctly when i export to Blender in UE4
I followed your guide, so i set up everything like is show in the " Unit Scale in Blender " part.
I also left the 1.0 value in the fbx exporter and when i import in UE4, i get this.

I just imported the standard blender cube.
I also tried to set the 50 value in the exporter and i have no warning and a 100x100x100 size, that should be correct i guess.
Why i get this warning? Where’s the mistake?

AFAIK the standard Blender cube remains unaffected even after you’ve setup your units because it was spawned before the changes.

Try scaling that cube by 100 and Ctrl-A -> ‘Apply Scale’ or just model something afresh. Assuming you’ve set the scale factor (under metric) to 0.01 if you extrude any face by 100 units that will work out to be 1 metre. Also turn edge length on (hit N’ in Edit Mode, look under ‘display’) until you get things working right so you can be sure that your units are correct in Blender first. I suspect your cube will read 2cm currently instead of 2m.

most of that information is very misleading, it used to be more accurate but someones changed it.

if your model is that small why does the edge you’ve highlighted say its 100M’s in length?, I think you might need to change your unit scale settings.

the default blender cube is only 2x2x2 units witch in UE4 is still 2x2x2cm, that’s why scaling up by 50 during export gives you a cube of 100x100x100 in size.

I think both of your issues is caused by how your setting up your units and/or scale, If you tell me how your doing it I should be able to tell you a way to fix it.

Hey Smokey13, the image from my post in August was a dummy model to demonstrate the issue of artificats with large clip sizes. I haven’t had any issues with my actual models at all as most of these are less than 2m so I suspect I read the more accurate version of the wiki.

My settings: Blender units set to Metric + Scale set to 0.01 for convenience + Clip size between 1mm to 10m (as opposed to the prescribed 1km) + leave scale untouched on export.

I’ve found skeletal meshes a bit more tricky but usually mange to scrape through after applying transformations/rotating about Z/use pose0 as reference pose in import, etc.

Hey I’m wondering if you can help me out. I’m kinda new to blender and UE4. I made a basic door mesh with a window in it. The first time i imported into unreal the texture came with it and also the windows tint color did put it was not transparent. So i went to change the alpha level(heard that might fix my transparent window) and now when I import it again none of my materials or textures are coming with it… not sure what I’m doing wrong but no matter what i try i cannot get it back. Also not sure if this matter but somehow i have 2 different uv unwarps one with the texture for the door and another thats blank for the windows somehow. for example if i have the uv editor open and click on the window it brings up the blank uv but if i click anywhere else the one with the texture appears. Any help would be awesome this is driving me nuts

Hi,

I’d like to add that if you want to work with powers of 2 then set the unit of measure to **none **followed by setting the **scale **to 128 and **subdivisions **to 8 under **display **within the **properties **panel. (Hotkey [N])

b6f410d362cc1065d812965e80e0b026aa23388c.png

Note: Bare in mind that any object you add will be twice the size as the grid scale. For example, if you set the **scale **to 64, then any cube you add (shift+A) will have the dimensions of 128^3. However, you must save it as the default startup file (ctrl+U) and reload the scene (ctrl+N) before the settings will take effect. And yes, same rules apply to subdivisions unless you have a reason for setting the minimum grid scale above or below a size of 2…

Hi. So what’s about LOD setup? Naming groups and meshes in the same way it’s used in Maya doesn’t seem work, even when i tweak Baked animations on export

245af706a28b5423224ff27d1aff6c69ecb39e8f.jpeg

Blender doesn’t support it except within their own internal game engine. It’s a feature that’s being worked on though…

The only option you have for now is to manually import each LOD individually within the Static Mesh Editor.

Details>LOD Settings>LOD Import

I have made rigged and animated a model in blenders and forgot to check that the scale was right till I had already rigged it so when I import it into unreal it comes in really small. Whats the best way to scale up the model without messing up the animations? I’m using lots of additive animations in UE4 and if I scale it up using the scale on export of scale up the armature in blender unreal notice its been scaled up and thinks that’s part of the animation so it adds it to the other animations so that way it ends up huge as soon as it starts playing any animations!

I have tried applying the armatures scale after scaling it up but that messes up my animations in blender… Any ideas how I should do this?

Hi, I know this is such a old thread but I’m having problems exporting fbx from blender 2.76.

Here’s the following error:

Failed to import ‘D:\FBXs\Asset_01.fbx’. Failed to create asset ‘/Game/StarterContent/Shapes/Assets’

After a rather long time, I have finally managed to get absolutely everything working when importing from Blender to Unreal. Noteworthy is something like the eternal Smoothing Group issue, which in fact is something really simple to fix: How do I fix smoothing group error when Importing mesh? - UE4 AnswerHub

Question: I’d like to assist in improving the Wiki page @

with multiple edits, tips and tricks. Is any one monitoring this thread able to let me in and edit the page?

I know this thread is for Static Meshes only, but the wiki brought me here and there is no related thread for skeletal meshes.

I would also like to assist in improving the wiki page (and the skeletal mesh page as well A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums)

I had never tried using skeletal meshes from blender until recently, and had a couple of issues (one appeared in a recent version of blender) and have easy fixes but aren’t mentioned anywhere.

The first but less troublesome issue is that in blender, forward is Y-, while in UE is X+, but this is not too bad you can just rotate the mesh in UE4 without much problems.

The second issue is with a new export feature in blender, that tries to avoid the 0.01 scale tweak by doing it at export time, while it doesn’t work bad, it introduces an issue when adding sockets to a skeleton (see screenshot).
bfcf021337e7803526b261a2c80561fe33db8682.png

The sockets appear scaled 100x and when using local translation in the editor the gizmo shows 100x the size, although it is not that bad, is a thing you can easily avoid by using the 0.01 scale tweak, see the screenshot below for comparison:

f1e55a31df6d7a8b5ba272cd46b327285f49cbd8.jpeg

Look at the socket size. In the image above the scale gizmo is not affected, but setting the translate gizmo shows a big big gizmo:

The third issue I had was trying to get root motion to work. It didn’t work at first because of the way maya/fbx works, browsing reddit and the blender issue tracker I found ⚓ T45368 Blender 2.75 FBX Export - Adds Extra Bone to Rig and https://www.reddit.com/r/unrealengine/comments/3q75xg/blender_276_root_motion/
It says that maya/fbx don’t have the concept of Armature that blender has, there are just bones that are children of other bones and there is a root bone (I’m not really sure about this, I don’t use maya) so when you animate a root bone in blender, you won’t get root motion in unreal because the FBX exporter adds a root bone that has the transform of the armature object in blender. This is not a bug in any way but is something you should be aware when doing animations. If you want to have root motion you need to animate the armature, not the root bone.

Sorry again if this is not the place, but is the link I found from the wiki, and writing it here maybe people will find this information easier. And I’d like to help with the wiki pages as well if someone reads this.

EDIT: Found out that can edit the wiki page, just had to log in again in the wiki. If anyone reading this would like to contribute, I created an article called “Blender” for posting anything relevant, and linked the other three existing pages talking about blender. @Fritsl here is the link if you are interested in contributing A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums

Hello. First off, thank you so much for contributing this! And firstly I want to express my appreciated for adding to the documentation.

After that, I have some suggestions. You could make some of the references to other topics (“Pivot Points,” “Exporting”, etc.) into hyperlinks.

Under the “Modeling Objects” section, you have a part that says “However, is recommended”. Just thought I’d help out showing the typo. Cheers. Thanks again.