[Solved] Unreal Editor loading stuck at 45%

Just installed Editor 4.25.1
Got stuck at 45% Loading ,when I tried to create a new project. CPU was running at 100%. (Nvidia GTX 1660)

  • killed the process with task manager
  • restarted PC, and created a new project again, this time with RAY-TRACING turned OFF

it worked for me.

Now I got another problem:
i was trying to open a project i have done with version 4.22 in version 4.25.1
its getting stuck at 95% loading (cpu running at 30%)
wondering what could be it…

It wasn’t stuck, it was rebuilding every single shader to support raytracing. If you leave it, it’ll eventually finish. 45% is always shader compilation.

95% is something different, but it’s still doing something. Let it finish, even if it takes a couple of hours.

I was successful in opening a new project - but when I tried enabling Raytrace it stuck at 45%. I have no materials in the scene.

CPU - i9-9900 coffelake
Geforce 2080 RTXi
​​​​​​​16 GB ram

Folks please read the thread before posting.

I’ve edited the title and OP to reflect the “solution”.

I had the same issue, but none of the suggested workarounds worked for me. However, I think I may have figured out what was going wrong.

By default, Unreal Engine saves new projects in the Documents folder. I had my Documents folder syncing to OneDrive. When I opened the project folder, I noticed some files had an icon indicating that a sync was still pending (even when the project is closed). They were TMP files, and even after waiting for a while, they never got synced. I wonder if Microsoft intentionally ignores syncing files with a certain extension, seems like that would make sense… but in any case, because they were marked as “sync pending”, they were essentially locked. When I tried to move the project folder outside of OneDrive (using Windows Explorer), it wouldn’t let me for the same reason.

I just ended up copying the entire Unreal Projects folder, moving it outside of Documents (and therefore outside of OneDrive). I was able to open the project it just fine afterward.

This isn’t ideal or user friendly, but your output logs should show the progress of shaders and other things being compiled. Even though the loading splash screen looks stuck, this should at least give you a hint as to what’s going on. It would actually be nice if this was made more obvious and not confuse people.

yeah i think i will create a hello neighbor fan game in unity…

Hi. My 4.26.1 stuck first at 39% but i add swarmagent to firewall and this help. But stuck at 45% and get BSOD… this is on Intel cpu on older pc work fine… any ideas? I try with OC and on stock and any changes always get bsod on Intel

Test pc
Intel i7 9700k
32gb ram
GTX 1060 6gb
Samsung 970 Evo pro

Amd fx8370
16gb ram
GTX 1060 6gb
Samsung 970 Evo plus

Quoting Amanyadav (Profile - Amanyadav - Unreal Engine Forums) “go to your project folder on your drive and rename config folder to config_old, thats it… now open your project and its done…”

This worked for me!

Im having the same problem.
How did you open disable raytracing to be able to open this I can tget it.

hi, I don’t know my way works for everybody, my device just works with version 2.23.1 blow and install 2.6.2 at first didn’t work and stop at 45% then I try to open one old versions project and worked after one time even I can create a new project.

Hi! I fixed the problem by uninstalling Incredibuild!

2 Likes

Like SamiMD, uninstalling Incredibuild fixed it for me.

I believe it’s normal for there to be some (even a lot of) shader compiling, but most alarmingly, the display was not updating (e.g. stuck at 1144 shaders left), even after a couple hours.

Turns out I had an old version of Incredibuild with no license and that was actively undermining the process by only allowing a single core, seemingly adding pauses between shaders, and causing the display not be updated. It’s great software, but only when you have many machines and are paying for it.

This was after many, many attempts, including (this may help you):

  • Deactivating virus real-time protection in Windows
  • Deleting the “intermediate” folder in the project
  • Consulting the log file for any weird information
  • Allowing it to run for hours (I believe it would have eventually succeeded, but it would have taken literally days)
5 Likes

Thanks, that was the solution :slight_smile:
I was getting ue5 to run without using raytrace but every time i activated it it got stuck at 45%.
Now that i unsintalled incedibuild i can enable raytrace and the shaders are compiling without any problems.

1 Like

hiiii everyone-love u all for your guids-finaly my problem solved by unistaling incredibuild

Also got stuck at 45%, but wating did no good at all. After over 18 hours it was still stuck at 45% (8226 shaders left to do).

The solution for me was to uninstall Incredibuild, and first after that I now can play the wating game that didn’t work before :wink:

1 Like

As of 4.27 and 5.0, the splash screen tells you that it’s compiling shaders rather than just displaying no progress. This should alleviatte the usability issue.

But otherwise, you shouldn’t even have Incredibuild installed unless you have one of their costly licenses and multiple machines. UBT already distributes work to all cores just as effectively - there is zero benefit using it on a single machine other than slowing down your compile times while it faffs around trying to find a license.

SO is there a solution or is everyone going to be posting their experience. It comes off as very condescending when you’re new to this and trying to learn this process. IJS

It depends on what the “problem” is. If you’re hanging at 45%, you’re probably building shaders, and it’s going to be a while. If you launch with the -log command line option, you can see what it’s doing while it’s doing it.

here is the solution :+1: