Download

Solution to problems with Blender

Hi Marcio Daniel,

Try the fix listed here:

https://answers.unrealengine.com/questions/23181/blender-export-and-bones-translation-doubts.html

Please let me know if that addresses the issue.

Hi Adam, thanks for the reply.

I don’t think this link provides the solution for my problem. My bones are already with scale = 1 and I’m using Unreal Engine 4.5. I found many similar links with the same problem I have, but many of these links don’t solve the issue (some people changed to the old version of the exporter, but it has some limitations, like I said before).

I really suspect this issue is on Blender, but, like we can see in the link on the original post (⚓ T41719 UE4 - Blender FBX Export to Unreal Engine 4 Bone Translation Error.), they are not convinced of that… so, I know maybe there is nothing to be fixed by the Unreal team, but maybe you can offer some support to them, I think everybody wins this way. Otherwise, we, Blender users, will not be able to properly use the tools…

Hi Marcio Daniel,

I can completely understand the frustation with this. As a blender user myself (albeit still learning) I can tell you that working between the engine and blender has been interesting. Can you show me a screenshot of what you are experiencing with your mesh so I can get an idea of what to look for when I port over a skeletal mesh? Any information that can help reproduce this on our end may shed light onto whether this is a UE4 issue or one more in line with Blender.

It seems like a blender bug in the latest version. When you use the 2.7 everything works fine + I think morph targets are already included in that version :slight_smile:

But I will try out some stuff -> probably I can find a workaround :wink:

I’d love to see an easy, reliable workflow from Blender into UE4.

Just delving into it a little has been so frustrating, it has made me very hesitant to do modeling work and frustratingly so when I’ve had to.

To have a way to get models in & out of Unreal Engine in a reliable way so a person would know if it was something they had missed or done wrong rather than wondering if it was something to do with the exporting of their content, would be bliss.

Adam,
Here is a screenshot of my character in Blender:

c3f0d7f88cfa178fe20988823bb88960f31f9622.jpeg

And here is the same character in the Unreal Editor:

812006312c685fc174ab0b5d914729a674f8e4f2.jpeg

Wireframe:
c6b12d6485821fc6366499bdaf228a0bc303567a.jpeg


Do you see these “things” on the head of the character? Their positions are wrong. Her ears are wrong too, but it can’t be seen very well.

A few observations:


fighter5347,
Blender 02.70 uses the old ascii exporter. I confess I read some stuff now and the morph targets apparently works with this version (I thought it doesn’t, but maybe I read it wrong before)… but still doesn’t work for me, I downloaded Blender 02.70 but I can’t make it work (it exports the shape keys and Unreal imports the morph targets, but without animation).


  • You can move this topic if it is in the wrong subforum, I posted it here because I was not sure how to talk about it with the Unreal team, but now I see it is a bit “technical” and maybe it belongs to another subforum.

Sorry for the flood, but the previous post has a lot of informations. I didn’t edit the post because I think it would become more confused.

Here is the .blend file:
https://drive.google.com/file/d/0B0DingZbOrwXeHM5RWRuOEJsR1k/view?usp=sharing

These are my export configurations (BEFORE export, select the mesh AND the skeleton, because I checked the “Selected Objects” option to avoid export gizmos).

(The nigthly builds of Blender has some new options, like “Bone primary axis” and “Bone secondary axis”; but none of them fixes the issue).

Update: now, my animations worked using the old ascii exporter… I have NO IDEA what I did, but it works now. So, finally my character is animating like I want. :slight_smile:

Anyway, I think it’s not an easy workflow, right? So, to make this thread useful, I will give my feedback (or a suggestion): add the Blender workflow to the official documentation (only 3dsmax and Maya have the workflow explained in the docs of the FBX pipeline). Unreal is used by many indie developers now, so I think it will be very useful.

Which exporter have you used -> from which version? :slight_smile:

+1 for this. This can be very benefitial, because many indie devs gets frustrated by the workflow of blender to the UE4 -> many people ask me stuff on skype which could be easily noted somewhere (where it can be found easily) -> probably I will write a document with the most important stuff :smiley:

But here is a short overview of the workflow:

+1
Absolutely, Blender is such a wonderful software. Epic should make an effort to make workflow from Blender to UE4 painless.

Blender 2.72b, FBX 6.1 ASCII

But I can’t reproduce what I did yesterday :(, I am trying to export new animations today, but without success (shape key animations are not being exported, again). And I’m crying.

Hmm ok, then I will try some more stuff…probably I will find a workaround (now as you uploaded your mesh it will be easier to reproduce your problem) :slight_smile:

A brief description of the issues, if my previous posts have become confused:

  • Blender 2.72b, FBX 7.4 Binary exporter: shape key animation works fine, but some bones have weird translations when animated
  • Blender 2.72b, FBX 6.1 ASCII exporter: bones are ok, but I can’t export shape key animations (I exported successfully once, but I don’t know how…)

The shape keys animations are disabled in the file I uploaded. Here is a new file with these animations:
https://drive.google.com/file/d/0B0DingZbOrwXOFRmU3RWOC0zMGM/view?usp=sharing
(It’s actually the same file, but this one has the shape key animations enabled and configured on NLA Editor)

Just a short question:

Is this how it should look like? :slight_smile:

b46a52bddc9559faa4021b4648d6c3758d3a4b7a.jpeg

Because when I import it from blender 2.72b everything works fine -> when the upper picture is how it should look like ^^

Yes, that’s it. Did you use the binary exporter? Did you notice some another bone issue (like a finger far away from the hand)?

If not, tell me your secret. =P

Are you using Unreal Engine 4.5?

As far as I have seen, everything works correct -> I will send you the uasset files when I’m back home :slight_smile:

I’m using the 4.5.1 version of the engine + blender 2.72b + the included fbx exporter (File-Export-FBX)

One more question: did you import the animation? All bone issues only happen with animation sequences. If you import the FBX file without animation, all bones are imported correctly.

Yep, the upper picture shows the idle animation :slight_smile:

Just one more thing: :stuck_out_tongue:

Can you try the first file? (https://drive.google.com/file/d/0B0DingZbOrwXeHM5RWRuOEJsR1k/view?usp=sharing)

It’s actually the same file, but this one has a “walk” animation enabled (you can also use the other file, if you change the action on NLA editor or export all actions, but I think it may be easier if you download this file).

Depending the animation, the issue of the bones can appear or not, and now I am thinking maybe it’s not visible on the second file (the idle animation). Actually, I uploaded the second file only because it has the shape key animations and I have the other issue (can’t use shape key animations with ASCII exporter, although I made it work once).

Ok, now I know why it worked with the idle animation :stuck_out_tongue: → havent found a fix for the walking animation, but when you select your skeletal mesh - Object - Apply - Location/Rotation/… it should fix the problem with the deformed hands.

As a temporary solution you could do a right click onto the bone in the skeletal mesh editor - “Recursively Set Translation Retargeting Skeleton” But I will try out some more stuff :wink: