'Simple Move to Location' doesn't move my character

The “Simple Move to Location” is using the Pathfinding from Unreal which only works in areas which have a navmesh.

Do you have a NavMesh Volume set up in the area you want this movement?

Quite simply, this does not work, and I have no idea why this might be or where to start working it out.

16213-capture.png

Hi SirYakalot,

If you are trying to move your player character, you will want to use “movement input”. The “Simple Move to Location” node is designed for navmesh movement as Erasio stated, either as a mouse click move similar to diablo or AI movement.

yes, I do.

I’m not trying to move the player character. but what differentiates a player character from a non-player character in terms of set up?

The main difference is that the non player character has no manual input being tied into it. This causes it to rely on the navmesh for pathing instead of having a player to tell it where to go and what to do. Do you have a behavior tree set up for the AI?

no, I don’t. I was driving it through it’s standard blueprint. Can you recommend a good resource to learn about the behaviour tree stuff? (not actual behaviour trees, I know how they work etc) thanks!

Hi SirYakalot,

We have a great tutorial on AI movement via BT here:

Let me know if this helps you out!

im having same issue.
this stuff used to work fine, not sure what is different now.

Hi axelZellalex,

Can you show me how your blueprint is set up?

my level has a nav mesh
I have a class derived from Character, and another derived from AiController
when I print out my Character’s DefaultController it is of class AIController
in Character I have tried both in the update tick and event begin, the same setup as OP’s screenshot

Have you tried the AI bot tutorial listed in the comments further down the page?

ye ive done that tut before and it works really well

but this setup should work without that right ?

it used to…

seems a huge over kill for MoveTo() to work…

the only difference (i can see) between my current setup and previous ones are : i have no skel mesh

But i can’t see that being an issue

It depends on the rest of your blueprint and how you have the executions set up. Do you have a stripped down project that I can take a look at? If you are comfortable with uploading it to an FTP server I would be happy to take a look and see what may be occurring.

hi adam, what do you mean by the “rest of your blueprints” and how i “have the executions set up” ? - does this mean there are other areas I need to look at ? As I said I thought i needed Character, AiController & NavMesh for this to work (which im sure is all ive had before…)

I thought, with MoveTo(), it was a simple call ? i tried it in update tick() and at the begin level() event

i dont really have a stripped down version of the project

Hi axelZellalex,

I mean that in the image shown I can only see two blueprint nodes, In Sir Yakalot’s image, I cannot see how he has the rest of this particular blueprint set up, what nodes he is using that may be interfering with this, what executions he has set up, etc. If you could show me your blueprint that has these nodes being executed, I may be able to see what is occurring.

hah! sorry adam, i knew you meant the literal rest of my blueprint… but i wasnt sure what else i could show you. it is (or was) literally linked up as : Event Begin Play → FindLocation() → MoveTo()
i can try and set it up again and get you a screen shot… but… that’s literally all youre going to see :S

adam! and everyone, i apologise for wasting your time(s). i have a horrible feeling it was because the vector being passed to MoveTo() had a Z location which was not on the floor (ie 0) - just doing some further tests

I had the same problem before. I found that a part of the character mesh is out of nav mesh volume, then I put the whole character mesh in it, finally it worked.
Hope it works for you.

Well you didn’t waste my time, literally this comment solved my problem and I wouldn’t have figured it out if you hadn’t struggled with it yourself. And thanks for coming back and stating what the issue was!