Shader compiling. Causes crash after updating to 4.13

Hi there

I having an issue with my project I updated from 4.12 to 4.13 and the shader counter is going down to 530 and then crashing. It loaded fine the first and now it wont stay open long enough

[d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\core\private\misc\outputdevice.cpp:421]

PLEASE HELP !!!

and when i try and load the 4.12 version is crashing instantly

Hello cplandy93,

I would try deleting your Saved and Intermediate folders located in your Unreal Projects directory for the 4.13 project in question.

Can you also provide me with your full crash logs from the crash report generated?

For information on how to locate your logs and any additional information we might request, I highly suggest taking a look at the How to Report a Bug sticky post on the forums.

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

Hi there

when i tried to delete the folders it removes all my whole landscape and assests used

and which one

Cheers
Andrew

I will need the diagnostics.txt, minidump.dmp, ProjectName.log.

I will also need steps so I can reproduce this crash on my end in a new blank project.

Thanks,

Andrew Hurley

Hi there

C:\Users\Andrew\AppData\Local\Microsoft\Windows\WER\ReportQueue

i look there for reports but the folder is empty :confused:

Cheers
Andrew

So I need your ‘dxdiag’ and if you could get the crash to produce the Crash Reporter Client window, you can copy the callstack, MachineID, and Epic Account ID so I can search for the crash on my side.

Thanks,

Andrew Hurley

Here is the crash window log

where do i locate the ‘dxdiag’

here i the crash window

MachineId:67D3D783490F52BC8A70EE96B3012C0C EpicAccountId:00fa5e8191fa48c9a0eb73d8d5674476

Assertion failed: Canary != FShader::ShaderMagic_CleaningUp [File:D:\Build++UE4+Release-4.13+Compile\Sync\Engine\Source\Runtime\ShaderCore\Private\Shader.cpp] [Line: 440]

UE4Editor!FEngineLoop::Tick() [d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\launch\private\launchengineloop.cpp:2843] UE4Editor!GuardedMain() [d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\launch\private\launch.cpp:156] UE4Editor!GuardedMainWrapper() [d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor!WinMain() [d:\build++ue4+release-4.13+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:202] UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] kernel32 ntdll

as for the dxdiag. where is that located ???

Cheers Andrew

found it link text

Hi there

Ive updated my drivers last week and i just that seen that the report was from a year ago :confused:

i am unable to reproduce the crash as ive tried everything to open it in a black project. i add all the assest i used from the market place separately into 4.13 and then tried to move my map over and that is whats causing the crash. it comes up compiling shaders and then it stops…

when i was working on the project in 4.12 it was going fine when i saved it and work on it the next day it just stopped opening all together. but on the crash report window it was blank.

Cheers
Andrew

ive just released that ive sent you the wrong dxdiag report.

when i search dxdiag in the search window it took me to my last year project

sorry for the inconvenience

looking at my project now and i dont see the file.

Cheers
Andrew

how can i find the file for this project ???

Cheers
Andrew

So looking at your crash it is hard to tell what is causing the issue, but it definitely has something to do with rendering code and a material shader issue. I have noticed that your graphics driver is about a year old, and you will want to update that as this could be what is causing the crash.

Do you have anyway to reproduce this in a new blank project, or steps so I can move from 4.12 to 4.13 and get the crash to occur in that way?

You also mention you cannot open you copied project in 4.12 or 4.13? Do you recall when this started to occur and what changes you made before it started happening?

Thank you,

Andrew Hurley

Unfortunately this crash seems very specific to your map which seems corrupted. Your 4.12 version might have a backup of the map from an earlier version which you can find going into your Unreal Projects/YourProject/Saved/Backup directory. Check the date and time of the file to see if you have any earlier versions of your map you can load.

Unless we can reproduce this issue on our end, or have some steps to reproduce the crash there is not much in the way of entering this as a bug in our system as it deals with a very case specific crash that is caused by something corrupt in your map.

Thank you,

Andrew Hurley

Unfortunately the map is lost due to opening it. cause i deleted the saved and intermediate data and forgot to back it up.

for the backup file. it was lasted back up on the 29/09/2016

Cheers
Andrew

Hi there

sorry for the late reply been busy with Uni

how do it get the dxdiag for the 4.13 project as the one i sent is from last year and i only seen this when i looked at the Graphics card that it was using

and ive lost the 4.12 version because i deleted the saved and immediate folders and forgot to back up :’(

cheers
Andrew

Your ‘dxdiag’ or direct X diagnostics is actually not related to your projects, but rather provides information on your computer like your operating system version, your graphics card, your processor, drivers and driver dates, etc…

This might be one of those hard learned lessons where you make sure to create a copy before deleting any folders or files within your projects. This is generally the case when working with anything that is important and you believe deleting the files/folders will resolve the issue.

Unless you can load the backup in your 4.12 version then there isn’t much in the way of anything I can do. If you haven’t emptied your recycle bin/trash then you might be able to restore the deleted items that way.

Are you unable to open the 4.13 version at all, and does it give you the crash whenever you attempt to open that map/level?

Thanks,

Andrew Hurley

Hi Andrew

Again sorry for the late reply :confused:

and yes it does please see the file

link text

As I mentioned before, unless I have a way of reproducing this crash on my end there is not much to report.

I did open the logs for the most recent crash you are getting and noticed your drivers for you 980 TI were a little out of date. Currently the most stable drivers for that series of cards is 372.90 Released 9/21/2016.

Is this a VR project, and do you have the HMD connected while you are attempting to open the project map?

Thanks,

Andrew Hurley