Download

Root Motion Extractor

**Update 2.0.5

  • Removed the precision slider as it was useless and was causing inconsistencies. Instead, the curve key density now is based on the amount of frames in the animation.
  • Implemented a Curve Multiplier variable that let’s you alter the curve’s value.
  • Implemented “Create In-Place target copies” which works only for bulk extraction and allows RME to copy the source file to the target directory, disable Root Motion and Force Root Lock on it to make it as an in-place animation but only if there’s no target file available in the directory.**

Hey, awesome plugin!

Were having a little trouble compiling the latest version: what is this **UE_4_20_OR_LATER **macro in RootMotionExtractor.Build.cs?
Where is this defined?

Should:
#if WITH_FORWARDED_MODULE_RULES_CTOR
#define UE_4_16_OR_LATER

endif

Be:
#if WITH_FORWARDED_MODULE_RULES_CTOR
#define UE_4_20_OR_LATER

endif

Thanks!

Hi, thanks for the feedback.

**WITH_FORWARDED_MODULE_RULES_CTOR **came in with version 4.16. We’re checking for it only to provide some backwards compatibility. We just identify that we’re equal or above version 4.16.

I don’t believe UE_4_16_OR_LATER it’s even used by the plugin anymore.

**UE_4_20_OR_LATER **is used as of https://docs.unrealengine.com/en-us/…17#programming

Where “UnrealBuildTool now defines UE_4_X_OR_LATER macros for every UE4 version greater or equal to 4.17 when compiling .build.cs files (eg. UE_4_17_OR_LATER, etc…).”

Can you let me know the error you’re getting?

UE 4.21 is now supported.

As of today i opened a discord server for discussions and support for this plugin. https://discord.gg/v4D42Vp

Very interesting! Do you mind posting a simple example where the speed curve value is sent to the Max Walk Speed? I can’t find a way to connect these two items… the only tutorials that are using animation curves explain not very useful stuff, like scaling player head.

Update 2.0.8

  • Compatibility with UE 4.23
  • Always use Animation Raw Data

Why do some animations fail? I have an animation where the character moves backwards a few steps and it won’t work on that one. Is it because it would be negative speed?

Hi, how does it fail? Are you sure those animations have root motion enabled? There is no reason for it to fail on backwards animations.

Yes, it has root motion enabled and it gives me a message that it it failed. It’s not an “in place” animation, because the character moves during the animation if Root Motion is disabled and snaps back to the start position.

It’s the Sword_Block_Left_Shield animation from the Kubold Sword and Shield anim-pack.

Edit: You know what? I just tried it again and it worked this time. Maybe Root Motion wasn’t enabled and I enabled it while trying to troubleshoot.

Hey, glad it’s sorted out. Have fun!

I used this plugin without issue for 4.21 but having updated for 4.22 support it says “Extraction successful for 0 file(s)” trying to process the animation I have selected.
If I add a bone to capture then it can do that and completes successfully unless the named bone is “root” in which case it doesn’t extract again.
I’ve tried to debug through the code but its not clear to me the problem.

Root Motion Extractor 2.0.9 is Live! (05/04/2021)

  • Fixed some UI bugs
  • Fixed a bug where RME wouldn’t correctly create Target in-place copies.