Problems downloading the engine

Hi everyone,

after I just upgraded my mainboard and CPU I’m now having major trouble reinstalling UE4.
I have a 28 MBit/s internet connection, however the launcher downloads with around 100 - 500 KB/s and that drops to 0 constantly. When I look at the ethernet throughput graph in the Windows task manager, I can clearly see lots of very short spikes where it downloads and then goes back to 0.
All other applications that require internet access work just fine, only the Unreal Launcher is causing trouble. And what’s even worse: Whenever Unreal is downloading (or attempting to do that), my internet connection becomes unusable or super slow in other apps as well.

Maybe also worth mentioning: On several of my attempts to get the download to work, the launcher asked me to subscribe. I’m currently not subscribed but have downloaded the exact same versions of UE4 in the past when I was subscribed :frowning:
Also, I’ve been wondering if it might be the Killer E2200 NIC on my new mainboard that’s causing these issues?

Anyways, after some searching I haven’t really found a solution here or on the wiki, so I’ve created a verbose log:
Verbose Log

Any help would be appreciated! :slight_smile:

HI Daniel,

Thanks for uploading your Verbose Logs. I will ask our Launcher team to look through them.

You may have already attempted these, but if you haven’t, try the trouble shooting steps linked below.

Thank you!

Yup, I’ve tried those and, unfortunately, they didn’t change anything.

I used UE4 long time, but now 2 months I can not use the launcher. I click as shown in the screenshot, the lights show “please wait” but then again “installation”

I’ve tried everything on the website to download button does not work. I tried to download using different ISPs, and even across different computers but nothing helps. I wrote in support, but for the second month mene say wait a little longer

Here is an example:

Hey Daniel W,

Apologies for the inconvenience, we’re currently tracking down and debugging some issues with our http downloading code (and being tolerant for packet loss etc), we don’t have any new updates yet, but hope to soon. Is there anything special about your connection? (Proxy/firewall/etc) Looking at your logs it looks like most of your downloads finish pretty quickly (000000E61019B900 - that request downloaded 8MB in about 3 seconds), were you updating from an earlier version of the engine or was this a fresh install?


Hi adndima,

Looks like your issue might be unrelated. The first screenshot you posted looks like is no longer valid. Where you able to download the msi/dmg installer and had problems downloading the engine? Or were you having problems downloading the installer in the first place? Thanks for your patience.


Hi Carlos,

actually there’s nothing special about my connection at all. No proxies or firewalls (except for the Windows firewall which is set to not block the launcher). The thing is, I should be able to download files with 3,5 MB/s, so 8MB in 3 seconds is not that bad. However, what usually happens is that it starts out fast and then breaks down all the way to 0 or a few Bytes a second. And then it jumps back and forth between 0 and 100-500 KB/s. It looks as if it receives a few packets and then takes a break or something, although I have no idea what’s actually going on. Even if it just downloaded with 500 KB/s I’d be happy if it didn’t block internet access for all other apps in the meantime :frowning:

I’ve done some more testing. Most of the time when I start a download it’s fast for the first 10-30s and then slows down etc. Also, this affects both my desktop and laptop computers. And finally, as I’ve mentioned before, only Unreal is affected, everything else works fine. Trace route and pathping to look ok, if that helps.

This was a fresh install. After the hardware changes, I formatted my hard drive and reinstalled Windows, so all old data is gone. I downloaded the latest version of the launcher and installed it.

This is what the Windows Resource Monitor shows with the launcher process checked (the orange line is the launcher):


I changed the DNS address and I have all earned

Hey Daniel,

Thanks for the added info! One thing to note is that our patching system doesn’t download everything up front, we start processing information and recombining chunks as we download. The download speed indicator in the launcher is just network bandwidth over time, and doesn’t take into account times where we wait on file writes. I suspect the valleys you’re seeing in download bandwidth correspond with times when we’re processing patch data. We’ve had several discussions recently about working on a better overall solution both in terms of how we handle downloading and how we present the data.


EDIT: Okay, this is kind of embarrassing :frowning: There was some kind of firewall issue. With a recent firmware upgrade, my cable modem (a Cisco EPC3925) changed some of its internal firewall settings. It activated the IP flood detection and apparently believed launcher downloads to be an IP flood and blocked them half the time. I switched it off and for the moment everything works fine. Thanks again, Carlos!

Now irrelevant information below…

Thank you for explaining this. But shouldn’t an i7-4790K CPU and an SSD be fast enough to process a few file writes? In the past (i.e. a few months ago), this has worked flawlessly. Also, as I’ve mentioned above, the launcher sometimes won’t even let me start the download, telling me to subscribe - I am subscribed for the next 12 months via an educational license. And even if it’s actually just writing files, why do all other applications lose their internet connection as soon as Unreal starts downloading, even though it’s only using such a small part of my bandwidth?

Thanks a lot for your help!