Download

Please don't launch SteamVR with the editor every time, it was already annoying in UE4

You’re entirely wrong. The engine has this plugin flagged as EnabledByDefault. You can disable it by going out of your way to edit that, but it’s enabled by default.
You might not have noticed if you don’t have a VR headset, as you won’t have SteamVR installed, but it’s really incredibly easy to reproduce; have SteamVR installed, have a clean engine install, start even just the project browser, SteamVR will open alongside it. It’s done this since SteamVR support was added.

2 Likes

My ol’ Grad Student Buddies (who’re scattered across the game industry now) collectively wanted to peek at UE5 together in a Discord Stream.

Everyone groaned when Steam VR launched itself.

We all hate it. We’ve hate it currently in UE4. Makes no sense being a default considering VR projects aren’t even close to the majority of new games being developed.

Agree with the earlier comment about someone going through old plugins and reviewing which should be enabled by default or not.

1 Like

Navigate to “Path_To_Install\UE_version\Engine\Plugins\Runtime\Steam\SteamVR”
open “SteamVR.uplugin”
edit line 13 “EnabledByDefault”: false,
save
profit.
All new projects won’t launch with it enabled.
IIRC, you can also move the steamVR.exe to another folder, so anyone developing for VR that needs the plugin but hates having it auto-launch, can then just manually launch the moved steamVR.exe when they want to test.

1 Like

I’d just like to let everyone know that it’s not as simple as just defaulting the VR plugins to False.

That said, we’re aware of the annoyance it can cause and we’re working on a solution. There are several good tips in this thread on how to disable the behavior in the meantime.

2 Likes

Generally, as a rule of thumb, if you want to get people to your side, it’s a lot more important to say “why”, not just what. :slight_smile:

Just acknowledging the issue and letting us know you are working on it is of course great, but what would be even better is if you gave us at least a very basic short list of reasons it’s not as easy as just turning the plugin off by default.

And not just here, in this tread, but in general, on the entire forum :slight_smile: Not only saying that X is not that simple but also at least roughly specifying why really goes a long way in terms of building better community engagement.

1 Like

You can also go into UE% folder to plugins Runtime and delete the steam vr folder it will stop it. Also as a side note UE5 will not open if Steam VR is started at launch. If you are having issues opening UE5 and you have it opening steam vr at same time you will need to follow step mentioned to stop it from crash at start.

EA2 just brought this back yet again… urgh

Might you elaborate? I’m a VR dev, and even I would like the default for SteamVR to be “off”.

All of these tips on how to configure your current engine install to default to off are great, but need to be configured on every engine update. Not really a solution to the annoyance, other than for a couple of months.

Seems to me that the majority of projects wouldn’t want this enabled anyway, but I’m open to hearing why this could be an issue.

Kinda pointless for me to answer here since i “liked” the OP’s post.
But I would also like this to be default behavior in the engine.