Player foot floats over the floor? Help me Plz?

Hi im yousing ue4. And my characters foot always floats over the floor. Do you guys have any fixes?

Here is an image how it looks:

maybe the mesh is above capsule component

Yes ive taken it up and down nothing works still floating

mesh is at same level

Hello, have you checked your charactermesh’s position in the viewport?

What does your IK logic look like? Maybe there is extra offset being added. Also, what does your skeleton look like? Maybe the joints are positioned below the foot.

  1. Disable IK and try on flat surface.
  2. If problem persists, open character, select collision and in details: show collision in game. If collision is touching floor it’s the mesh
  3. If it’s the mesh, check if mesh is above bottom of collision (zoom in real close, also, do use ortographic mode)

If I’m not mistaken, it’s gotta be one of those.

If the problem is

  • IK: check if offsets are added or if skeleton points from whick IK is cast are correct
  • collision: check if floor has correct collision
  • mesh: lower the mesh

Thank you so much, these troubleshooting tips helped me narrow it down to IK likely being (partially) the culprit in my case. I found that if I turn off IK and lower the pawn down by a little extra on the Z, that squares it with the ground. It still hasn’t solved my problem though, I’m afraid.

I’ve used some custom animations (Movement Animset Pro) which I retracked using the standard UE4->UE5 retracking to duplicate & retrack the SKM_Manny skellymesh. In the Sequencer, all the new animations look great an IK tracks to the floor. But when I look in the ABP preview, or in-game, the pawn is floating.

I can’t imagine that the default IK rig for one of the default SKMs would be faulty, so it has to have something to do with the animations. Right? But then again, everything looks fine in the Animation preview/Sequencer.

If I set the idle animation to one from the asset pack, the pawn floats. If I set the idle animation to the stock UE5 one, the pawn doesn’t float.

This is all on an otherwise vanilla UE5 SKM_Manny, I’ve no idea what to check to fix this, or even what troubleshooting steps to take next – and I can’t find any information about this problem elsewhere – this is the first post I’ve come across with this problem.

Im with the same problem, and I think maybe the same animation pack Mocap mobility pro. Did you solve this?

Nope, still have the same issue with Movement Animset Pro (and the free Mocap one, forget it’s name). More info here: Floating IK feet (but not really); what am I doing wrong?

There’s something wonky with IK and animation retargeting from the (old?) UE4 mannequin to Manny, unless I’m just stupid and not doing it right.

Just a guess but the capsules half high could be pushing the character component upwards while on the stairs. Turn on the capsules visibility to see if this is the case.

Most tutorials using 2 bone IK changes the capsules half high to account for stairs as well ramps.

It’s a good guess, but mine happens on default Manny tps BP, skeleton, and ABP, save for changing one animation. No tutorial necessary, IK is set to work out of the box with Manny and Quinn in UE5, but… /gestures at floating feet/

This is so annoying! :expressionless:

Looks like I have found solution :slight_smile:

Update: I have updated the solution with full explanation of the problem, and solution on how to fix it.