Parallax Occlusion problem

Hello! I had a problem with the node of the parallax oссlusion, and yet I can not find solutions. If you look at my video example, UE 4 Parallax Occlusion node problem - YouTube
you might think that the heightmap is not connected to the shader. If I disable the normal map, the shader generally shows a flat surface. At this moment my shader work like in this tutorial Unreal 4 Materials 11 Windows with fake interiors (Bump Offset) - YouTube
But it’s not what I need. I wanted to make a shader to simulate masonry. On this page: New 4.9 Parallax Occlusion Mapping Node Problems - Rendering - Unreal Engine Forums
I found a similar problem, but could not understand which the variable (int i, which is needed assign a value “0”) they mean. I am attaching a texture for this test shader and shader structure, which is made by several different lessons.alt text

Double check what you are using as an input to HeightMap Channel. You’ve misplaced one of the pins there on your screenshot. It should take a vector4 not vector2 Also mind reference plane value.

Today I made a new shader according to this lesson.

Nothing still does not work, even though everything seems to be right.

Also, I tried to turn off the heightmap, and compare the result with the attached map.

There is no difference, beyond that height map I have is not working. At the same taime shader with tessellation it works fine.

However, I had a suspicion that perhaps the case in the settings of the graphics card or computer. I tried to test the parallax shader in Unity 3D, and here And here that I’v got


When I change the height parameter, the plane with the bricks just a little pushed back, like in Unreal Engine, but the effect of the surface with dimples is not obtained. Could be some setting that I have not included and therefore parallax occlusion “does not see” height map?

Excuse me, node channel height map I just forgot to return to the correct state. Just trying to change the settings to see whether any effect. Constant tempAAStepmult I put in the correct value, but it has given nothing. In general, if I put a constant Reference Plain to 1, then I can put any value in the height channel of parallax node, but it does not affect the rendering of a shader, as if it were an ordinary material with normal map.

POM material function has quality/platform switches inside. Try bypassing them.

Thanks for the answer! I tried to do it, but for some reason it does not work. Maybe I have to ask Ryan Brucks how to solve my problem (if he is not too busy to pay attention to this profane as I am :-D)