OSX -Matinee Recording, Window can't be closed

When recording the matinee, the video goes fullscreen and can’t be closed.
Expecting to use ESC key to close.
OSX 10.10.3

Hello rotwang,

Would you mind providing me with some simple steps to reproduce the issue you are experiencing?

Typically if I would like to create a video recording using Matinee, I will use the ‘Create Movie’ button instead of the ‘Record’ option. Be sure you have a director track set up as well. Using the ‘Create Movie’ button will allow you to have greater control over the size of the videos recording.

Create Movie Options

34753-movierenderoptions.png

You can also set the resolution for your recording in this dialog menu. It is hidden by the dropdown in the image. For even greater control over your cinematics you can set options within the details of the Matinee actor within the level.

Matinee Cinematic

Using these options correctly in conjunction with one another will yield some good results. I have also added some simple blueprint scripts for even greater control over playback.

Matinee in Blueprints

Let me now if you are still having issues.

Cheers,

Andrew Hurley

Thanks for the quick and comprehensive answer.
I used the Reflections demo with ‘Create Movie’ button, selected Cinematics (Cinematics => does this mean fullscreen option?). I couldn’t close the fullscreen window with ESC. Tried other keys to no avail.
I’m asking for a duration and optional start field in that ‘Create Movie’ dialog which would allow to render specific shots.
From the bluprint above, I can see, that the X key should quit, don’t know, if the Reflection demo has this implemented.
Thank you for your time.

What is the resolution you are setting when using the ‘Create Movie’ option?

All of what you are requesting is already implemented. For cutting to specific shots, you need to use the director track (used for cinematics). You can also set the ‘Force Start Position’ of the Matinee actor.

Force Start Position

If you would simply like to exit the cinematic, bring up the console command window (~) and type ‘Quit.’ If you notice, I set this to my ‘X’ key in blueprints. Acts like an escape key.

Thanks,

Andrew Hurley

Andrew, thank you, force start position is useful.
I still consider “Window can’t be closed” as a bug. On my Mac the tilde is alt-n and does not close the window.
“Simply bring up the console command window (~) and type ‘Quit.’” might be fine from a programmer’s perspective, but not for a user who plays with the Unreal Engine and suddenly has a blocking window and can’t move the mouse outside this window. The window close buttons are not reachable in this mode.

There is a great turorial for Matinee:

The track defaults to 5 seconds. I would recommend that Create Movie only records this actual length and does not record forever.
Hope this makes sense. From a user experience those things are ‘expected behaviour’.
Thank you for your time, I also invest mine to make this amazing engine even better.

Hey rotwang,

We are currently in the process of revamping the Matinee tool with another feature called Sequencer. This will increase the ease of use and give users greater control over their matinee cinematics and recordings.

In the meantime, you can add a simple node ‘Execute Console Command’ bound to a key so you can ‘Quit’ the matinee at the exact location you would like via key press. Then bring it into a video editing software (assuming you were doing this anyway) and shave off the ends you do not want to have in your final edit.

Similarly, you should be able to set the resolution to fullscreen. Something like, “r.setRes 1920x1080f” will run in the resolution at fullscreen.

Thank you,

Andrew Hurley