Opening old Widget or new Widget brakes editor

Hello,

I am currently working on a UI for my project in 4.5. But every time i try and open any widget in the editor, the whole editor crashes.

Any advice or information would be much helpful.

Hello Endrophes,

I have a couple of quick questions for you to help narrow down the issue that you may be experiencing.

Quick questions:

  1. Can you reproduce this in a clean project?
  2. If you can reproduce this in a clean project, can you provide accurate steps to reproduce the issue?
  3. Did this issue start to occur after updating the engine? (Example: Update from 4.5.1 to 4.6)
  4. Can you provide us with your dxdiag?

Please note: Thank you for the information provided. However, it would be more convenient for us in the future if when you are posting a crash report if you simply copy and paste it into a notepad and attach it to the question.

Hello Triplett,

I can reproduce the issue in 4.5. The crash happens when I reorder the layout, go to the graph, come back to designer and click on one of the widgets.
Here is the call stack: (Note: Thanks for the heads up, Is there any way you would like this formatted in the future please let me know)

MachineId:C419A67848477E743B526D8BC5D08A0D
EpicAccountId:929630d19fa44b4994f2376b8920748b

Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.5\Engine\Source\Runtime\Core\Public\Containers\Array.h] [Line: 536]
Array index out of bounds: 0 from an array of size 0

KERNELBASE + 37901 bytes
UE4Editor_Core + 3174852 bytes
UE4Editor_Core + 1677512 bytes
UE4Editor_Core + 1566866 bytes
UE4Editor_UMGEditor + 1174702 bytes
UE4Editor_UMGEditor + 896058 bytes
UE4Editor_UMGEditor + 641121 bytes
UE4Editor_UMGEditor + 1364659 bytes
UE4Editor_UMGEditor + 1352966 bytes
UE4Editor_UMGEditor + 1212892 bytes
UE4Editor_Slate + 820207 bytes
UE4Editor_Slate + 755243 bytes
UE4Editor_Core + 2505954 bytes
UE4Editor_Core + 2450091 bytes
UE4Editor_Core + 2510873 bytes
UE4Editor_Core + 2438466 bytes
user32 + 105425 bytes
user32 + 104666 bytes
UE4Editor_Core + 3157718 bytes
UE4Editor!FEngineLoop::Tick() + 3106 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launchengineloop.cpp:2111]
UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launch.cpp:133]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:201]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Hello Endrophes,

I was unable to reproduce this issue following the steps that were given. Just to be clear, did you mean that you switched up the hierarchy of the widgets when you said “reorder the layout”? When you say that you can reproduce this in 4.5 did you mean 4.5.1?

Hello Triplett,

Yes I am currently working in (4.5.1), sorry for the confusion. Here is the layout that i use that caused the crash:

Hello Endrophes,

I am still unable to reproduce this issue. Could you please provide your dxdiag?

To run a dxdiag report follow the steps below:

  • If you are running Windows XP or higher go to your task bar.
  • Click on, “Start Button”.
  • Click on, “Run”.
  • In the pop-up window enter dxdiag and hit ok.
  • The DirectX Diagnostic Tool pop-up window should appear.
  • Click on, “Save all information”.
  • Save As" window should be present.
  • Click on, “Save” (The file should be saved to your desktop as dxdiag.txt)
  • Exit the DirectX Diagnostic Tool.
  • Attach the dxdiag.txt to the next reply you make

I have also provided a link to answer your previous question about how to handle crashing in the future.

Here is a link if you were still curious:

link text

Here is file you have requested. The crash seems to happen only when i click on a image brush or progress bar, after I have rearranged the layout.

Hello Endrophes,

I see that you are working on a laptop. Typically laptops have a harder time running the engine. Could you please take a look and make sure that your laptop is using the Nvidia Graphics card (NVIDIA Quadro 2000M ) and not the on board graphics card (Intel(R) HD Graphics 3000)?

Hello Endrophes,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.