No engine installed after installation

I’ve recently purchased the engine and each time I run the launcher it removes all previous versions of the software and when l re-install it…it installs but be l’ve got no engine. I’ve done this several times as well as restarting my computer to see if that would’ve changes anything but it still says no engine. Is there a way to fix this issue?

Hi Shysta,

Are you installing it by going to the Library tab in the launcher then adding an engine version and installing it there?

Yes I’ve tried it through the library and by the tab just under my user name but all it seem to do is uninstall it from my computer then when l hit subscribe it re-installs it but I still have no engine after its been installed. How can I stop this from happening again and have the actual engine installed for use?

Here is some troubleshooting steps, please try the possible solutions under the section ‘Launcher is unable to download content’.

Afterwards if you still can’t download the engine, follow the 10 steps at the bottom of the page and post your ‘Verbose Logs’. They will help us look into the issue further.

Hi Shysta,

In addition to getting the verbose logs TJ mentioned, if you could provide screenshots of what you’re seeing in your launcher, that would help us out!

-Max B.

Sorry I have been busy but I’ve tried all the steps and I haven’t seen any progress. I have done as requested but I haven’t taken any screen shots because my cam seems to be having text

Sorry I have been busy but I’ve tried all the steps and I haven’t seen any progress. I have done as requested but I haven’t taken any screen shots because my cam seems to be having text

Good to hear back from you Shysta,

Shame you were not able to get a screenshot, let’s see if I understand your issue correctly:

  • You’re able to add an engine slot and select an engine version to download in the library.
  • It downloads and once it’s finished, clicking on the launch button on the engine slot or the sidebar “uninstalls” the version
  • Engine slot no longer shows launch button but a subscribe button. Clicking on it starts the engine download again but will still uninstall after finishing and clicking the launch button.

Is that the correct scenario? Also, can you navigate to the C:\Program Files\Epic Games folder and see if you have any folders labeled with engine versions (4.5 or 4.6 for example).

-Max B.

As you can see here with my installation of the unreal engine but after the installation I still have no engine and I’ve sent you the log a few days ago and each time l install it…it removes the program that’s already installed and then l need to re-install it. Each time after I install it the pics I’ve attached is what I’m always getting after

Hi Shysta,
Could you also look in you Epic Games folder and see if the engine version folders are showing up with any files? The default install path is “C:\Program Files\Epic Games”. You should see (Hopefully) folders like 4.6, 4.5 there.

-Max B.

Hey max sorry for the late response but the engine folder is empty

That’s no good! My recommendation at this point would be to uninstall and then reinstall the launcher itself. It seems like there may be some corruption that has occurred and reinstalling the launcher may fix the issue.

-Max B.

I’ve unistalled it several times even by using a program that uninstalls and delete every file associated with the program and when I install it yet again it still comes up with no engine. I’ve tried installing previous versions of the engine to see if that would fix the problem but they all gives me the same results with no engine.

Ok Shysta I think I know what the problem is,

Looking at your screenshots again it seems you’re on a different account than the one you have entitlements for. Please log into your other account and make sure you’re able to download the engines correctly.

-MAx B.

Hi Shysta,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the solution Maximusdb3 provided above.