Download

[ New UMG Widget ] Color Picker UMG Widget, The Same Color Picker You Know and Love!

Well, I can open and everything! So thanks, Rama.

Now I am encountering what appears to be an engine error with UMG. For some reason there are some elements which cannot be interacted with any more. It is very strange and the color picker is included.

Another that broke from the transition of 4.8 to 4.9 is the UMG Spin Box.

That is another issue with unreal 4.9 i guess…Spin Boxes doesnt work…Checkboxes also Doesnt work…?

Hey Rama,
Any update on the android compatibility for this plugin?

Yeah, 4.9.1 is broken, which is disappointing considering my app makes heavy use of UMG… And now I can’t be sure all related functions are working correctly, because plenty of my Blueprint functions are broken.

Currently beyond the scope of my available free time hours which usually are the hours when I should have been sleeping, such as now

:slight_smile:

Rama

Color Picker For Your Game!

Dear Community,

This plugin gives you the same color picker you use in the editor!

Enjoy!

Rama

Dear Community,

This plugin gives you the same color picker you use in the editor!

Enjoy!

Rama

~~

Update 5
(9/18/15)

I now support packaged builds for

Development Win64
Shipping Win32

And I have also upgraded the project to 4.9 !

Download Link, UE4 4.9 Plugin

Enjoy!

:slight_smile:

Rama

Build not working

Hey Rama,

I have some trouble with building a development 64Bit build. The color picker is not shown in the built version. It is a BP only project.

Hey Rama,
Could you re-compile the plugin for 4.10 please ? Now that it’s been released projects using the plugin can’t open.
Thanks ! =)

I’ve detected some problems with skiping animation on construct (4.10.1)
-EditDefaultsOnly property doesn’t show in widget editor
-Setting skip animation true by default in code / setting property EditAnywhere doesn’t resolve the problem
-Cannot set color properly before construct animation ended

Is it the reason you haven’t updated project to 4.10?
Hope someone will find workaround or it’s just something strange on my side

No Seriously Rama Your stuff is great. i appreciate the unreal community everyone seems to be really helpful for newer people

Hi really nice work, when do you plan to upgrade to 4.10 or directly to 4.11 ?
Can you expose the differente part of the widget to select what we want to see ? like if i juste whant the color wheel or etc ? any idea ?
Thx Again nice work

Hey Rama,

Great stuff.

Any idea on when an update for 4.10 might be out?

Thanks!

Hey Rama
Great job! are you planning to update it for 4.10 as well??

UMG Color Picker Upgraded to 4.11! :heart: RAma

Dear Community,

I’ve now upgraded my color picker to 4.11!

Please note I never did do a 4.10 update.

I presume ye all are gonna get 4.11 cause it Rocks :slight_smile:

Download Link! (17 mb)

Please note that I also supply you with these packaged binaries:

Development Win64
Shipping Win32

:heart: Rama



[QUOTE=Sillo;505253]
Hey Rama
Great job! are you planning to update it for  4.10 as well??
[/QUOTE]



[QUOTE=EternalSilence;467000]
Hi really nice work, when do you plan to upgrade to 4.10 or directly to 4.11 ? 
Can you expose the differente part of the widget to select what we want to see ? like if i juste whant the color wheel or etc ? any idea ? 
Thx Again nice work
[/QUOTE]



[QUOTE=vishaluae;483554]
Hey Rama,

Great stuff.

Any idea on when an update for 4.10 might be out?

Thanks!
[/QUOTE]



**[FONT=Comic Sans MS]Welcome to the forums Silo and Eternal Silence!**

Rama

Thanks a lot Rama

hay, iam new in unreal… btw how to sue this plugin? many thanks…

Good man! This plugin is useful to change object color , but how can i change the color of wall easily …

You’re welcome!

:slight_smile:

Rama

Hi I Trying Build this plugIn in 4.12.2 and receive this messages…

‘UWidget::GetEditorIcon’: GetEditorIcon is deprecated. Please define widget icons in your style set in the form ClassIcon.MyWidget, and register your style through FClassIconFinder::(Un)RegisterIconSource Please update your code to the new API before upgrading to the next release, otherwise your project will no longer compile.

Hi Rama, could you please compile it for 4.12?

Thank you,
Luigi