My UE4 Launcher either hangs during update or when I click "launch"


I am a paid user for UE4. I am using Windows 8.1 and am living in Germany (bought laptop in Germany but using English software).

When I boot up the UE4 exe, one of two things happens.

  1. The launcher shows that UE4 is being updated and it hangs there. I then open the task manager and find the ‘not responding’ message.

  2. I am able to click the “launch UE4” button, but it hangs on the next phase (where there is the UE4 banner that says it’s loading). I then have to open the task manager to kill it as it says it’s not responding.

Please note that this is after leaving it for over half an hour in each circumstance and based on a number of tries. I would love some help.


Hi bewise5,

Please try the troubleshooting steps linked below and upload your logs. Also, follow the steps at the bottom of the page to find your ‘Verbose Logs’ and post them here as well. They will help us track down the issue.



I appreciate the reply.

I followed the instructions regarding the firewall and running as administrator and still no success.

I’ve attached the verbose logs as requestedlink text

Hi there.

If at all possible, could I possibly request an update on this? This has halted our development (on my part) so we really need it resolved as soon as possible.

Hi bewise5,

It looks like you don’t have the latest version of the Launcher. You can fix this by downloading the latest .msi installer. To do this go to and sign in > click the Download button from the Subscription tab.

Let us know if this fixes the issue or not.

link text

Sadly it didn’t work. I downloaded all the latest drivers, tried reinstalling and just can’t get it to work. I’ve attached all verbose logs to this comment after my most recent attempt to start the launcher.

Facing the same issue here.

“Checking for update - Please Wait” and nothing happens…


There are a few different problems that can cause an update to fail. Please can you try the troubleshooting steps linked below. Also, follow the steps at the bottom of the page to find your ‘Verbose Logs’ and post them here as well. They will help us track down the issue.

Hi bewise5,

I’ve taken a look at these logs to find out what’s going on, but it doesn’t look like these logs have been generated with the veryverbose option. Please can you resend verbose logs as described on the troubleshooting page?


Oh, and please also ensure that you cleanly close the launcher (if it’s possible to do so) so that the full log file is flushed to disk. Although, I appreciate this might not be possible in your case.

link text

This seems…SEEMS to now be working. I uninstalled, reinstalled again, ran the launcher from the Home directory in C and it all went OK…SEEMINGLY.

I have attached the verbose logs just in case you are able to find any pitfalls that might inhibit me in some unforeseeable manner :slight_smile:

I would still really appreciate it if you were to glance through them and see if there was anything that has gone wrong. Thanks again in advance.

Hi bewise5,

I’m sorry that it has been a few days, but I got with a member of our Launcher team and asked them look through your logs. Everything looks fine from our end. If you have any other issues in the future that seem related please post back here to let us know.



Thank you kindly for checking it out. Should be fine from here but I’ll chime in again if I face a similar issue.