[Mac] Unreal Engine Launcher goes unresponsive upon download

Hi,

I am trying to download Unreal Engine 4.7 Preview 2 with my Mac via Unreal Engine Launcher → Library → Add Engine.
The download goes smoothly for a few minutes, but then the whole unreal launcher application is going unresponsive:

I am using MacBook Pro with OS X Yosemite 10.10.1, and I can see in Activity Monitor the % CPU is still moving between 50 - 60% range, does that mean the download is still ongoing, despite the launcher is going unresponsive?

Thanks a lot in advance.

Charles

Hi Charles,

Have you been able to use earlier versions of the editor? Can you give us your system specs? You can find the information we need in the Apple Menu > About This Mac. Just copy all of that and paste it in a comment (minus the serial number). Thanks!

Hi Ben,

I have tried installing Unreal Engine 4.5.1 and the installation goes well.
So just installation for 4.7 Preview 2 is not working

Below is the spec of my mac:

MacBook Pro (Retina, 13-inch)
Processor 2.8 GHz Intel Core i5
Memory 8 GB 1600 MHz DDR3
Startup Disk Macintosh HD
Graphics Intel Iris 1536 MB

Thanks for looking at the issue I am having in advance.

We haven’t been able to reproduce what you are seeing. Try the troubleshooting steps linked below under the "Launcher is Unable to Download Content’ section.

If you are able to download and install an earlier version of the editor these steps may not help, but post back to let us know.

Hi TJ,

Thanks for your suggestion.
I have tried almost but to no avail, including:

  • Close UnrealEngineLauncher, waits for hours before restarting
  • Open UnrealEngineLauncher with sudo
  • Turning off firewall of mac
  • Open UnrealEngineLauncher with -HTTP=Curl as argument

Below is the archived log I found in /Users/[User Name]/Library/Logs/Unreal Engine/UnrealEngineLauncher.
UnrealEngineLauncher.tar.gz

Could you help and see what’s the problem?
Thanks a lot.

Charles

Hi Charles,

I took a look at your logs and what’s happening is you’ve experienced a crash and the Crash Reporter window has frozen when attempting to open up after the crash. Unfortunately at this point in time, Yosemite currently has several known issues with the unreal launcher. Fortunately, most of these issues should be fixed once the next update for the launcher comes out. Let us know though if you’re still having issues with the preview build once the launcher update goes live.

-Max B.

Thanks Max for pointing this out.

I have done some googling myself and I guess it’s related to Wi-Fi disconnection issue of Yosemite (which has not been fixed in version 10.10.1). Hope that Apple’s upcoming upgrade will truly address this problem.