Download

Light build creates dark or black spots on geometry thats too close i assume.

No its not. Uv could be an issue on the gate, but the wall with windows has perfect uvs. I am pretty sure i know the cause now , but i still have no idea how to fix it. You see my scene is lit with a skylight only like a cloudy day… no directional light or anything. When its lit with indirect lighting only these issues appear all over. This is my guess on what is causing hte problem… I dont think the problem appears with direct lighting like a point, spot, or directional light. I think lightmass just sucks with indirect lighting from just a skylight or light bounce. So the question is what setting might i use to fix that?

As I initially wrote, maybe your materials are preventing bounce light from being caught…
What happens if you increase the indirect lighting boost level?

I think you have a problem with object normals. Stair steps look like their ends have smooth shading on them (smooth shading == multiple faces sharing same smoothing group), and japanese tiled roof looks like every tile has random normal directions.

So, either incorrectly calculated normals, or incorrectly canculated tangents, or incorrectly computed normalmap.

The effect on the stairs is very similar to what you get when make a box out of 8 faces, put every face in single smoothing group and then light it up with per-pixel lighting.

Actually i wasnt even looking at the stairs as a problem. I didnt notice that myself. I really can care less about something so tiny… but no the stares are fine… those are flat… with hard edge normals… Nothing special going on there. The shadow thing could be needing more res, but again im not even looking at that as a problem. Lets alll just focus on the wall with the window and the plant. Perfect UVs… hardedge model… just a wood texture and a normal texture from a 2d image for tiny bumps in the wood… nothing major… nothing special. That wood has the shadow from the other side on that 1 spot because there is a big plant box on the other end right next to the walls other side. Looks like lightmass sucks with indirect lighting so im trying to find a way to see if there are settings that can help this.

Well the materials are normal materials. Nothing special at all… just the color , normal, roughness, and metallic textures directly plugged in. The model itself for the wall with windows is just hard edge geometry… the normals are just details for the woods texture… so its a little bumpy.

As for the indirect lighting boost level… the skylight intensity is at 25, the indirect lighting intensity is at 12, the color is a .463 grey …

And as for the world settings… here is a screenshot instead of typing that all out…

If you’re talking about massive black spot at the bottom of the wall in the 3rd screen, that also could be related to misaligned normals.

You need to check normals in the engine (honestly, just do it). Open mesh in static mesh editor, enable normal map display (button at the toolbars) and make sure they’re pointing in the correct direction. Check tangents/binormals too. Black plant on the wall can also be caused by incorrect normal direction or flipped normals.

Because, honestly, there’s no reason to think that the model has been correctly exported when it displays those kinds of artifacts.

edit : just saw your comment about no directional lighting, but i’ll leave what i was writing below too as scale could still be a factor and an easy check.

I don’t know that you can get away without a directional light. I’m not sure what information it has to go on for building Uvlighing if you see what I mean. The idea is that it will take the shadows generated from your light, and render them into your textures on objects for static light and objects. If you have not light, i’m not sure what it will build based on.

Just turn down the intensity of the directional light, and turn up the Indirect Lighting. It should be easy to see if adding back in a directional light if the problem goes away, and as you turn down intensity when it comes back. You can also turn down the Indirect intensity on the directional light too.

It’s an interesting problem, and i like your models.

-finn


I don’t know if all your problems are UV related, but there is definitely some UV issues here. The small roofed structure for instance, the area that large sections of your model have for lightMap UVs are tiny, there is lots of space between them, in fact some parts are so tiny there is more vacant space than space taken up by the model in the lightMap UVs. This one in particular is very questionable and should be remapped, and I would probably do this manually so you can take larger sections of your model and keep them together since it seems to really be fragmenting it. This doesn’t look like Maya doing an Automatic mapping, it looks very spread out for Maya.

So I would do this

1 ) Fix UVs on that small structure

2 ) Render tests alone in a test scene with a light so you can debug more quickly instead of in a whole game where you have to wait.

3 ) Increase the resolution of your UVs in UE4. You have it set to 256 now, but scroll down to your min LightMap Resolution in the LOD1 section. I seem to remember having to work with his too.

4 ) It actually sounds like there is a tolerance problem with your scene due to the fact that what you describe sounds like things being too close together are self shadowing or shadowing other things. In some software there is a way to change that tolerance, I don’t know about that with UE4, however, it could be that when you started importing into the game the size of your models is too small and you began assembling the game small (that’s my guess).

The way to test this out is to take something from UE4, a model from one of their game libraries, put it in a default game and EXPORT as a fbx. Import it into your modeling software. In your software you want to use this (could be one of their characters for instance) as your template for your world.

One thing I notice with modeling and importing into UE4, the settings of our export is very important. For instance, in Maya I like to work with my scale set to Feet. That way I don’t have clipping problems and can work in a scale that makes sense to my American sense of size. Then I set my preferences to Centimeters before I export my models to UE4. Once I do this, the scale comes in perfect for UE4 since that is what UE4 is expecting. If I export with Feet the model is gigantic I believe. I haven’t tried setting it to inches, so I don’t know what to expect, but it’s best to just match what UE4 expects.

Here are screenshots of normals. I see no issue. And as i said before… these are not hte only models that do it… hell that plant came from the unreal market. It happens with the vast majority of things in the scene that are only lit by indirect skylight with no directional light in the scene… this includes grass, stones, and plants along the floor. Some just show blackness where it should not show blackness… like a leaf pointing at the sky should not be really dark.

Alright let me try to respond to every point lol…

4.) Its at correct scale. No doubt about that. I usually match stuff up with meters or cm and match it to the size of what it would be like according to other unreal market assets… Heck some of the models in that scene are from the unreal market. So scale is on point.

3.)Shouldnt need high resolution on a flat wall… where the uvs are fine… Lets not worry about the roof top thing for now. We all know those uvs are ****, but i dont care about that since thats not the root cause of my issues for the rest of the scene.

2.) will wait to do that one… besides… i dont want a directional light. Its a rainy cloudy thunderstorm kind of day. Unreal has skylight for a purpose… and thast what im using it for. Sky light lights from all directions liek a sky… sort of like indirect lighting.

1.)again lets not worry about that roof top… the uvs are fine on the window wall and plant that we are testing with.

Thanks for the compliment… I am hoping some expert in lightmass or a developer comments on this … hopefully there is a setting to use… i hate lightmass so much. Its weird to feel like your using a next gen engine, but still be stuck with last gen technology while everyone else has moved on for the most part… baking for 8 hours just to see if u fixed something…

Actually, I’m not sure about that.

First, in-game vizualistion won’t give any useful info. You need to display vertex normal in editor window.

You are supposed to have multiple normals per vertex at seams. Instead you appear to have one set of them, although it is hard to tell for sure, because of enabled tangents and binormals. The faraway panel looks curved, and it definitely shouldn’t look that way.

Enable normals only and try again.

Check attachment to see what it should look like.

Yea i see no problems… here are 2 shots from both sides. normals only.

I don’t see any outwards pointing normals on bottom corners and near bottom of the wooden panels in the first screen. Most likely black spots occur at that side of the wall.
If the long wooden plank is tesselated, then it also doesn’t have correct normals.

Something like that could’ve happened if you created backfacing part of the mesh by duplicating and dragging front-facing portion.

When you look at the surface, surface normals should be pointing towards you. When you look at the surface from behind the surface, the normal should be pointing away from you.

Anyway, recalculate normals properly, reexport geometry and try again.

You may be onto something. i exported that model out of unreal and into my 3d package and i saw the normals were opposite direction for that side of the wall. Very strange. That model was made in unreal because i combined a bunch of assets… (the wall usually comes in a 1 sided peice and i duplicated and scaled it negative one to make it double sided… then i merged them with unreals merge mesh tool. Looks like scaling things negative in unreal is never a good idea even if it looks correct normal wise from a visual standpoint.

Still though that doesnt exactly explain foliage / rocks in terrain turning black… worst part of the rocks is its random… for instance lod 0 may be fun but lod1 turns black… or opposite can be true… or nothing turns black…

This is a little off topic, but i figure id ask. Whats the best approach to lighting a 2 sided flat peice of geometry that light can somewhat shine through like sss … almost like foliage… like paper shoji windows or something…?

It does explain it. Lighting is calculated based on normal and direction towards light source (n dot l in traditional shaders). If normal points towards light, surface is lit, if it is pointing away, surface is in shadow. Normal is interpolated across faces for the purposes of light calculates.

If normal is flipped to the opposite, you get black surface. Black plant most likely has normal flipped. Rocks are lacking proper edges, and normals are either overly smoothed or pointing in the wrong direction, which would produce similar effect - black spots.

Basically, you have an issue related to either smoothing groups or normal export somewhere. Cursory look at your level in the first screen show that there’s quite a lot of geometry that appears to be smooth shaded, although it looks like it is supposed to have hard edges.

For example, column near that gate at the first screen seems to be smooth shaded. Half of the pillar on the same column also looks smooth shaded. There’s strangely smoothed ends of steps on stairs, etc.

Thats intentional. Some of those are actual props where the normal map is generated from a high res model. So how would u do something that has to be lit from 2 sides and is flat? Like shoji windows.

There was “two-sided-lighting” checkbox somewhere.

THat never works out nice after a lightmap bake. I mean with realtime lights it works great, but 2 sided lighting in a lightmap bake makes one of the sides dark always… Its as though it does take some lighting from the other side, but its much much darker…

See the screenshot for what im talking about… Baking that should not make it practically black in a lit room…

I’m not dealing with this kind of levels, so I can’t help with that.

You could try turning those into high-opacity translucent windows, or just cheat and add emissive glow to the “inside” surface. Aside from that, I don’t have any ideas.

I dont know if thos helps but i switched my lights to movable and it fixed this problem for me its a cheap fix but it works

Your nice work looks like you have big experience with meshing and setup.
Happens that only to your meshes? Basic UE4 assets behavior different?

Have you more then two uv channels on your objects? First channel UV- second LM?
I dunno if that helps, but i encountered something a bit similar some time ago.
The meshes i imported into UE with triangles in the basemesh (not quads only, before triangulating) caused(cause) problems sometimes.

When i make clean quadtopo and export that, i get no errors.(Blender)
Overlapping/loose faces/vertices/hidden objects?

What is when you make a cube and or sphere with emissive material and place it in your darkish scene?

Edit again: mhhh when i look at first picture Light build creates dark or black spots on geometry thats too close i assume. - Content Creation - Unreal Engine Forums
Can you make a shindle one seperate object with own uvmap lightmap, and then try it again? Your whole object is onto one lightmap…
Scaled you the models down so much inside ue4?