LIFT / ELEVATOR bug

Hello,
100% repro bug.
I tried it with engine versions 4.11.2 and 4.10.4 too.

  1. Place basic mesh in 3rd person example map
  2. Make BP to move him up (set loc or move component to or matinee… many ways…)
  3. Step on lift and launch him

BUGs:

  1. If character jump while lift moving up, he drop down (maybe only when lift moving very slowly then maybe not)
  2. Character is stuck in lift while lift is moving up or levitate a bit when lift is moving down

I googled that improvements comming “soon” in 2014 but i didnt found any solution yet and spent with it 4 days…

I tried:

  1. More maps and engine versions
  2. Ccd
  3. Always check floor
  4. Something in project settings in physics probably its called substepping
  5. Making more collision boxes attached under lift
  6. 3 ways how to move lift(move component, set location, matinee)

VIDEO + SCREENSHOT here:

Hello,

Here is a screenshot of my setup in the Level Blueprint:

The only setting I changed was on the cube mesh, I changed Collision Complexity to Use Complex Collision as Simple.

When I used this method, I didn’t see any issues occurring. Are you using Sweep at all when you are moving your elevator?

Hello,
Still same problem… I did what you too (complex collision and sweep) but still same 2 problems…

BP setup:

Video:

So after few hours i again reloaded project and now “SWEEP” running well - character is not stucked anymore and dont drop down after jump - BUT lift is not moving up when im standing on it…

Have you tried putting a Trigger Volume on the elevator and doing an Overlap event? You can then cast the Other Actor to the Character and then move the elevator up when the character is overlapping the volume.

Then, you can also use an End Overlap event to stop the elevator from moving up and return it to its original location.

Of course, my first attempt was exactly what you said …
What i found last days:

  1. sweep cannot be used for lift because it disabling actor movement
  2. I can jump on lift when lift is moving up but max speed is delta_time × 700… which is around 1 - 2 meters per second… at higher speed 850+ character will drop down…
  3. Character is stuck or hovered on lift in any speed but with increasing speed it is more visible…

I read from 2014 that this is issue with character movement component and someone from staff said that improvements comming soon (in 2014) but i did not found any solution yet…

Unreal engine is probably atm the best engine in the world so i hope this basic stuff must be solved or repaired easily…

The setup that I provided you was working as expected on my end. Could you please zip up your project, upload it to Dropbox, and provide me with a download link so that I can see what is causing errors with your particular setup?

Here is my forum profile link so you can PM me the link: https://forums.unrealengine.com/member.php?160394-Sean-Flint

Hello,

Take a look at these tutorials:

These should help you get a working elevator set up. If you’d like to find more tutorials, you can go to Unreal Engine 4 Documentation | Unreal Engine Documentation and perform a search for Elevator. If you are still having issues after following the tutorials, please let me know.

Hello,

I really dont know, but you are a robot or you are just trolling me…
I know how to do lift by many ways, but it does not running properly…

just check my videos:

**1. problem: I cant jump when lift is moving up faster than +- 3 meters per second**

2. problem: Character is stuck in lift when lift is moving up or hovered above lift when lift is moving down

Following the setup in the tutorials I’ve linked does not provide the results that you’re experiencing. After looking into your project, the workflow that you are using to set up your elevator is not recommended, which is why I provided the tutorial links for you to look at.

The reason that you cannot jump when the lift is moving is because it is causing the character to be slightly off the ground based on how you are moving the platform, which means that it does not think that it is possible to jump at that time.

I’ve seen the videos, but when I was in your project I did not experience the character becoming stuck in the lift.

Please take a look at the tutorials I’ve provided and see if copying those setups provides you with the same results, and then we can begin to determine if there is a potential issue. In my setup that I created in a clean project, I was able to get the elevator working properly in a few ways. You can create a Matinee that has a movement track that moves the elevator. You can also use a timeline for this purpose as well, which would allow the elevator to have much smoother and more consistent movement.

The ways that you have set up your lift all seem to be using the Set Actor Location node, which I don’t recommend because it can cause collision issues when used in combination with the capsule on the Third Person Character.

While I do recognize and understand the issues that you are experiencing, I’m suggesting that you create your lift in a different manner that is more efficient, as this should eliminate the problems that you are having when it comes to your character being unable to jump and getting stuck in the lift.

Let me know if you have any further questions.

Well, so, in my project which i sent, was movement of lift set to time x 900, i changed it to time x 3000 for better look and here are results:

character is stuck in lift… with higher speed is character more “swallowed” or “drowned” or “stranded” (im not sure which word is right)

ok so now jump, you said that is not possible so it is bug? because i cant believe this is feature… so i made test… i checked box to true “impart base velocity Z” at character movement component and lets see results:

When character jumps, he is above lift about 2 seconds… enought time for detect some kind of collision… and when im landing on second lift platform, character is stopped immediately… it is something like first lift is flagged as “character cant land here” but not updated in tick … all others platforms are land-able… you can test it much more well - if you set impart z velocity to true and lets increase characters jump Z velocity to 2000 or 3000, he will take to land about 5-10 seconds and again he will drop down… after 10 seconds flying over lift…
But as i shown in video, from platform which i have not jumped, i can land at any time, even if that is moving with any speed…

Hello Name368,

I apologize for the delay, thanks for your patience. I have spent some more time looking into your project, and it seems that the issue here is not technically a bug, it is a limitation of the functionality of the character movement component. You can try setting up a Pawn instead of using the character class, and creating your own custom movement component in C++ or adding a Floating Pawn Movement component to the Pawn and see if you get different results.

Other than that, based on the method that you’re using, it is expected that you will see issues because of the way that the character movement component is set up.

The base character class is meant to be used as a quick way to set up a prototype, but I’d never recommend using it in a full project because, as you see in your project, it can cause different sorts of issues, especially when it comes to collision.

While it was stated that character movement improvements will be coming, this is not a main focus of our developers at this time.

To reiterate, give using a Pawn class with a floating pawn movement component a try, and see if that makes any difference in your case. If not, you can try to set up your elevator using Sequencer or a timeline in an attempt to get smoother movement which could prevent these collision issues from occurring.

Have a great day

Hi, thanks for info.
I tried pawn with floating pawn movement but unsuccessfully. Its a pity but i have some alternative methods so i will use them… So i think we can close this topic.

for anyone having this problem, you must disable sweep when the platform is moving