Launcher Crash when queuing multiple version updates/installs

I was installing 4.4 and tried to tell the launcher to update 4.2 or 4.1 or so, and the launcher crashed. Now when it opens (the launcher), it says (In a window titled “Updating Unreal Engine Launcher”) “Error! No version information received.” “Retry” does nothing but bring it right back up to the same message. Clicking “Ok” brings me to the signin page but when entering credentials it just tells me “Error! Did not get a response. Are you connected to the internet.” I have tried deleting the Launcher folder, and then reinstalling, as well as using the installer to “Remove Unreal Engine” and then reinstall, but no luck. Same exact deal. Please help. I want the ability to choose engine version from this simple window, as well as get updates to engine versions, as Unreal Engine 4.4 crashes on me everytime I use a keyboard shortcut in a blueprint or material window.

Hi MikeHazeJr,

Could you please post your dxdiag, .DMP, and .LOG files? Direction in the link below.

Please take a look through the troubleshooting steps in the link below. If nothing works, please follow the steps and post your Verbose Logs as well.

Hi MikeHazeJr,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, try the troubleshooting steps linked above. If the issue persists, please post your Verbose Logs.

Thanks, TJ

So, I actually attempted to uninstall the engine AND the editor to reinstall, and upon reinstalling the launcher I still get the editor error, so I do not now have the engine itself installed, and therefore, I think, no .log file.
I do have my dxdiag though:

Here is the first error window, followed by what happens after i try to login.

That should do for now. I’ll get with our Launcher team to see what we can find out.


Hey MikeHazeJr,

Sorry for asking you to go back and get even more information, but when troubleshooting connection issues, getting the verbose launcher logs is usually the best way to figure out what’s going on. Would it be possible to check out:

And perform the steps in the "None of the Above Helped - Getting Verbose Logs
" section. Thanks!


I can but it will be probably tomorrow night. Sorry for the delays, I currently have no internet at home and to do any of this requires me to go back and forth to a friend’s house. (Slight change in last comment, I said editor error but it was in the launcher. I currently have no editor installed due to the launcher error , and don’t exactly feel much like compiling the editor source right now.)