Launcher "connection to the server failed" problem

It says “connection to server failed”. I recently switched browsers, but that must be a coincidence.Any direction could help.

Hello LostScout,

If you can right click on your Epic Games Launcher icon and choose " Properties . " From three navigate to the Shortcut Tab. You will see a section labeled " Target. " If you enter -http=wininet to the end does this fix the issue. This is a fix for windows only.

Here is also a link to Troubleshooting with the launcher :


I added the -http=wininet and now I am getting a new message that says “could not establish a web session. please try again”. My connection seems good and my credentials are accurate.

At least I got a different result. Anyway, thanks for the response. I will keep you updated if a solution is found. In the meantime, any additional direction would be much appreciated.
Thanks again!

Also, the launcher began to crash. I went back and deleted the -http=wininet and that seemed to fix the launcher crash. However, it now says"connection to server failed" again.

Interesting, I will continue to investigate this issue further.

This problem persists with the unity Launcher as well. I am not behind a proxy server and I do do not see any potential firewalls that could be causing the problem. I am getting desperate. Any luck on the situation?

Don’t laugh, but try the google dns servers. My Windows Store would not work without… I know, odd. but…

The Google Public DNS IP addresses (IPv4) are as follows:

I changed both IPv4 and IPv6 DNS addresses to Google`s DNS servers. The problem still presists…:frowning:

I have noticed that when I do not have -http=wininet included and go offline, that nothing in the editor is connecting, however when I do have -http=wininet and go offline, the news section of the editor is connected to the internet…but that`s it.

It is like things are partially connected.interesting.

Hi LostScout,

Could you please provide your launcher logs and dxdiag? Steps on how to get this information can be found here.

Also, could you provide two sets of launcher logs. One with " -http=wininet" included in your target line and one without.

Thank you!

link text


link text

Log with -http=wininet added

link text

Log without -http=wininet added

Hope this helps!

Another observation I made is that when I hit sign in with out -http=wininet added, It automatically says connection to the server failed…regardless of the password I enter. However, when I add -http=wininet, entering my password will result in the message “could not establish a web session. please try again”. Although, if I enter an incorrect password, it checks my credentials for accuracy.

Hi LostScout,

Your issue has been reported as issue OPP-4984. I’ll reply back as soon as I have any additional information for you.

I appreciate that.
Thanks for the update.

Did you try reseting your password on the web site and trying again?

My credentials are accurate… it seems connection with the server is failing.

Hi Lost,

Can you take a screenshot of your current proxy settings?

You can see these by going to:

Control Panel- → Network and Internet → Internet Options
Select the Connections tab then click LAN settings at the bottom on the window.