Issue with Atmospheric Fog and Translucent Materials

2018 and still exists, its pretty safe to say now that this is a feature and not a bug that will ever get fixed.

Yeah there only seems to be odd workaround and way for dynamic worlds with bigger more intricate particle systems that might overlap and different fog settings accomodating dynamic day and night etc. I really hope Epic fixes this eventually!

You have to enable compute fog per pixel in the material settings

1 Like

Thats great, works. Inside the material,go to translucency, check compute fog per pixel. All the other fixes mentioned above didnt work for me.

I’m not sure if this option was in UE4, but in UE5 there is an option in the material called “Apply Fogging.” Ticking this on for me has fixed the issue.