Is there a way to check in Blueprints if your in Standalone Game or not?

Hi,

is there a way to check in a blueprint whether the game is currently running in the editor or as a standalone game? I’d like to have my custom debug stuff only work if I’m playing in the editor.

Thanks!

I’m wondering too!

I need this too.

You can check by “Get Platform Name” and comparing strings

Doesn’t this only show the OS and not the version of the GameVersion?
This will be true on a Windows PC in Editor and Standalone or?

Why do you guys need to know about standalone or editor? ):

My need today is due to a screen fader effect I need to run to solve an issue of camera position not being valid when my level loads. Depending on network / PC conditions the player camera is placed in a default location until my EventPlay function kicks in and moves it.

To resolve this I’ve created a BP with an embedded post processing effect that blacks out the screen, and once the camera is positioned, it fades out the PPE.

Problem is, that BP also blacks out the editor, so before packaging I have to remember to enable it. I would like the have something in its construction script which can detect its environment so it can disable itself if it’s in editor, but not when released so I don’t have to manually adjust all the time.

Just run into this. My blueprint was derived from a c++ class so I just implemented the following in my class but you could do the same in a blueprint function library.

//! Allow the blueprint to determine whether we are running with the editor or not
UFUNCTION( BlueprintPure, Category = Whatever )
bool IsWithEditor() const
{
#if WITH_EDITOR
	return true;
#else
	return false;
#endif
}

I wrote my original “me too” request on Jun 01 '15 at 2:56 PM, and over a year later, I still can’t seem to do this?

I have come across another case where I need this in BP. I am trying to keep as much of my project in Blueprint as possible, as it minimizes upgrade pain. However, not all features work well in editor. For instance I have just discovered that the console command “servertravel” does not work in editor when seamless travel is enabled. I understand that this is because seamless travel still has bugs in Play-In-Editor mode and has been disabled. For that reason, I need a workaround in the editor. What I want to do is turn off the Use Seamless Travel bool if we’re in the editor.

But I can’t tell if I’m in the editor from BP.

Is there any way to do this other than rebuilding my project from code again and adding a bool function to one of my high level classes? I’ll do it if I have to, but I’m trying to get out of the high level C++ classes as much as possible. Many of the reasons they were created back in version 4.6 have been fixed by the time we got to 4.13.

This says “Windows”, which I believe is not helpful to determining if in-editor or not – which was the question.

Can someone please downvote this?

New in 4.14

116711-standalone.png

Unfortunately, this node returns “true” for me even when I’m playing In Editor. (I’m using 4.14.0)

It is because that node returns whether the game is a networked game (players over a network connection) or entirely local.
Here is the doc string:
Standalone: a game without networking, with one or more local players. Still considered a server because it has all server functionality.

Any News here to check per BP if it is started in Editor, PIE, Stand Alone? Would be nice.

Really miss an Is PIE test too (one was included in UDK-Kismet as well). Possible workarounds:

  1. Use a ‘Get Command Line’ Node (pass different parameters when not PIE i.e. standalone)
  2. Explore using PlayerStartPIE to see if it is different in PIE versus standalone, See [here][1]
  3. Try this hack, which I’ve not done any real testing on, but it seems to work so far in 4.18 etc.

Add a mesh of any type and zero scale (so its invisible) in the level. Give it a tag like IsPIE_MeshTest.

Then in the main game loop, Gamemode for me, add a Bool called IsPIE, that’s accessible to any BP.

Then run something like this in Gamemode EventBeginPlay. Give it a shot and see if it works for now. :slight_smile:

Don’t know if that will solve your problem, but have you tried the Is Packaged For Distribution node?

337336-screenshot-2021-04-28-021133.png

Here is a link to the documentation: Is Packaged for Distribution | Unreal Engine Documentation

This method has worked for me, as of version 4.26.
In PIE, the engine spawns a PlayerStartPIE even if it isn’t used. This doesn’t happen in standalone or a built version, so just checking this way at any point will give you an answer.

I created this Function in my GameInstance so I can reference it from anywhere at any time.

Thanks! Definitely saved me there.

Just trying this in UE4.27.2 and it doesn’t seem to work, can anyone else verify?
The greater than always returns false.