Download

IOS11 ARkit?

Hi, any info about the new ios ARkit?

https://www.youtube.com/watch?v=S14AVwaBF-Y

Epic has an early access version of UE4 support for ARKit in github. Blog entry about it here: AR And VR For The Rest of Us - Unreal Engine
Looks like binary support will be arriving in UE4.17 Preview in July.

ARKit branch on GitHub: https://github.com/EpicGames/UnrealEngine/tree/dev-ar-kit

I am signed in, but I get a Page Not Found every time I go to that link.

The link is fine so you probably missed the step where you have to link your github account to your epic ue4 account

Yep. That did it. I was unaware of that step. Thank you!

Is there any way to get this up and running without a Mac? It seems like to get all of the Prerequisites ready you need Xcode.

Unlikely because this stuff only just came out from apple in beta form and latest xcode beta is required to compile apps with ARkit support for iOS 11 beta.

Binary support for ARKit will come in 4.17. I would guess you will be able to test on windows, just like with other UE4 iOS apps. AR And VR For The Rest of Us - Unreal Engine

Anyone had any luck with this? I’ve got so far through the build, to the point where the ARSample begins to run, then fails with the following error:


2017-06-07 16:11:41.337034+0100 UE4Editor[17873:479369] Fatal error: [File:/Applications/UnrealEngine/Engine/Source/Runtime/Apple/MetalRHI/Private/MetalPipeline.cpp] [Line: 714] 
Failed to generate a render pipeline state object:

 Unhandled atom in intrinsic: llvm.bswap.i32


Yep I get the same error

Yep I get the same error

We (at Epic) aren’t seeing any compile errors… Are you getting that while cooking for IOS?

You are using the Xcode 9 beta, on the downloads page? I just ran through it today, no problem.

Also, are you on the 10.13 beta?

Josh

No, it seems to be an editor crash.
Yes, xcode9beta. No, 10.12.5.

As you may imagine there was a lot of forward facing work involved, so if you can please try using the macOS High Sierra Beta (on a separate drive or partition!) I’d recommend it. The error suggests there may be a problem with using these improvements in UE4Editor on the current shipping version of macOS Sierra you have installed.

Ok, I installed 10.13beta but it still crashes in exactly the same place.

build machine: MacBook pro mid-2012 NVIDIA GeForce GT 650M

If you are willing to suffer through recompiling all the shaders try going opening the Common.usf shader file in Xcode (under UE4/Engine/Shaders). Find the function ReverseBits32 and replace whatever it is now with:


uint ReverseBits32( uint bits )
{
#if SM5_PROFILE && !METAL_SM5_PROFILE
	return reversebits( bits );
#else
	bits = ( bits << 16) | ( bits >> 16);
	bits = ( (bits & 0x00ff00ff) << 8 ) | ( (bits & 0xff00ff00) >> 8 );
	bits = ( (bits & 0x0f0f0f0f) << 4 ) | ( (bits & 0xf0f0f0f0) >> 4 );
	bits = ( (bits & 0x33333333) << 2 ) | ( (bits & 0xcccccccc) >> 2 );
	bits = ( (bits & 0x55555555) << 1 ) | ( (bits & 0xaaaaaaaa) >> 1 );
	return bits;
#endif
}

FYI, I was able to get the AR sample app to build and run on an iPhone with the iOS Beta 11. I am using a 13" MacBook Pro late 2016 with Touchbar with Sierra (not the High Sierra Beta) and the Xcode 9 beta.

I did have to wait for all the shaders to compile before launch the build. It looks me about 4 hours to get the build compiling and then running yesterday but the iPhone 6s is running the AR scene in the wrong aspect ratio.

Today, I did delete the app and do another build. It failed to compile & install the first time but then it did install the binary the second time & also the aspect ratio was correct this time.

I do have a question, do I always need to launch the Unreal editor from within Xcode?

How can I can run the Unreal editor as an app?

When I launch the binary from the file system, it gets stuck at 35% when loading the Unreal editor.

And if anyone is curious, I have attached the console output.

I tried this on 10.12.5 with a GTX 1080. I’m still getting the same error:


 2017-06-08 16:26:00.424989-0600 UE4Editor[96881:658923] Fatal error: [File:/Users/timothyd/Development/UnrealAR/Engine/Source/Runtime/Apple/MetalRHI/Private/MetalPipeline.cpp] [Line: 714] 
Failed to generate a render pipeline state object:

 Unhandled atom in intrinsic: llvm.bswap.i32

Edit: Assuming that this is a bug in the Editor on Mac, rather than the iOS device:

This bug runs much deeper than I had imagined, it will take time to resolve but is likely restricted to Nvidia GPUs.

I will also reiterate that only GPUs shipped and/or supported by Apple are officially supported in UE4.

If this is a bug on the iOS device itself, which would be even more surprising, can you lets us know what devices you are using? It’ll make fixing the problem a lot easier if we know it is restricted to a certain class of device.