Download

iOS 14.5 breaks all Unreal apps made on Windows (and temporary workaround)

If it helps anyone the commit on Git Hub does indeed work, I believe others have tested it on versions of iOS below 14.5 too.
I am still using 4.26 but I replaced the whole ‘\UE_4.26\Engine\Binaries\DotNET\IOS’ folder with the newly built version from the 4.27 Github release.

1 Like

Hello everyone,

We have fixed the issue for 4.27, for iOS 14.5 and up as well as previous iOS / iPadOS / tvOS versions.
If you can’t wait for release, please update Engine/Binaries/DotNET/IOS from the 4.27 stream on GitHub and you should be good !

You can also get the head rev of these two files and rebuild the iPhone Packager from VS.

Engine/Source/Programs/IOS/iPhonePackager/MachObjects.cs
Engine/Source/Programs/IOS/iPhonePackager/CodeSigning.cs

Thanks,
Axel

8 Likes

Solved, I used IPP from 4.27 preview to resign my ipa, and it just worked.
Thanks!

1 Like

Hello,
I updated my engine to 4.27 to solve this problem, however, after uploading my IPA with Transporter, I still get the same error

ERROR ITMS-90725: “SDK Version Issue. This app was built with the iOS 13.2 SDK. All iOS apps submitted to the App Store must be built with the iOS 14 SDK or later, included in Xcode 12 or later.”

I tried to resign my IPA with iPhonePackager.exe but without success

Do I miss something ?

Still having this issue as well, I can deploy locally to the iphone, but to try and submit anything to testflight via transporter fails with the 13.2 SDK message?

Any work around aside from doing full builds on the mac, or forcing c++ remote builds?