How to tile a texture?

This is probably the most basic question (I started using unreal engine yesterday) and I was wondering how you tile textures because at the moment the texture is just stretched across my object. Any help?

Hey there!

This is very simple. In your material, attach a TextureCoordinate node to the UV input of your diffuse (and normal, if you have one). Then, you can change the X and Y tiling inside it.


Thanks! When I searched for an answer all I got were people complaining that it was tiled (instead of my problem being that it wasn’t). This worked perfectly though!

This is the tutorial I am following and it seems for them, it was automatically set to tiling from the start, but for mine it is clamping and stretching. When I went into the M_Concrete_Tiles and set the TexCoord from .5/.5 to 5/5 it looked better, for the floor texture, but when I tried to increase it for the wall texture M_Concrete_Poured to something like 1 / 25 and 25 / 1 and nothing changes. I am not sure if I’m not changing the right TexCoord’s values for UTiling and VTiling. I’ve seen in other post about this advanced option setting texture to clamp or tiling but I have been unable to find this option. Any idea how I should go about trying to tile the wall texture?

Is there any way to make it tile correctly an all sides of something like a block? adding a bunch of tiles this way only looks good on 2 sides of a stretched block and the rest is squished

So I can’t use the texture coordinate in a material instance? It doesn’t show up for me. Thanks for any help.

Alittle late, but just ran into this problem myself… one way to get is to, pull from a UV socket and type in “coord” and it shows up

Here is a good video on scale-able tiling with “TextureCoordinate” node: Unreal Engine 4 Tutorial - Scale Textures - YouTube

Or, try the “BrickAndTileUVs” node and set variables with “scalar parameter” nodes in the material’s blueprint… seems like it is designed to do tiling as a baked feature in UE4.17

See blueprint example in this thread:

1 Like

That didn’t work for me,. I found this ‘TextureCoordinate’ and it worked predictably…,.

1 Like

You need to attach the “Texture Coordinate” node to both your textures in the “UVs”. Not only the NormalMap one.

Hi, hope this could help you


This is the best answer. This exposes the UV tiling as parameters, which means you change the tiling on any Material Instances you create from the Material.

For new users, the U_Normal and V_Normal nodes in the image above are “ScalarParameter” nodes and the Append node is a “AppendVector” node.