How to fix "A D3D11-compatible GPU (Feature Level 11.0, Shader Model 5.0) is required to run the engine"

I am attempting to use UE5 preview on our build server. The machine has a NVIDIA QUADRO RTX 6000.

It has feature level 12_2 (Direct X 12) and shader model 6.6 - which should make it compatible with DirectX 11 (Feature Level 11_0. shader model 5.0)?

So far I have tried updating the Drivers, Updating Windows, and Updating Direct X End-User Runtime, however none of this has helped.

Is there anything else anyone can suggest to possibly get UE5 working?

1 Like

Is there another vid card on the motherboard?

Yeah, looks like there’s a Matrox G200eW3 (Nuvoton) WDDM 2.0. I’m gonna guess that UE5 is trying to use the Matrox instead of the Nvidia GPU.

Yes, you can choose the card to use in the engine config, but it’s probably easier to disable the onboard card in the BIOS.

I think you might also be able to choose it using the gpu settings for your vid card:

So just putting this here in case anyone else has this problem.

I solved it by setting the card in the engine config files.

Go to Program Files / Epic Games / UE_5.0EA / Engine / Config / ConsoleVariables.ini
Add r.GraphicsAdapter=x
Where X is the index of the graphics adapter that the engine should use.

Hope this helps anyone else with this problem.

1 Like

I’m a total noob but what do you mean by add r.graphicsadapter=x?

like, where do i find the index of the graphics adapter that the engine is using?

I’m having this same issue w/ trying to run Fortnite on a laptop i was given for my 8 year old son (Asus Rog G73JH).

If you open device manager on your device, then look for display adapters, these should be ordered in the order of their index (i.e. the top one is zero, the second one is one etc…)

So at the bottom of the config file ConsoleVariables.ini, on a new line add r.GraphicsAdapter=x
And replace X with the index of the display adapter that you want UE4 to use. If not sure trial and error is normally a good option, just move through the list until it works as intended.

I’m no expert myself but this helped me understand the problem, although the problem with my system ended up being much larger than just this. I believe the fix mentioned here should completely solve the problem for most people.

1 Like

Worked for me too. I just replaced “x” with “1”

r.GraphicsAdapter=1

1 Like

Also worked for me

this worked, thank you