How do I compile lightmass?

Everytime I press Build in my Unreal engine editor an error pops up wich say : Lighting build failed. Swarm failed to kick off. Compile Lightmass. Now I dont have any clue how I can compile the lightmass. Can you help me?

1 Like
1 Like

i have same problem :frowning: nothing works.

This thread worked for me.

https://forums.unrealengine.com/development-discussion/rendering/121445-how-to-compile-lightmass

Hope this helps

1 Like

If anyone still needs this…
I was building UE 4.22 from source in Visual Studio and got this problem.

This answer probably doesn’t pertain to the launcher version of UE.

PLEASE NOTE: I have no clue whether what I did was a good idea–just that it solved this problem at the time.

The solution was to build the UnrealLightmass project in Visual Studio.
To do that, I couldn’t just right click UnrealLightmass and build. (I got an invalid configuration for Win32 message.)

First, r-click UnrealLightmass > Properties. Click upper right button to go to the Configuration Manager. (Or just get to Configuration Manager any way you like).

In the list, find UnrealLightmass.

Change the configuration from ‘Invalid’ to ‘Development_Program’ (random guess) and Platform x64.

Then, r-click UnrealLightmass and builld.

Relaunch the engine for good measure.

This allowed the Swarm Agent to work in the Editor. But, again, I have no idea if my build configuration makes any sense.

2 Likes

Thanks. That worked for me too in 4.22

This worked for me in 4.26.1, too.

Thanks, solved the problem in 4.26.2
anyone knows why this is happening?

You are a life saver! That worked for me in 4.26.1