How do I change the icon and name of my packaged game?

i feel stupid, but i still don’t know,
can you explain point 5 a bit more?

The easy answer is just to output to the directory: WindowsNoEditor and rename the folder after the fact. Experiment with packaging some of the Blank Templates and you will see this does not interfere with the executable.

The previous #5 above shows where this directory originates so advanced users can change the name there if desired. Another user posted a way for this to be done in the following post:

Sorry to bump this but I’ve followed these steps and the icon of my .exe is still displaying the editor default image depending on the current zoom of windows explorer.

My image is exactly 256*256 and of the same file format than the default unreal icon (.ico) so I don’t know what to do more.

My project contains both Blueprint and C++.

The source image is stored at the same folder location than the default unreal icon.

Do you have your icon selected for the correct platform that you are packaging for in your project settings?

I followed all the required steps to set icon and process name however it just wouldnt work. Turns out its an Engine code issue.

See my question here - Not able to correctly set icon and name for packaged game - Programming & Scripting - Epic Developer Community Forums

Note the comment on the accepted answer by project.gheist. If you follow his links (his PRs), you should be able to successfully set icon and process name correctly, as I was able to.

I shall link project.gheist pull requests here as well -

  1. For icon issues -
  2. For process name issues -

An issue was created for only the icon issue and can be tracked here - Unreal Engine Issues and Bug Tracker (UE-36945)

Hey all. So as of UE4 version 4.13 the following works 100% for windows projects. I have not tested on other platforms, but I’m confident it will work for those as well. The problem isn’t with Unreal, it’s the fact that icon files need to have multiple sizes for them to work properly in Windows.

Step 1 - Create your icon file as a 256x256 PNG image and upload it to

Step 2 - After uploading your icon image, scroll down to Step 4 and select the following sizes: 16x16, 32x32, 64x64, 128x128, 256x256. Then hit the Step 5 Convert and Download link to download your new icon file.

Step 3 - Under the Project Settings in the UE4 editor, scroll down to your target platform (windows for example) to specify the new icon. You can also change the splash screen images here. These can be PNG files at 600x200 pixels in size.

Step 4 - Package your project and your new icon file will replace the Unreal U icon.

1 Like

Nice, Thanks !

looks like source control was blocking me :

SourceControl: Error: The following paths are ignored by one of your .gitignore files:
SourceControl: Error: Build/Mac/Application.icns
SourceControl: Error: Use -f if you really want to add them.

Simply modifying the folder so that it was included allowed the icon to be set as would be expected through the ui

You’re welcome. It took me a while to figure out what was wrong too :slight_smile:

I had the same question this place explains everything

I found out the hard way that if your file path to your .ico file has a SPACE, this will break it and UE will revert back to the default icon. Also, uncommon characters such as an exclamation point breaks it to. Underscores work.

So make sure you have no SPACES or SPECIAL CHARACTERS in the file path to the .ico file.

For anyone out there who might still have problems with your .ico on a packaged game, I’ve just finished writing The definitive guide on packaging icons for Windows executables after having similar issues myself, which took me many days trying to figure out how to properly resolve. So… you’re welcome! :slight_smile:

1 Like