How can I make my computer use NVIDIA GPU instead of Intel GPU?

I’ve set the NVidia Control Panel settings. They’re all set for UE4Editor.exe as shown in the answers/comments above. Also, my BIOS doesn’t have Optimus options. =(

This laptop setup is the Clevo W230sd, with a i7 (Intel Graphics HD 4600) and GTX 960M video card. And I’m using Windows 10.

I’ve tested the same project on my PC to make sure it wasn’t a Win 10 issue. It runs flawlessly. Also, as a reference point, my older notebook has a i7 (no Intel HD Graphics) and a GTX 560M and it runs ok, at 35fps.

By checking the output log in the engine, it says the chosen card is the GTX 960M. But how come the performance is so poor (50fps), almost the same as the GTX 560M? It runs Mortal Kombat X bot not Unreal?!!

Thanks in advance for your time!

Make sure that your Intel Integrated Graphics drivers are also up to date. I believe they are around version 15 now IIRC.

If you know that the GPU is actually being used this falls more into a performance question rather than a question for switching from integrated to card GPUs. This would be better served as asking as a separate question on the AnswerHub.

To narrow down any performance issues you can start by profiling the GPU and CPU for your games performance.

If you’re not familiar withe process of profiling you can start by having a look at this Support Stream and our documentation linked below:

Yeah I made it run. I have a laptop using Nvidia Optimus. No matter what a set for r.GraphicsAdapter Unreal always choosed Intel HD 4600. I noticed in logs that it might be because there is in fact no output on GeForce graphic. All output goes through Intel so all devices are connected to it.

So I made a fake display connected to GeForce acording to this: http://www.helping-squad.com/fake-connect-a-monitor/

Now when there is an output on both adapters UE choosing GeForce finally!

Cheers

Im 4 years late but disable intel driver in device manager and this will force the PC to use the Nvidia Display Driver. Problem Solved.

hi 7 years late here but I struggled with this when UE5 was released and tried lots of things before I got it to work so wanted to share my steps:

switched my driver to NVIDIA studio driver instead of game ready driver
ensured that all of my intel graphics card features were turned off ( anything that required extra internal graphics card processing
set settings in NVidia control panel under manage 3d settings ( I am running on a 3060laptop) : 1gb shader cache size, for UE5 application specific settings under “program settings” I set OpenGL rendering GPU to the Nvidia.

I messed with this for a long time but these were the last of the steps that I did before a final restart and when I fire up UE5 now everything works great with Lumen and Raytracing enabled, 60fps locked as it should be.

Hope this helps someone,
Cheers
Tele

1 Like