How can I change the download/install directory?

As use a ssd, I wish to switch the download directory to another drive because of low disk space. I don’t how to do that.

I’ve installed it to my L: drive, but it still requires space on the C: to store downloaded store content. This causes unpacking problems on my main drive.

Not exactly, his was about installing. Mine was about opening store content.

Hey iFire,

It sounds like you’re having trouble with the location of the downloaded store content. Currently, the Launcher automatically looks for everything in the default location on your C: drive. We’re working on an update to let you choose the location for that. There is some more information here that might help you get around that:

Hope that helps!

Ben Halliday

This post was bumped (and then the bump removed by the poster) so I will go ahead and update this.

EDIT: With recent launcher updates, content sample projects are now automatically downloaded to the Vault in your engine install location. You can then make a copy of the project at any location you choose.

Cheers

Hi, has there been any progress regarding this?
I do not have the required 18gb free space on my C drive and would like to install to a new drive. However it gives me no option to select my install directory.

Something i feel is lacking considering the usage of small SSD for OS.

Please note. Not for the downloads of sample content but for where to install the Engine.
I had to delete all my builds but now when i try to install it requires `18gb. I do not have 18gb.

And there is nothing i can further remove from my drive

Hi Crocopede,

If you uninstall from your SSD, you can download the installer to your secondary drive and install there. This should put everything, including the Vault and all Engine content, on the other drive. Is that not working for you?

Use "MKLINK /D link target"command to link a directory to another location. In a command prompt opened as administrator. This is native to Windows stuff.

Use it for almost anything.

Two changes i made: launcher seems to duplicate and patch a copy of engine (4.7 preview is sitting at 20GB for me) before replacing it. And VaultCache (store content) is just fine on my HDD instead of my small C-drive/SSD.

    cd \Program Files\Epic Games\Launcher
    (First move PatchStaging and VaultCache to other drive, root of E:\ for me with Windows Explorer)
    mklink /d PatchStaging E:\PatchStaging
    mklink /d VaultCache E:\VaultCache
    
     Directory of C:\Program Files\Epic Games\Launcher
    
02/02/2015  07:24 PM    <DIR>          Backup
12/11/2014  01:19 AM    <DIR>          Engine
02/12/2015  07:28 PM    <SYMLINKD>     PatchStaging [E:\PatchStaging]
01/07/2015  02:31 AM    <SYMLINKD>     VaultCache [E:\VaultCache]

Make sure the /d is there and it says SYMLINKD.

This works fine with the 4.6, 4.7 engine folders. This works fine with Unreal Projects folder in your Documents folder.

edit: updated Launcher Troubleshooting guide: Tips and Tricks

Hi.

Apologies for the misunderstanding. I was hoping there was a way to keep the installer on my C:\ and only have the engine on the d:\

However i read on the forums that its essential they reside next to each other. I am in the process of contemplating uninstalling and re-installing.

Thanks for the feedback. Have a great weekend.

Yes there might be issues with relative pathing (… stuff).

The symlinks should make this transparent. As far as UE4 is concerned, its asking for Epic Games\4.6 and its getting 4.6 (Not E:\4.6 as in example).

Also last option, windows does let you mount an entire hard drive partition onto a directory. Just un-assign the drive letter of that partition and mount it on directory. Inside Disk Management. (same right click absolute lower left on Win 8.1)

29934-mount.png

For me the mklink didn’t work as well as no other workaround I found in the Internet.

I had 4.9 and 4.10 installed on C:\program files\epic games\ and just cut the “epic games”-folder and pasted it to D:\program files…

  1. Verifying didn’t work BUT this could be solved by starting the launcher with Admin-Rights.

  2. With Admin-Rights repairing/verifiying works BUT the launcher would create new folders on C:\ all the time and I didn’t find any manifest-files/Ini-files to change the target-directory

  3. THE SOLUTION: was to uninstall 4.9 and 4.10 via Launcher.
    3.1 I just clicked “uninstall”. This DIDN’T deleted my 4.9 or 4.10 folders in D:\program files\epic games\ - they’re still there which is awesome.
    3.2 I just restarted the launcher and now it noticed the folders on D:\ and started verifying BUT failed!
    3.3 I had to start the Launcher again with Admin-Rights and then the verifiying worked!

I found this open source app which changes the default installation folder of windows installers
maybe it helps :slight_smile:

That is how I originally had my 4.6 install. Then somewhere along the line I either reinstalled the launcher or something and it put my new stuff in the Program Files directory. Which for a developer is a really bad place to put things. It seems the launcher is really designed for end users of games and not developers. Anyway, I find almost all of my SSD space is gone because of this and was wondering what the heck happened. So I am copying everything over hoping the launcher will get it right though it will be run from a different directory. I really DONT EVER want to try developing from a program files directory. Just dealing with permissions would be horrible.

I have tried this. Now it will not recognize my 4.6, 4.9, or 4.10 installs. I made sure the launcher is installed to my E: drive, but I had to move it because the installer forces to C: drive. This is very bad that you cannot choose the install directory. I cannot get the launcher to even see the installed files now. When it went to repair it was downloading to Program Files again even though the launcher is running from E: drive now.

Correction, I had to completely uninstall first. Then the installer would give me the option to change the directory. If there is an existing launcher installed it will not let you choose. Now it is recognizing my existing projects.

this is not a solution, this didnt work at all

OK GUYS EVERYBODY LOOK HERE

Install Epic Games Launcher in wanted drive (D: if your C: is full) (I think it isn’t necessary)

Open Epic Games Launcher click on gear icon at upper right corner left from minimize THAN
in pop up window CLICK ON Edit Vault Cache Location AND ALMOST DONE in next pop up window
JUST CLICK Reset and Apply or (change C: to wanted drive in this case D:) AND that’s it.

OK GUYS EVERYBODY LOOK HERE

Install Epic Games Launcher in wanted drive (D: if your C: is full) (I think it isn’t necessary)

Open Epic Games Launcher click on gear icon at upper right corner left from minimize THAN
in pop up window CLICK ON Edit Vault Cache Location AND ALMOST DONE in next pop up window
JUST CLICK Reset and Apply or (change C: to wanted drive in this case D:) AND that’s it.