Download

GitHub dependency zips and latest-preview snapshots

Is setup currently working for OSX? As in the setup.command? Currently is just seems to exit.

EDIT: This is the latest promoted label.

It seems to be working fine on my Mac. Can you open a terminal window and run sh -x Setup.sh, then post the output?

That’s all I get… am I missing a dependency or something. This used to work however. I grabbed the latest via the github app.

is it possible that this Setup.bat is missing some Linux features take a look at my problem https://forums.unrealengine.com/showthread.php?57270-Could-not-determine-the-version-of-compiler-WHY

I don’t think so; you shouldn’t need anything other than what’s in GitHub to make this work. I’ll PM you.

Hi!

I see one global problem for user who behind the Proxy or don’t have Admin rights: they can’t get necessary files using Setup.bat

So, is it still possible to get them somehow?

Thank you in advance!

You can specify a proxy to use on the command line like this:



Setup.bat -proxy=http://username:password@address


Or alternatively, set the HTTP_PROXY environment variable.

Hi Ben, I’ve just tried this under Linux with Setup.sh and envvar, but had no success.

I just checked it on Windows in the master branch and it seems to work correctly, but I forgot that the version of GitDependencies in the release branch requires you to specify username and password through separate arguments:



Setup.bat -proxy=http://<address> -proxy-user=<username> -proxy-password=<password>


Does that help?

Sorry, I should have given more info!

I am on ‘master’ branch, perfectly up to date.
I tested this under Linux/Ubuntu 14.04 amd64 (up to date) behind a local http proxy handling the authentication to the corporate Windows proxy (so no authentication required for the script).

The script failed to fetch dependencies with ‘0% Result 1’, but then continue trying to compile third-party libs and exit saying SUCCESS while in fact nothing was done

~/workspace/UE4$ export HTTP_PROXY=http://localhost:5865/
~/workspace/UE4$ ./Setup.sh
Registering git hooks… (this will override existing ones!)

Github build
Checking / downloading the latest archives
Checking dependencies (excluding Win32, Win64, Mac, HTML5, Android)…
Updating dependencies:   0% (0/16093)…
Failed to download ‘http://cdn.unrealengine.com/dependencies/2369826-2acd3c361c9d4a858bd63938a2ab980e/07a88f4f32dff82062e33545b17b0011c4f3242b’: The remote server returned an error: (403) URLBlocked. (WebException)
Result: 1
Fixing inconsistent case in filenames.
find: “Content/Editor/Slate”: Aucun fichier ou dossier de ce type
find: “Content/Slate”: Aucun fichier ou dossier de ce type
find: “Documentation/Source/Shared/Icons”: Aucun fichier ou dossier de ce type

Building ThirdParty libraries

If you don’t see SUCCESS message in the end, then building did not finish properly.
In that case, take a look into /home/dev/workspace/UE4/Engine/Build/BatchFiles/Linux/BuildThirdParty.log for details.
==> BuildLND
**********  SUCCESS ****************

I’ve also tried the explicit -proxy param without any success.
Seems to me that the proxy is not taken into account under Linux.

Ah, okay! I don’t have a Linux box, so I’ll ask Dmitry to take a look.

I have just tried using HTTP_PROXY for GitDependencies on Linux and it picked it up…

A few more ideas to test:



export http_proxy=<your proxy>
wget http://cdn.unrealengine.com/dependencies/2369826-2acd3c361c9d4a858bd63938a2ab980e/07a88f4f32dff82062e33545b17b0011c4f3242b

That said, script should be fixed to fail when GitDependencies.exe fail. I did the change in the main (master) branch.

Thanks Dmitry, now I get the clean failure…

Problem is that our corporate proxy disallow the unrealengine.com domain :frowning:

Sorry for the time loss

No time loss, at least Setup.sh got improved to notice the failure! :slight_smile:

So, I just updated to the latest off release and when I run setup.bat, I’m now getting this:


D:\dev\UnrealEngine>Setup.bat
Checking dependencies (excluding Mac, HTML5, Android)...

Unhandled Exception: System.IO.IOException: The file exists.

   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.__Error.WinIOError()
   at System.IO.Path.InternalGetTempFileName(Boolean checkHost)
   at GitDependencies.Program.DownloadDependencies(String RootPath, IEnumerable`
1 RequiredFiles, IEnumerable`1 Blobs, IEnumerable`1 Packs, Int32 NumThreads, Int
32 MaxRetries, String ProxyUrl, String ProxyUsername, String ProxyPassword)
   at GitDependencies.Program.UpdateWorkingTree(Boolean bDryRun, String RootPath
, HashSet`1 ExcludeFolders, Int32 NumThreads, Int32 MaxRetries, String ProxyUrl,
 String ProxyUsername, String ProxyPassword, OverwriteMode Overwrite)
   at GitDependencies.Program.Main(String] Args)
Registering git hooks...
Installing prerequisites...
The system cannot find the file Engine\Extras\Redist\en-us\UE4PrereqSetup_x64.exe.

Win 7 - 64 bit. fetched using both cygwin + git and the native windows 7 Git Bash.

Any thoughts, or have I missed something earlier in this thread?

Just to add to this - I’ve cloned https://github.com/Nuclearfossil/UnrealEngine.git directly and am still seeing the same error.

OK, switching over to promoted seems to work. Interesting.

Let me clarify, promoted now allows me to run Setup.bat.

Running GenerateProjects.bat gives this:



D:\dev\epic-UnrealEngine>GenerateProjectFiles.bat
Setting up Unreal Engine 4 project files...
Binding IntelliSense data... 100%
Writing project files... 0%
UnrealBuildTool Exception: System.IO.IOException: The file exists.

   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.Path.InternalGetTempFileName(Boolean checkHost)
   at UnrealBuildTool.Utils.SetEnvironmentVariablesFromBatchFile(String BatchFil
eName) in d:\dev\epic-UnrealEngine\Engine\Source\Programs\UnrealBuildTool\System\Utils.cs:line 183
   at UnrealBuildTool.VCEnvironment..ctor(CPPTargetPlatform InPlatform) in d:\dev\epic-UnrealEngine\Engine\Source\Programs\UnrealBuildTool\Windows\VCEnvironment
.cs:line 73
   at UnrealBuildTool.VCToolChain.GetVCIncludePaths(CPPTargetPlatform Platform) in d:\dev\epic-UnrealEngine\Engine\Source\Programs\UnrealBuildTool\Windows\VCToo
lChain.cs:line 1677
   at UnrealBuildTool.VCProjectFile.WriteProjectFile(List`1 InPlatforms, List`1InConfigurations) in d:\dev\epic-UnrealEngine\Engine\Source\Programs\UnrealBuild
Tool\System\VCProject.cs:line 364
   at UnrealBuildTool.ProjectFileGenerator.WriteProjectFiles() in d:\dev\epic-UnrealEngine\Engine\Source\Programs\UnrealBuildTool\System\ProjectFileGenerator.cs
:line 2022
   at UnrealBuildTool.ProjectFileGenerator.GenerateProjectFiles(String] Arguments, Boolean& bSuccess) in d:\dev\epic-UnrealEngine\Engine\Source\Programs\Unreal
BuildTool\System\ProjectFileGenerator.cs:line 608
   at UnrealBuildTool.UnrealBuildTool.GenerateProjectFiles(ProjectFileGeneratorGenerator, String] Arguments) in d:\dev\epic-UnrealEngine\Engine\Source\Program
s\UnrealBuildTool\System\UnrealBuildTool.cs:line 1238
   at UnrealBuildTool.UnrealBuildTool.Main(String] Arguments) in d:\dev\epic-UnrealEngine\Engine\Source\Programs\UnrealBuildTool\System\UnrealBuildTool.cs:line
 1085

GenerateProjectFiles ERROR: UnrealBuildTool was unable to generate project files
.

Press any key to continue . . .


I think I may have found the issue.

Apparently my temp folder’s root was quite … full. And this is indicative of the crash I’m seeing.

I’ll see what I can do about reproducing it more and potentially add some reporting code for it.

Hey Ben,

Really great tool, a true time saver!

I was just wondering, how did you manage to assocaite asset versions to concrete git commits but actually don’t clutter git repo? Was it something like git-annex or custom solution? I’m thinking about rolling similar system but it makes me wonder what’s the best practice to do on backend side?

Cheers!