Download

game types problem

I wanted to add a cover system and I added a game type that contain such script, however problem arose , which is when I play in Editor the system is working however, when I play on PC UTGame type is the one who is applied however, I have changed the game types in the world properties and the default gametype in the config files

OK bro, however try now, after you begin the game, on the menu you click on “Instant Action”, then you click on “Game Mode”, change from Deathmatch to your custom game mode (i.e PowerGame). Then you click on Map, select your map (however your map will only appear on the list if you added the correct prefix as defined in the ini files, like DM-Yourmapname.udk, then you click on StartGame.

Now you will see the coversystem working perfectly. Like I said, if you extend UTGame this will always happen, and you need to make many changes even on the flash/scaleform menus (remove some menu items, and so on) to be able to completely customize your game.

Think like extending UTGame is like if you were creating a Total Conversion MOD for Unreal Tournament 3 using UDK Engine. If you extend UDKGame instead, you will begin from scratch.

However, for my game, as I, since the beginning of developing my game, wanted to make many game modes, like Campaign Mode, Base Invasion, Enemies Horde, so because this extending UTGame is the perfect solution for me, so I can have all the game rullings already setup, just change/remove what I need, as well because my game is a ThirdPerson Shooter.

Let’s say if I was making a puzzlegame, platformer, racing game, I would not extend UTGame.

Hope my explanation helps you.

Oh yes! Finally PIE works like Play on PC! I’ve changed the supported gametypes of the map (now I know why you said there were 3 places to set it, geodav) and added this to my GameInfo subclass:

static event class<GameInfo> SetGameType(string MapName, string Options, string Portal)
{
return Default.Class;
}