Epic Games Launcher: Error! No Version Received

So, I’m trying to install Unreal Engine 4 and when I attempt to sign in using the Epic Games Launcher, I get an error saying “Error! No version information received.”, if I click retry the same thing happens. When I click OK and type in my Email and Password and hit Sign In I get this error “Error! Did not get a response. Are you connected to the internet?” and nothing happens after that. I’ve tried literally everything… changing DNS, disabling firewall/antivirus, giving access to the program in both antivirus and firewall, restarting my computer, re-installing the launcher, adding “-HTTP=Curl” to my target path. Not sure what else I can try, and not sure what’s going on. I’ll provide my system details and a launcher log.

System Info:

MSI GTX 970,
120GB SSD + 1TB HDD,
Windows 7 Home Premium 64-bit

Launcher Log

Not sure if you need any more information than that, if you do let me know and I’ll try to get it for you.

Hi xGray,

After you try Xenlock’s suggestion above, if the issue still persist let us know.

The logs that you uploaded are the standard launcher logs. Could you post the ‘Verbose logs’ as well?

The directions on how to find them are located towards the bottom of that troubleshooting page.

I’ve the same problem. Nothing helped yet. Here are my log files.link text

Hi Tobyy,

It looks like every recent log in your folder is the standard launcher logs. Could you follow the steps in the link I posted below and enable your Debugging logs? Post them here once you get them.

It also seems like “Bitdeffender” blocks the Launcher from connecting.

Some guys in the forum group fixed it by deleting that program.

Can you try this? At the end of the Target path, add: " -http=wininet" without the quotes, then apply and restart your Launcher

-Max B.

Thanks! That fixed it. What exactly does that do? Just wondering what the actual problem was and if its anything I should try to fix for other programs in the future. Thanks again.

you can refer to the answer on this answerhub thread for a more technical explination: Error! No version information received - Programming & Scripting - Epic Developer Community Forums

Thanks! It seems to fixed it in my case too.

I’ve tried all of these options and nothing at this time has worked :frowning:

Adding -http wininet to target path did not work for me. Please help me guys .

Try the following:
The string you need to add is -http=wininet (Make sure to add the equal = sign)
Make sure to add a space between the file path and the -http=wininet

A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

Disable BitDefender (or any other antivirus), see if it fixes the issue. If it does, add an exception to your antivirus

Turn your firewall off and add an exception for the EpicGamesLauncher.exe if necessary

Disable Teredo tunneling if you’ve got that running

I have tried everything in that link except for that proxy. Is there any way to bypass the proxy ? . Im using internet in my college. Any ways to bypass it will be helpful.

The best way would be to approach the university’s IT dept. and tell them to allow connections to Epic’s servers. Any other way would be unethical, but if you must, a simple Google search would give you the answers.

What is the size of the Unreal Engine 4 ? i will try to download it somewhere else.

~ 4GB for the engine. More if you want Content examples.

I have found a new solution if everything else fails. I had the same problem and tried everything on the internet. Literally everything! Change proxy, adding -http=wininet etc etc… my solution was making a new user on my computer. Found this solution nowhere on the internet… on the new user it just works…try that if everything else fails