Editor crashes everytime I open my project

I was editing a collapsed graph, and deleted some nodes. I undid the deletes and everything came back. I went up to the event graph, and saw I had a few errors popping up. I compiled to get rid of them like normal and the engine crashed to desktop.

Tried to open my project again from the launcher and got a crash, I crash every time I open the project. I really need to try and get this back.

Error log


Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: InputSink != NULL [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Editor\KismetCompiler\Private\KismetCompiler.cpp] [Line: 2922]

KERNELBASE + 37901 bytes
UE4Editor_Core + 3092333 bytes
UE4Editor_Core + 1597672 bytes
UE4Editor_Core + 1479042 bytes
UE4Editor_KismetCompiler + 501530 bytes
UE4Editor_KismetCompiler + 502431 bytes
UE4Editor_KismetCompiler + 403128 bytes
UE4Editor_KismetCompiler + 415220 bytes
UE4Editor_KismetCompiler + 359446 bytes
UE4Editor_KismetCompiler + 370653 bytes
UE4Editor_KismetCompiler + 369118 bytes
UE4Editor_UnrealEd + 9877018 bytes
UE4Editor_UnrealEd + 9617164 bytes
UE4Editor_CoreUObject + 626800 bytes
UE4Editor_CoreUObject + 946322 bytes
UE4Editor_CoreUObject + 1054484 bytes
UE4Editor_CoreUObject + 878004 bytes
UE4Editor_CoreUObject + 686086 bytes
UE4Editor_CoreUObject + 1094210 bytes
UE4Editor_CoreUObject + 946764 bytes
UE4Editor_CoreUObject + 1054484 bytes
UE4Editor_CoreUObject + 944791 bytes
UE4Editor_CoreUObject + 947419 bytes
UE4Editor_CoreUObject + 1062891 bytes
UE4Editor_CoreUObject + 1460613 bytes
UE4Editor_CoreUObject + 1193007 bytes
UE4Editor_CoreUObject + 1189666 bytes
UE4Editor_CoreUObject + 1193874 bytes
UE4Editor_CoreUObject + 1189666 bytes
UE4Editor_CoreUObject + 1193874 bytes
UE4Editor_CoreUObject + 1189666 bytes
UE4Editor_CoreUObject + 1189156 bytes
UE4Editor_CoreUObject + 976397 bytes
UE4Editor_CoreUObject + 1185872 bytes
UE4Editor_CoreUObject + 951800 bytes
UE4Editor_CoreUObject + 1026078 bytes
UE4Editor_CoreUObject + 1460171 bytes
UE4Editor_UnrealEd + 2768012 bytes
UE4Editor_UnrealEd + 2700861 bytes
UE4Editor_UnrealEd + 2612749 bytes
UE4Editor_UnrealEd + 6316416 bytes
UE4Editor_UnrealEd + 3168772 bytes
UE4Editor_UnrealEd + 3167944 bytes
UE4Editor_UnrealEd + 6555369 bytes
UE4Editor_UnrealEd + 6310846 bytes
UE4Editor!GuardedMain() + 285 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launch.cpp:123]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Hi esquire,

I’ll be looking into your issue. In the meantime, could you find and post your LOG and DMP files from the crash? Follow the link below for directions on where to find them.



Even though you hit undo, it looks like a reference for one of the nodes is missing. Try this:

  • Make a clone of your project.

  • Go into the project through Windows Explorer and move the .uasset that you were working on when the project crashed out of the project. Don’t delete it, just move it.

  • Try to load the project.

  • If it does load up, try moving the .uasset back into the project.

Let me know how that goes.

\Well that worked to get the project open. When I moved the asset back into the project it showed up. When I tried to open it, I got a crash again. So its definitely my characters BP graph. I couldn’t attach the logs because it said .log wasn’t an allowed file type and .dmp had no such upload.

Thanks for the super quick help. Any ideas on how I can get back into that graph? Or can I try to find an autosave of that specific asset?

As long as you zip the log and dmp files they should upload fine.

You can see if a backup of the blueprint was generated. Just make sure to copy/paste them so not to lose any backups.

:\Users\YourName\Documents\Unreal Projects\YourProjectName\Saved

Hi esquire,

We haven’t heard back from you in a few days, so we are marking this post as resolved for tracking purposes. If you’re still experiencing this issue, please feel free to post back here and we can continue troubleshooting.