DOF doesn't work in the editor at all

Hello, I hope you can help me out with the odd issue I’m having with my editor.

K, so I am using the Substance plugin for my project. I can download the plugin and hook it up to UE4, and it works fine when running in the editor, but to launch or build the project I had to sign into ‘Githud’ and download the source version of UE4 so I can compile the code so the plugin will work. I got all of that to work, and packaging the project works just fine. The issue I am having is within the new editor I open up.

When I open the editor, there is no response to my ‘depth of field’ at all. I place a ‘post processing volume’ in the scene, check off the ‘unbound’ option, and change my ‘depth of field’ method to ‘gaussian’. No matter what value I put for any of the DOF settings, noting shows up in the editor. However, if I go into Visual Studio 2013 and make a build of the game, the game itself registers the DOF that I put in.

I wanted to see if this was project specific somehow, so I built an entirely new project from the new editor, and the same issue occurs. I don’t know what’s causing the issue. Unreal is downloaded, the ‘setup.bat’ was run, as well as the ‘GenerateProjectFiles.bat’ file. I have Visual Studio 2013 installed, and it’s hooked up correctly to Unreal. I can do builds and everyting else, but there is no ‘Depth Of Field’ at all in the editor.

I went back to my previous UE4 4.7.3 build before downloading the UE4 source, and the DOF there works just fine in the editor.

Can anyone give me a hand with this?

Hi C -

Just to clarify - You initially used the Launcher version of the editor (4.7.3) and installed the plug-in so Substance was working in the editor. Then after setting everything up you went to package (Launch) and the DoF was lost in the packaged (or Launched)? Could you let me know what you were attempting to Launch (or Package) for? Also when you went to gitHub did you get the Substance Branch of the engine or a branch from Epic and then install the plug in again?

Thank You for the clarifications -

Eric Ketchum

Hey Eric, Sorry for the late reply.

Not quite. I downloaded the launcher version of the editor (4.7.3) and installed the Substance plugin by downloading it through Allegorithmic’s website and placing it in the Plugin folder. This works just fine for testing the game in the editor, but I was never able to ‘launch’ it. I up online that the source code for Unreal is required to build any plugins into the actual code for your project. I downloaded Visual Studio 2013, hooked it up to the build I downloaded from the gitHud, ran the ‘Setup.bat’ and ‘GenerateProjectFiles.bat’ files (at first my Visual Studio wasn’t hooked up right, and it had an issue finding a few files, but I looked online and fixed those bugs). I took the Allegorithmic plugin code that I downloaded earlier and put it into the source code version of UE4.

Now, when I open the editor and look at everything, the allegorithmic plugin works just fine; However, the DOF does not. No matter what I try to do settings wise, it appears as though the DOF just doesn’t render in the editor for me. Even when I create a fresh project, the DOF isn’t registering correctly.

I am actually still having some issues with building and launching my project through the editor, so when I have time over this weekend I’ll be re-doing the process for downloading the latest UE4 build from gitHud, and I’ll be uninstalling and re-installing Visual Studio as well. I’ll try to cut out any issues I may be having on my end, but it’s hard to know exactly what’s going on for me since I am able to follow the steps for setting up the gitHud copy of UE4 without any warnings (after correctly directing some files to the right location such as where Visual Studio 2013 is installed), but when it comes time to launch or make a build, I constantly have issues with it.

It still seems very odd to me that the DOF doesn’t work in the editor. This leads me to believe that I must have done something wrong, but what I’m not sure.

Hi C -

I am going to run a specific test again regarding the launching of a project with Substance plug-in but you should starting with 4.7 be able to place the plug-in into the launcher version which includes the full source code and launching should package the project with teh correct plugin settings.

Take a look at this wiki entry I did for another user a while back about installing the Substance plug-in, you can check it against your steps.

Thank You

Eric Ketchum

Well, I made progress on getting everything set up correctly. I have the Substance Designer plugin installed, I have C++ code for my project, and I can build my project just fine. I am running the 4.7.4 build of the engine, and the DOF issue I was experiencing no longer exists. I can still run everything just fine in the editor, and if I do a ‘build solution’ within Microsoft Visual Studio 2013, it outputs a .exe that runs just fine. However, it is now giving me a new error.

Whenever I go to Launch the game or package it from within the editor, It spits out an error message that reads “ERROR: Exception in AutomationTool: You are attempting to compile on a machine that does not have a supported compiler!”

I up on different UE4 forums, and simple Google searches, and there was a lot of talk about editing a “vcvars32.bat” file, but no suggested changes to this file seems to fix the issue. I clearly have VS2013 installed, and I even recently re-installed it last night, so it’s as installed as that sucker’s gunna get! :slight_smile:

SO, I’m not sure what’s stopping UE4 from seeing the compiler software but it’s preventing me from packaging anything, or from launching the game from the editor.

Do you know of any solution to this problem?

(In case you’re wondering about my computers specs, here is the quick breakdown. Feel free to ask for more information if you need it, and thanks in advance for any help you might have.)

Windows 7,
64-bit Operating System,
Intel Core i7-2600 3.40 GHz,
8.00 GB of Ram

Hi -

Ok, so we are half way there maybe? On your computer in the folder structure containing Unreal Engine or Visual Studio OR your Computer’s Name OR your User Name, do you have any non-Latin Characters (including accent vowels or umlauts) or items which begin with Numbers?

If so you may need to change those items to only include A to Z no accents or Umlauts and 0 to 9 but not at the beginning of the folder name.

Let me know if you have tried this and I will continue to research,

Eric Ketchum

Hello again.

well, the folder structure for everything appears to be OK, and my computer user name was good, but my computer’s name was ‘Scruffy-PC’. Just to rule that out as a possible cause, I changed it to ‘ScruffyPC’.

I restarted my computer, booted up UE4, and Cooked my content (it says that everything was successful); but when I go to package my project for windows (32 or 64 bit), it fails and spits out “You are attempting to compile on a machine that does not have a supported compiler!”. So I went to File/Open Visual Studio and it opened up VS and the project in it just fine.

Any ideas?

  • Regards

Update: I noticed that there is an updated 4.7.5 version of UE4 available. I updated it to this version, opened up my scene and went through the regular steps to launch or package my game. Same result, It still gives me the error:

ERROR: Exception in AutomationTool: You are attempting to compile on a machine that does not have a supported compiler!

Ok, so let me ask do you have any other versions of Visual Studio on your CPU and if so can you try uninstalling them and see if that allows you to eliminate the error?

Let me know I am researching a few other items as well -

Eric Ketchum

I went into my uninstallation window and took a screenshot of what I have installed. The included image below is everything ‘Microsoft Visual’ related that’s on my system!

It appears as though only one version of ‘visual studio’ is installed.

Hey -

Quick test - Can you package or Launch a blank project with no starter content? and I know your project is C++ but are you using a source build or the launcher build?

Thank You -

Eric Ketchum

Hey Eric,

I did a test going through different steps taken that either work or don’t work when dealing with substance designer. If any of it isn’t too clear, just let me know and I’ll try to fill in more on what I did at that step.

(It was a bit lengthy and wouldn’t fit in this text box, so I included it in a text below. Hope it can help!)

Kind Regards

link text

Hi -

So I had a conversation with out programmers here and think I can get you back on track. First, a misunderstanding on my part and some clarification. While the plug-in will work when placed in the launcher it will cause problems in Launch and Packaging if it is not built into the engine source. To that end, I’ve edited my earlier Wiki Page to remove that section until a solution can be found.

For your problem, I would get Version 4.7.5 from GitHub,

Get the most Current Version of the Substance Plugin from here,

Extract the Engine to a Folder

Run the Setup.bat file

Extract the Substance Plug-in into the Engine\Plugin Folder created in previous step

Run the GenerateProjectFiles program

Build your UE4 Solution

Substance should now be running correctly and allow you to build.

Alternatively if your are ok with working with a slightly behind branch of the 4.7, you can simply pull the engine source directly from Allegorithmic’s Source Control on GitHub here,

Thank You

Eric Ketchum

Hello again Eric,

So I went through and followed the steps you provided in your last message. I downloaded the 4.7.5 version, and ran the ‘Setup.bat’ file. However, when I ran the ‘GenerateProjectFiles.bat’, I got this error message.

Setting up Unreal Engine 4 project files…
The system cannot find the files specified.
(repeats 7 times)
’msbuild’ is not recognized as an internal or external command,
Operable program or batch file.
GenerateProjectFiles ERROR: UnrealBuildTool failed to compile.

I did a search online, and I found this posting:

I changed the setting described in that post for the location of ‘msbuild.exe’, and I ran 'GenerateProjectFiles.bat again.

This time it had the same ‘The system cannot find the files specified.’ message, but it did run through the ‘Building Intellisense data…’ to 100%. Unfortunately I looked away and didn’t see if the ‘Writing Project files…’ finished, but when I ran the ‘Generate Project Files.bat’ again, it finished the ‘binding’ to 100%, but canceled before the ‘writing’ even had a chance to change from 0%.

I wanted to see if I could open the editor and see if by chance it worked, so I tried to find the UE4Editor.exe file. Normally it’s located here on my previous builds:
Unreal Engine\4.7\Engine\Binaries\Win64

So I went to that location in the source version of unreal, and the UE4Editor.exe doesn’t exist. I actually did a search for that file name, and it’s nowhere to be found in the Unreal folder at all.

I’m not entirely sure where to go from here, but I do have an older computer that I could possibly install Visual Studio onto, download the source code for UE4 again, and see if it will work on that computer instead of my work one. It wouldn’t be ideal for my project, but if I can get everything working with that computer, then at least I can make some builds.

I’ll let you know how that goes.

Hey C Albeluhn-

What is the file path where you extracted the zip file to? The line about “cannot find the files specified” lead me to believe that it can’t find the location where the files should be. Could you try extracting the zip to another location and run Setup.bat and GenerateProjectFiles.bat again?

Hey ,

The first time I did it, I placed the file in the same director as the other UE4 builds (C:\Program Files\Unreal Engine), but I named it this 4.7.5-SourceCode, and I got the error messages I mentioned earlier.

As you suggested I tried a new directory to see what it would do. I re-exported the zip files to my desktop, didn’t change a single name, ran the ‘Setup.bat’ just fine, but the ‘GenerateProjectFiles.bat’ still comes up with those same issues, and it still can’t find ‘MSBuild’.

I did a lot of testing over the past two days in regards to this issue. The over all text is a little lengthy, so I included everything in a file for you guys to . (It wouldn’t all fit in this text box). I did manage to get the editor actually ‘running’, but ‘working’ is a different story.

link to text

Hey C Albeluhn-

I over the file you attached and the next step I would try before doing a reinstall of windows would be to try reinstalling the editor. Uninstall and delete UE4 files from your computer and then download the source again (either the 4.7 branch or the release branch). Let us know if you’re able to run Setup.bat and GenerateProjectFiles.bat

Hey ,

Well… I removed everything. The individual builds, any windows installed UE4 based software, my windows temp folder, and everything else UE4 related I could find. I re-downloaded the source, ran the ‘Setup.bat’ just fine, and ran the ‘GenerateProjectFiles.bat’. I had to do the same fix as I mentioned earlier where I had to directly locate the MSBuild directory. Also, it still came up with the 7 error messages of The system cannot find the file specified.

I built the source of the engine, loaded it up, created default scene with the tables and chairs, and cooked the content. When I cooked it, I got 7 more The system cannot find the file specified. messages. And when I launch the default scene from within UE4, I get a message saying:
*PackagingResults:Error: Error Launch failed! Missing UE4Game binary.
You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:
UE4Game *

It also had this message near the bottom after it said the build failed. Could not find exe C:\Program Files\Unreal Engine\UnrealEngine-4.7.5-release\Engine\Binaries\Win64\UE4Game.exe

I have no idea why it’s doing this for me, but I am making an executive decision to back up my computer and re-install windows. I need a fresh start on all of this, because repeating the same things over and over isn’t getting me anywhere unfortunately.

I might be offline for a few days because of this, but as soon as I find out more I’ll update this posting. HOPEFULLY There’s just something installed incorrectly, or some lingering files are causing issues possibly. Regardless, a full format and restart should give us a new perspective.

(fingers crossed!)

I am a very happy artist!

Once I decided to format my main harddrive and start everything from scratch (work backed up of course), the process went a lot smoother. I had to install Service pack 1 for my windows 7, get some directX versions, and install Visual Studio 2013, everything else went smoothly. I no longer thet the 7 missing file warning message, and it locates the msbuild just fine. The files executed just perfectly. (with the Substance Designer plugin installed)

Once everything was done extracting, I built the solution of UE4, copied over my backed up project, linked it to the new source, and loaded it up in the editor. I did have it crash on me a few times when it was ‘discovering assets’, but I found a link that said to simply remove the ‘content’, open the editor, close it, put the content back in, and open it back up in the editor. For some reason, it stopped it from crashing during this step. With that out of the way, I started testing out some of the features I was having issues with before. The game runs fine in the editor, the ‘Launch’ works just fine, I can cook the content, and I can package it as well (I only tested packaging it for Windows 64-bit so far). But everything seems to work as expected.

I have no idea why it didn’t before. Obviously it was an issue with my computer and not your software, but I do wish that I could have found out exactly why it was doing what it was doing, and what software (if not multiple) are to blame for the mess up. Regardless, we covered a LOT of stuff on this Answerhub posting. At the very least, I hope it can help out anyone who may run into the same issues I have.

I am deeply thankfull for the help you guys have given me. Even though I had to format everything, at least I have a fresh clean install of everything and I know things are working correctly now. (It’s one less stress)

Again, thank you all so much!