Crash of packaged game "Assertion failed: SchemaIt != SchemaEnd"

Hey there. I fiddled around with Facial Mocap and Live link in UE5 Preview 1. In editor everything works perfectly, but when I package the App and try to execute it, I get the following error:

Screenshot 2022-02-26 122112

Does anyone know where the problem could lie? Here is the callstack from the crashlog:

[2022.02.26-10.59.48:637][  0]LogThreadingWindows: Error: Runnable thread FAsyncLoadingThread crashed.
[2022.02.26-10.59.48:637][  0]LogWindows: Error: === Critical error: ===
[2022.02.26-10.59.48:637][  0]LogWindows: Error: 
[2022.02.26-10.59.48:637][  0]LogWindows: Error: Assertion failed: SchemaIt != SchemaEnd [File:D:\build\++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\Serialization\UnversionedPropertySerialization.cpp] [Line: 669] 
[2022.02.26-10.59.48:637][  0]LogWindows: Error: 
[2022.02.26-10.59.48:637][  0]LogWindows: Error: 
[2022.02.26-10.59.48:637][  0]LogWindows: Error: 
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff7509bf9c3 Pseudocorpus_5_0.exe!SerializeUnversionedProperties() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff7509bf073 Pseudocorpus_5_0.exe!UScriptStruct::SerializeItem() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff750b2f7f6 Pseudocorpus_5_0.exe!FStructProperty::SerializeItem() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff7509bfa28 Pseudocorpus_5_0.exe!SerializeUnversionedProperties() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff7509b9658 Pseudocorpus_5_0.exe!UClass::SerializeDefaultObject() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff754d47753 Pseudocorpus_5_0.exe!UBlueprintGeneratedClass::SerializeDefaultObject() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff74ec0a8d2 Pseudocorpus_5_0.exe!UClass::SerializeDefaultObject() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff7508c0733 Pseudocorpus_5_0.exe!FAsyncPackage2::EventDrivenSerializeExport() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff7508c7b60 Pseudocorpus_5_0.exe!FAsyncPackage2::Event_ProcessExportBundle() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff7508cb793 Pseudocorpus_5_0.exe!FEventLoadNode2::Execute() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff7508e53d6 Pseudocorpus_5_0.exe!FAsyncLoadEventQueue2::PopAndExecute() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff750904584 Pseudocorpus_5_0.exe!FAsyncLoadingThread2::Run() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff7507e1dab Pseudocorpus_5_0.exe!FRunnableThreadWin::Run() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ff7507dacb0 Pseudocorpus_5_0.exe!FRunnableThreadWin::GuardedRun() []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ffdb89d54e0 KERNEL32.DLL!UnknownFunction []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: [Callstack] 0x00007ffdb9a0485b ntdll.dll!UnknownFunction []
[2022.02.26-10.59.48:637][  0]LogWindows: Error: 
[2022.02.26-10.59.48:637][  0]LogWindows: Error: Crash in runnable thread FAsyncLoadingThread
[2022.02.26-10.59.48:647][  0]LogExit: Executing StaticShutdownAfterError
[2022.02.26-10.59.48:647][  0]LogWindows: FPlatformMisc::RequestExit(1)
[2022.02.26-10.59.48:647][  0]LogWindows: FPlatformMisc::RequestExitWithStatus(1, 3)
[2022.02.26-10.59.48:647][  0]LogCore: Engine exit requested (reason: Win RequestExit)
[2022.02.26-10.59.48:647][  0]LogDisplayClusterEngine: UDisplayClusterGameEngine::PreExitImpl
[2022.02.26-10.59.48:656][  0]Log file closed, 02/26/22 11:59:48

3 Likes

I get that crash too in a packaged game when I try to open up a Map from my main menu Map.

1 Like

The Problem still persists in Preview 2 of Unreal Engine 5.

I figured out that the Live Link Pose node in the Animation Blueprint seems to be the cause of the issue. Since the Facial Capture is the whole point of the project, I can’t really get rid of it. Anyway, this appears to be a bug with the Live Link Plugin.

grafik

5 Likes

I am also facing the same issue,

[2022.03.12-07.46.58:755][  0]Message dialog closed, result: Ok, title: The UE5-Demo_Store Game has crashed and will close, text: Assertion failed: SchemaIt != SchemaEnd [File:D:\build\++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\Serialization\UnversionedPropertySerialization.cpp] [Line: 669] 




[2022.03.12-07.46.58:755][  0]LogThreadingWindows: Error: Runnable thread FAsyncLoadingThread crashed.
[2022.03.12-07.46.58:755][  0]LogWindows: Error: === Critical error: ===
[2022.03.12-07.46.58:755][  0]LogWindows: Error: 
[2022.03.12-07.46.58:755][  0]LogWindows: Error: Assertion failed: SchemaIt != SchemaEnd [File:D:\build\++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\Serialization\UnversionedPropertySerialization.cpp] [Line: 669] 
[2022.03.12-07.46.58:755][  0]LogWindows: Error: 
[2022.03.12-07.46.58:755][  0]LogWindows: Error: 
[2022.03.12-07.46.58:755][  0]LogWindows: Error: 
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a9a71003 Demo_Store.exe!SerializeUnversionedProperties() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a9a706b3 Demo_Store.exe!UScriptStruct::SerializeItem() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a9be43b6 Demo_Store.exe!FStructProperty::SerializeItem() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a9a71068 Demo_Store.exe!SerializeUnversionedProperties() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a9a6ac98 Demo_Store.exe!UClass::SerializeDefaultObject() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7ade3ffd3 Demo_Store.exe!UBlueprintGeneratedClass::SerializeDefaultObject() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a82c9b92 Demo_Store.exe!UClass::SerializeDefaultObject() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a99717c3 Demo_Store.exe!FAsyncPackage2::EventDrivenSerializeExport() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a9978bf0 Demo_Store.exe!FAsyncPackage2::Event_ProcessExportBundle() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a997c823 Demo_Store.exe!FEventLoadNode2::Execute() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a9996526 Demo_Store.exe!FAsyncLoadEventQueue2::PopAndExecute() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a99b57e4 Demo_Store.exe!FAsyncLoadingThread2::Run() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a9891ceb Demo_Store.exe!FRunnableThreadWin::Run() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ff7a988abf0 Demo_Store.exe!FRunnableThreadWin::GuardedRun() []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ffb3b2254e0 KERNEL32.DLL!UnknownFunction []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: [Callstack] 0x00007ffb3c98485b ntdll.dll!UnknownFunction []
[2022.03.12-07.46.58:755][  0]LogWindows: Error: 
[2022.03.12-07.46.58:755][  0]LogWindows: Error: Crash in runnable thread FAsyncLoadingThread
[2022.03.12-07.46.58:763][  0]LogExit: Executing StaticShutdownAfterError
[2022.03.12-07.46.58:763][  0]LogWindows: FPlatformMisc::RequestExit(1)
[2022.03.12-07.46.58:763][  0]LogWindows: FPlatformMisc::RequestExitWithStatus(1, 3)
[2022.03.12-07.46.58:763][  0]LogCore: Engine exit requested (reason: Win RequestExit)
[2022.03.12-07.46.58:780][  0]Log file closed, 03/12/22 13:16:58
1 Like

Actually the crash is still there even after removing the Live Link Pose.

ok then the problem lies somewhere else :pensive:

I had the same error. I just unhooked(Made it not execute) everything to do with that variable, including in other blueprints, and then it worked.

2 Likes

Just tested this and worked just fine! Thank you!

1 Like

This fixed my issue too. I couldn’t disable the plugin, but just not using the node stopped it from crashing in a packaged build (no errors inside the editor)

1 Like

Thanks for the help! I’m having this issue when including any MetaHumans in my project (which had previously worked in UE5 Preview 2). Removing the Live Link Pose from being called in the AnimGraph of Face_AnimBP fixed the issue.

Edit: Also having trouble with MetaHuman hair. It seems both issues are related to missing dependencies in the build.

Confirming the exact same error, using UE5 release build and freshly generated metahumans with a blueprint project.

In the Editor, everything runs fine and smooth.
But in a cooked / packaged program, the very exact same Error ( Assertion failed: SchemaIt != SchemaEnd, etc.) appears in the crash.

Even after completely deleting all anim/pose files from the metahumans directories and re-cooking, i still got the same issue.

The only way to solve it for me seemed to be to delete all Quixel-Bridge imported metahumans out of all levels / Scenes, then the project does not crash anymore. Kinda… unpractical. :smiley:

I’ll re-implement the Metahumans and try manually removing LiveLink nodes from the FaceAnim. Let’s see if that does the trick here as well :slight_smile:

Edit: I edited Face_Anim_BP in the common folder under Metahumans. Sadly, it did not work. Still crashes with UnversionedPropertySerialisation. Maybe there are other blueprints or animation blueprints that link to livelink, but i’m just an UE5 Beginner. Both Metahumans i imported don’t seem to have an own Face_Anim_BP.
Guess i’m back to the mannequin til the next patch :wink:

2 Likes

It works! Thank you.

1 Like

Getting the same issue here with UE5.
Removed the liveLink node from the Face_AnimBP and I still get the error on mine.
I just have one metahuman in my map that I created, works fine play mode.
:frowning:

Hi, could you say which other blueprints you mean please? As i can only find it in the Face blueprint.
Many thanks
EDIT - I have it working on mine now.
There is also a livelink node in the Metahumans Skeletal mesh, it was in the Face folder of my own metahuman, i just bypassed the node at the start and now it works in the build. Hair is fine also. So to clarify i remove the live link node in the BP of the character as mentioned above but also the skeletal mesh.
Hope that helps someone
:slight_smile:

It’s solved here.

And EASY, without changing any metahuman blueprints.

After Update to 5.0.1:
→ I activated “Faceware Live Link” Plugin under “Project Settings → plugins”
Restarted UE, packaged the project (dev build). Testrun: works like a charm.

Additional info: I removed my metahuman folder from my little test project before patch 5.0.1. After the Update, i added a freshly downloaded metahuman into the project and placed it on the map.
First package without activated plugin: Same error as before.
Checked installed plugins and enabled the plugin: after packaging the project it runs without errors.
Cross-check with build setting “shipping”: Works fine as well!

1 Like

I think this is related to the Apple ARKit face support.
I resolved this error by enabling this plugin.
Indeed the LiveLink is waiting for any face tracking so it seems to crash if you don’t enable any face tracking system.
But disabling LiveLink in any animation BP should also do the trick i f you don’t want to real-time animate your MetaHuman in your app

I’ve found a solution that doesn’t require enabling any extra plugins, as well as finding a fix for my hair issue!

LiveLink doesn’t need any additional face tracking system as far as I can tell. There’s just an Unreal bug where its dependencies aren’t being included in builds.

The solution for the main issue requires you to be using a C++ project, and involves adding "LiveLinkAnimationCore" into the list of PublicDependencyModuleNames in the “<Project name>.Build.cs” file (which can be found in the folder “Source\<Project name>”).

If you don’t have a C++ project, you have to include another plugin that includes the correct module, such as the “Apple ARKit Face Support” or “Faceware Live Link” plugins mentioned earlier in the thread.

The fix for the hair can be used by anyone who hits the same issue, and just involves adding the following code into the list of plugins in your .uproject file.

		{
			"Name": "HairStrands",
			"Enabled": true
		},

Edit: As I mention in a later comment, Apple ARKit is now automatically enabled when adding MetaHumans for the first time, so that should be taken as the “correct” solution.

6 Likes

Good afternoon, I have exactly the same problem, but I don’t use Facial Mocap and Live link in my project. Tell me what to do.

BUTnv has summarized in which blueprints the livelink nodes have to be disconnected, if they are not used.
davisctools mentioned a method when using a C++ project.

thank you so much, this fixed my problem