Crash of packaged game "Assertion failed: SchemaIt != SchemaEnd"

Confirming the exact same error, using UE5 release build and freshly generated metahumans with a blueprint project.

In the Editor, everything runs fine and smooth.
But in a cooked / packaged program, the very exact same Error ( Assertion failed: SchemaIt != SchemaEnd, etc.) appears in the crash.

Even after completely deleting all anim/pose files from the metahumans directories and re-cooking, i still got the same issue.

The only way to solve it for me seemed to be to delete all Quixel-Bridge imported metahumans out of all levels / Scenes, then the project does not crash anymore. Kinda… unpractical. :smiley:

I’ll re-implement the Metahumans and try manually removing LiveLink nodes from the FaceAnim. Let’s see if that does the trick here as well :slight_smile:

Edit: I edited Face_Anim_BP in the common folder under Metahumans. Sadly, it did not work. Still crashes with UnversionedPropertySerialisation. Maybe there are other blueprints or animation blueprints that link to livelink, but i’m just an UE5 Beginner. Both Metahumans i imported don’t seem to have an own Face_Anim_BP.
Guess i’m back to the mannequin til the next patch :wink:

2 Likes

It works! Thank you.

1 Like

Getting the same issue here with UE5.
Removed the liveLink node from the Face_AnimBP and I still get the error on mine.
I just have one metahuman in my map that I created, works fine play mode.
:frowning:

Hi, could you say which other blueprints you mean please? As i can only find it in the Face blueprint.
Many thanks
EDIT - I have it working on mine now.
There is also a livelink node in the Metahumans Skeletal mesh, it was in the Face folder of my own metahuman, i just bypassed the node at the start and now it works in the build. Hair is fine also. So to clarify i remove the live link node in the BP of the character as mentioned above but also the skeletal mesh.
Hope that helps someone
:slight_smile:

It’s solved here.

And EASY, without changing any metahuman blueprints.

After Update to 5.0.1:
→ I activated “Faceware Live Link” Plugin under “Project Settings → plugins”
Restarted UE, packaged the project (dev build). Testrun: works like a charm.

Additional info: I removed my metahuman folder from my little test project before patch 5.0.1. After the Update, i added a freshly downloaded metahuman into the project and placed it on the map.
First package without activated plugin: Same error as before.
Checked installed plugins and enabled the plugin: after packaging the project it runs without errors.
Cross-check with build setting “shipping”: Works fine as well!

1 Like

I think this is related to the Apple ARKit face support.
I resolved this error by enabling this plugin.
Indeed the LiveLink is waiting for any face tracking so it seems to crash if you don’t enable any face tracking system.
But disabling LiveLink in any animation BP should also do the trick i f you don’t want to real-time animate your MetaHuman in your app

I’ve found a solution that doesn’t require enabling any extra plugins, as well as finding a fix for my hair issue!

LiveLink doesn’t need any additional face tracking system as far as I can tell. There’s just an Unreal bug where its dependencies aren’t being included in builds.

The solution for the main issue requires you to be using a C++ project, and involves adding "LiveLinkAnimationCore" into the list of PublicDependencyModuleNames in the “<Project name>.Build.cs” file (which can be found in the folder “Source\<Project name>”).

If you don’t have a C++ project, you have to include another plugin that includes the correct module, such as the “Apple ARKit Face Support” or “Faceware Live Link” plugins mentioned earlier in the thread.

The fix for the hair can be used by anyone who hits the same issue, and just involves adding the following code into the list of plugins in your .uproject file.

		{
			"Name": "HairStrands",
			"Enabled": true
		},

Edit: As I mention in a later comment, Apple ARKit is now automatically enabled when adding MetaHumans for the first time, so that should be taken as the “correct” solution.

6 Likes

Good afternoon, I have exactly the same problem, but I don’t use Facial Mocap and Live link in my project. Tell me what to do.

BUTnv has summarized in which blueprints the livelink nodes have to be disconnected, if they are not used.
davisctools mentioned a method when using a C++ project.

thank you so much, this fixed my problem

most advanced game engine may buttox

there is no such plugin ya but head

The Marketplace browse you must.
This is the plugin you are looking for.

This Worked for me thank you!

1 Like

You are my favourite person today, thank you!

1 Like

Also a favourite person!

Even though we’re not actually using Live Link (yet), I can confirm that adding "LiveLinkAnimationCore" to the public dependencies in the .Build.cs fixes the assertion failure with packaged builds.

Thanks!

This doesn’t work for me, my version is UE5.02

installing Apple ARKit face support plugin fixed it for me, cheers

2 Likes

Apple ARKit is now automatically enabled when adding MetaHumans for the first time, so that should be taken as the “correct” solution.