Download

Build project for Vulkan

Is there any documentation on how to deploy to Vulkan?

I have my S7 and a project that I have successfully build in the past for Android.

I have tried building for Vulkan with 4.12 compiled from Github, I think I have everything required installed, but the build keeps failing.

Any hint on the steps to follow and requirements to successfully build for Vulkan would be much appreciated.

Thanks

Regards!

Hi Irigoyen,

With latest 4.12 you will need to first install LunarG Vulkan SDK on your PC. Build the editor. Run the editor and create your project. In the Android Project Settings, enable Supports Vulkan and package for ASTC or do a launch-on to your S7. Check the logcat to make sure it didn’t fall back to ES2 and used the Vulkan driver. You should see:

Compiled with Vulkan support
Vulkan library detected, checking for available driver
Vulkan driver available, will use VulkanRHI

You may also need to set the min/target SDK to 21; I don’t remember if this is necessary, but we do so in our tests.

Eeeh, ouch. Is it going to be available as stock checkbox option in maybe 4.13 ?

Maybe it implemented in 4.12 cross our fingers :wink:

Regards!

It will be easier once it moves out of Experimental.

Thank you for the answer.

I am getting this error, both in visual studio and Unreal, so I guess that is the problem, but I dont know why is not there.

Any hint?

Vulkan SDK is installed, but [SDK]/Source/lib/libvulkan.so was not found. Disabling Vulkan RHI for Android

Thanks again.

You need install libs in unix.

try with this. Installing And Testing Vulkan On Ubuntu – LinuxGameCast

Regards!

Thanks for the reply.

I am in windows though.
I have tried to copy manually libvulkan.so from and then recompile but I get this

Error C:/VulkanSDK/1.0.11.0/Source/lib/libvulkan.so: incompatible target

Hi Irigoyen,

This was a temporary workaround before Vulkan was released. The next 4.12 preview will remove this; we now check for it at runtime on device and properly fall back to ES2 if either the Vulkan loader is missing, or it is present but the device doesn’t have a Vulkan driver available. As I said above, Experimental :rolleyes:

Try to use the same settings.
https://vulkan.lunarg.com/app/docs/v1.0.11.1/getting_started_windows

Look System Requirements. Visual Studio 2013 Update 4 and this things.

Regards!

Thank you both for the help.

I’ll keep trying and report back.

Is this possible on MacOSx ?
I’m downloading UE4 4.12 Preview 3. What else do I need for me to be able to compile, for example, the Protostar demo?

Hi Sunchaser,

At the moment we can only generate Vulkan shaders on Windows. Mac OSX to package for Android Vulkan will be possible before it moves out of experimental.

I’ve been trying to build project using Vulkan to my s7 edge but result isn’t quite what I expect.
Any thoughts what might be the issue?
Build with 12.3 on windows.
In android settings only Vulkan is ticked.
c93623845be05caeaffa9fc521f04bb27941f2a9.jpeg

Is this on an S7 Exynos (Mali)? We are still making adjustments to the VulkanRHI and there will be updated drivers correcting issues.

Yes Chris that is correct. S7 Edge Exynos Mali.
Not pushing or anything but do you have any timeframe or is it just “we’re working on it”?

At this point we have fixed the issue on our side. I do not have any knowledge of release schedule for driver updates.

Thank you Chris