Build Failed with VS 2015 update 3

The fact that a software doesn’t do what you want right out of the box does not mean it has “bugs”. Maybe your expectation are just unrealistic. The issues are caused by stricter VS2015 U3 diagnostics, which I would describe as “features” not “bugs”, that are raising warnings about some shady compilation techniques used by Unreal. Just give Epic some time, I’m pretty sure with just a few tweaks Unreal will play fairly with VS2015 U3.

Works perfectly with VS2015U3. Thank you kindly, Tim!

Thanks, this resolved my problem !

Update: It does compile and will run in a debugging session in VS, but the files are not compatible with the launcher game (when using UT).

Please don’t take this the wrong way, I’m not trying to argue with you, I just want to illustrate why I said VS2015 is bugged:

“my expectation are just unrealistic”? You have no idea how much trouble VS2015 has given me. At first I had the “Roslyn package failed to load” that would prevent any file from being opened with VS2015. There is a active bug with Microsoft about this.https://connect.microsoft.com/VisualStudio/feedback/details/1342588/roslyn-package-failed-to-load-correctly-installing-2015rc
Even a txt file would crash VS2015. So no its not just Unreal that is the issue. Doing a repair did not fix, nor did uninstall and reinstall. I have had to completely wipe out my pc in hopes that VS2015 will work as it should. And even after a clean install, I have still had some issues with it. Finally got it working, only to have Update 3 break it. I have never had soo many problems and experienced VS crashing so often with any of the prior versions, dating back to Visual Studio.NET.

Thanks worked.

  1. open the WindowsPlatformCompilerSetup.h from the engine code
  2. remove 4599 from the table of warnings at the top
  3. add #pragma warning(disable : 4599) below the list

Thanks, worked !!!

Hi Guys,

apparently this problem is a bit more complicated than it seems. A colleague of mine update to update 3 before i could stop him and uninstalling the update didn’t work. It probably left some stuff behind. Also i needed to do a fresh install on a new machine and found no update 1 or 2 versions for download.

So here is the solution i found for both cases:

Unfortunately I could not find a way to install update 1 or 2 at this point. But at least it works.
Hope this is useful for some of you.

Or you can also add the lines:

#pragma warning(push)
#pragma warning(disable : 4599)
#include "Engine.h"
#pragma warning(pop)

I was having this problem with VS update 2 UE 4.12.2

This solution worked for that as well, thank you!

I found a workaround - basically remove 4599 and 4609 warning to error pragmas in Engine/Source/Runtime/Core/Public/Windows/WindowsPlatformCompilerSetup.h.

Here is a commit you can cherry-pick: https://github.com/Neurochrom/UnrealEngine/commit/89ab7a08af165cad02073261b4b8e7af61a63d2c

Thanks @Infected_Post, this did solve the issue.

For anyone getting into trouble because of this issue in 4.11:
the error message in 4.11 was slightly different:
Error C4599 ‘/IC:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE’: command line argument number 248 does not match precompiled header

It did costs me quite some hours tracing this ■■■■■■ down…

How to: Install a Specific Release of Visual Studio (i.e. Visual Studio 2015 with only the original Update 2 without any further Update 2-era updates or Update 3))

  1. If you have VS2015 with Update 3, you must completely uninstall it and reboot your PC. (You may have to use the VisualStudioUninstaller Release 2 worked for me where the latest did not)
  2. Download the VS2015 with Update 3 websetup from VisualStudio.com (example: vs_community_ENU.exe) It does not matter that it is the Update 3, we are going to force it to install Update 2 and not 3 in the next step
  3. “then append the .exe file with additional command-line parameters”. For the VS2015 community edition it would be (enter the following all as one line from a administrative command prompt):

vs_community_ENU.exe /OverrideFeedURI http://download.microsoft.com/download/0/6/B/06BB0C5C-C767-4250-91DA-AB463377597E/20160405.3/enu/feed.xml

Original instructions found at MSDN

I applied this workaround and it didn’t completely solve it for me with 4.12.4. I followed the same instructions for warning 4605 as above and that solved it however.

Thanks! Uninstalled Visual Studio 2015 Update 3, then reinstalled up to Version 2. Working correctly again!

Any timeframe for official Update 3 support?

I just added the line

#pragma warning(disable : 4599 4605)

after the big block of #pragma warning(error:…) up top. Order matters.

It seems to work fine in my setting (making editor plugins to support a production pipeline).

Hi TriNityGER,

We have a fix in place for anyone using the source code version of the Engine available from GitHub. You can get that fix here, and it should work fine in 4.10 and 4.11 as well. Unfortunately anyone using the Binary version of the Engine installed through the Launcher will still run into problems when using VS 2015 Update 3. We have logged ticket UE-32790 to track the issue with the Binary version of the Engine.

Tim

I have followed both infected_Post’s and Snake_Pliskin’s advice, including restart after uninstalling and running the VisualStudioInstaller. When I reinstall, it looks like only Update 2 will be installed… But ultimately, when I start up, I see in VS About/Help that it is still Version 14.0.25420.01 Update 3.

Update 3 keeps sneaking in! Any ideas what I am doing wrong?

You have to run the VisualStudioUninstaller tool. Try the newest release, and if that does not work, try the VisualStudioUninstaller Release 2. Then uninstall any thing related to VisualStudio (i.e. Windows SDK kits, Microsoft .NET Frameworks, Windows Phone Emulators, etc). Once everything is gone, REBOOT your PC.
Download the Visual Studio 2015 community ISO, mount the ISO
or download the Visual Studio 2015 community webinstaller.
Open a administrative command prompt, go to the folder where you have saved the webinstaller at or the root folder if its the ISO
Basicly you want to be in the same folder as the file vs_community_ENU.exe is in.
Most importantly, copy+paste the following into the command prompt, all as one line:

vs_community_ENU.exe /OverrideFeedURI http://download.microsoft.com/download/0/6/B/06BB0C5C-C767-4250-91DA-AB463377597E/20160405.3/enu/feed.xml

During install it will say “VS2015 with Updates” and once finished installing the VS about page will look like this:

I’m not having any luck uninstalling and reinstalling, either. I’m not sure what makes it not work on my computer. Maybe it has something to do with Windows 10…