Bone size too small to create physics asset

Hi guys,
When trying to import fbx with skeletal mesh exported from blender 2.7 and run through with fbx converter I’m getting warning that bone size is too small to create physics asset. Mesh is correct in size that is after importing it into UE4 and placing it next to 2m x 2m cube that mesh looks as is of good size.Any ideas why is that happening? I’m using UE4 4.6.1

Thank you.

How does the skeleton look in skeletal mesh editor? I’ve heard of this issue before; one way to fix it is to reset the bodies in Phat and set minimum bone scale to a smaller value while creating new bodies.

Hi Jacky,
Thank you for your reply.

The skeleton in mesh editor looks normal, that is, it looks exactly the same as it looks in Blender. I can see every bone, every bone has normal size.

I’ve figured that out so I thought that I’ll post my steps here so perhaps somebody with similar problems can simply follow them and save 3 days of banging wall and floor with his head, here it goes:

1.Rig mesh and make animations in Blender
2. Remove every material from this mesh. After unlinking your materials, save your file. Then reload it with Ctrl+Shift+O. This will ensure that no extra slots are exported with this mesh and you have just one material slot in UE4.
3.Unlink any textures in image editor of blender
4. Export in ASCII fbx with Skeleton and Mesh selected:
scale:100 must be rescaled by 100 in blender and exported with scale 1, that is make mesh as you would with “regular” dimensions, scale it up by 100, reset scale to 1, and export with scale set to 1
Axis:X Forward, Y UP, if that doesn’t make the rotation OK, set in UE4 in skeletal mesh editor roll to -90
5. Run through Fbx Converter
6. Import into UE4 selecting
a) import normals and tangents
b)create physics asset

Best regards

Had the issue too and got it working with these settings.

I also had the “Bone size too small cannot create physics asset” error. Turns out… it’s probably a bug in Blender. There is a ticket for it and there is a workaround described:

You can also use metric units with 0.01 scene scale (and apply transforms so both the mesh and rig are 1.000 scale), that way you can still modify the mesh and get good results.

after u did the whole metric 0.01 scale bla bla bla thingy u need to press ctrl A and apply rotation and scale to fix the bone size too small for physics asset

I might have found another solution. I had to set to radius of the Heads and Tails of my bones in Blender to a rather higher value. I still got the warning saying the bones were too small to autogenerate a Physics asset. But when i manually created bodies for the Physics asset, the simulation worked fine. It doesn’t spas out anymore.

I had same problem at 4.23 version UE: export FBX from 3ds max and got “bone too small” error. Export from Maya – same. Then tried to create physic asset on base mannequin (epic’s one) – error. Tried create physic asset on 4.22 – error. Then I download 4.2 version – and engine created physics asset from mine FBX successfully. Same fine asset on 4.12.
So yes, another solution: create physics asset on 4.12 and migrate it to 4.23 UE.

i had issues creating physic asset manually. The min bone size is the culprit. Just set to lowest possible value. Hope this would help others.


Thank you

The best anwer! saved my life! +1000