Binaries for Linux?

Hi guys!

Maybe some of you remember me from de IRC as the guy that couldn’t never build the editor on Linux… :smiley:

Well, I got some free time again on holidays and tried again, but the build process hogs my machine and kills the compilation process even for one file. (I tried to put only 1 parallel job at a time).

So… some time ago I was wondering how would be the editor distributed on Linux. It would be perfect in my case for having some binaries and using it in my Linux machine.

Has someone any idea of it?

Hi Mixu,

Presently we don’t know when will the binary Linux distribution happen. It is certain to say that when it does, download and installation will happen through the Unreal Engine Launcher, just like it works on the other two platforms.

A question for you though is, if you cannot even compile the Editor on your computer, what makes you think that you would be able to run it?

Everyone on the IRC is able to compile and run the editor on their computers, so I think it could be said that if you cannot compile it on a specific computer, you might not be able to run it either.

Perhaps you need to find out why/where your current computer bottlenecks and address that issue so that you can compile the Editor. If that’s not possible then really the only other alternative is to upgrade the hardware.

Hi amigo!
I got it once running. And my computer is capable of it, on Windows works, even inside a VirtualBox :stuck_out_tongue:
I’ve got an i7-4770k, 8GB of RAM, and a Nvidia GTX 560Ti, I think I have the minimum requeriments covered.

The bad part is that I’m using Arch Linux, I built UE4Editor with my system and it hogged. Using the docker system I managed to build it, but it seems to not run fine.
I’ve read there’s some threading problems with Arch and is recommended to make UE4Editor-Linux-Debug, but with docker I gets some strange things.

With the following command fails because there’s no MAKE target.

And with this one builds Linux Native Dialogs but not the UE4Editor-Linux-Debug (take not of the quotation marks)

On the first one the log of LND is this:

And if I change the command to this one (putting make before the make tag):

The output of LND is the following:

If with my system I issue “make UE4Editor-Linux-Debug” starts building it.

BTW, going back to the original question… :stuck_out_tongue:
I guess that with the distribution package manager would download the launcher, and then like Steam for Linux does download all the stuff.

Many people on the IRC are able to run it in Arch and also compile it there as well. If I recall correctly, we do not use docker anymore as an interim step since couple of weeks back and I think JKnife’s docker is out of date, too.

Firstly, and most importantly, never compile or run as “root” user. Create a normal user account and clone UE4 there, then compile and run.

Both epic/master and epic/promoted should run as of now and you might have best luck with them. Try epic/master first then go to epic/promoted if it doesn’t work.

Make sure you have working clang-3.5 and gcc toolchains in your Arch as well as all Mono dependencies satisfied, and otherwise follow the steps as outlined in the wiki. It should really be a straight forward process (cd UnrealEngine, ./, ./, make SlateViewer, etc).

I was using the release one on the other tries for building it.
So, just tried the promoted branch and… awesome, it works perfect! I can open some template projects! :smiley:

And good job to Epic and the Linux community, you rock!