Basic "This installation package is not supported by this processor type" thing

I might not have a high-end strong PC but at least I would like to try making some semi-realistic looking games.

So right after I download the Launcher (not install it), and click on it, it pops me out this message:

“This installation package is not supported by this processor type - contact the vendor”

I have Intel Pentium E5400, Dual-core. Am I hopeless?

I have also read at the system requirements that 64-bit version of Windows is recommended. But, is it needed? Since I have 32-bit.

…Hopeless?

Hi Skyzation,

We don’t support 32-bit windows. You can take a look at our recommended specs here: