Download

Assets missing in Mod folder

Hey everyone,
For some reason my mod has been working for a while and just recently two people stated that the item in my mod does not show up in Engram list. Now I found that strange so I test the game out for my self with my mod and sure enough the item does not show up in the engram list. So I have tried just about everything I can think of to fix it and then I realize where the issue is. No matter how many times I cook and upload when the game installs the mod on my PC, the folder only contains mod.info and mod.metainfo. Meaning that all my assets, such as primalgamedata file, engram entry BP file and every other file is not there. Does any one know why this would just happen out of no where and it is only one of my mods, as I have 6 or 7 I believe. Could it be a steam error? It is frustrating. Any help is appreciated.

I honestly have no idea. I’ve encountered an issue with my UI mod where the additional meshes for pawns, although now correctly staying in place in the devkit, in a cooked/uploaded version they’re not visible ingame at all.

More and more frequently the DevKit is behaving completely unexpectedly and doing things it shouldn’t be doing.

-WM

I had this happen to me - but I have 60-70 custom items that were using the main inventory and custom inventories. I asked for a developer insight on how many they can have per inventory - but alas, nothing. Once I removed a good chunk of them from the main inventory and put them into their very own crafting inventory, they all reappeared.

Well for my mod it is just a modified lamp posts. I mean its a new duplicated lamp post so no core data change but it is a very small mod. Not to mention it was working and then I think the game update for Ark just made all the uassets disappear. I think I might need to send the devs a message and see if they can shed some light on this bug as it makes no sense to just be deleted, and now every time I cook and upload the mod it shows my mod is not even 1 mb, so it could be the dev kit too but it happened before I could even uploaded any new version. Smh this is a pain

Want to check your level file again? no harm to see whether the references are still there…

dats wat happened to me :slight_smile:

Yea everything is there and reference, I feel like pulling my hair out lol. Something is not right I might just need to create a new mod :frowning: