Download

Any solution for the artifacts (the black stripes) using dynamic light with cascade shadows?

Using DX11 seems to solve the problem almost completely.

I’m considering to move to Dx12, but my problem with it is that it’s slower than dx9, especially when rendering skeletalmeshes. In my 100 bots test, dx9 gives 130 fps, and dx11 40 fps… but in the game the difference seems lower, with the skeletalmeshes more disperse, I think.

Also there are some good things like SSS. There are a problem with the specular in materials, but it can solved easily and with no extra performance loss: Specularity loss using movable light - Epic Games Forums

I’ve found shadows in UDK’s DX11 to look slightly worse (a bit more jagged edges) compared to DX9 but maybe it was just pointlights and not directional lights.
the performance difference seems not worth it though

CobaltUDK: "Using DX11 seems to solve the problem almost completely"

Hi Cobalt,
I was having this issue too in .13 but have just updated my engine to .18 and it’s NEARLY completely removed these intense artifacts for me.

I know there were some lighting improvments in the new update engine but I didn’t realise they made changes to this side of thing- the movable lights and hiw they cast shadows etc…

When I get a chance I’ll post some screenshots of before in .13 and after in .18 so you can see the difference. They are still there but much much less visible which is great.
As I’m doing my polys just with shaders though and no textures at all the problem was really apparent.

Anyway, I’ll continue testing the scene and let you know the results here- I hope I didn’t celebrate too early on this…!

Btw, are you using completely dynamic/movabke lights yes, for real time of day? If so, could you post your settings for the Skylight and the main Directional Light so I can compare what we have?

Ah sorry…! Just realised this is for UE3 whereas I’m using UE4…! Not sure if my post is still relvant though…!

Ah, how lucky that ue4 keeps updating.

I just came across this post, I had the same question. The way I solved the problem was to reduce “Dynamic Shadow Distance MoveableLight” under Cascaded Shadow Maps - I have set my directional light to movable.

please stop with the UE4 issues, this is the UE3 forum :wink:

@CobaltUDK Did you ever find a solution to this? I have always had this issue with my DDL and it’s very frustrating.

You mentioned ShadowDepthBias, do you mean on each of the individual materials, as I only see this property on the Material class?

Edit: I found it in DefaultSystemSettings. I’ve increased it and managed to mostly resolve this issue :slight_smile:

Yeah, solution is DX11. But I like DX9 :slight_smile:

I love those black stripes, if I see them in the morning ( ingame ) I know it’s a bad *** engine.!
Shadow depth bias something…