Download

Animation Blend Per Bool Issue - Weird Pop or Jump or something..

****, after hours and hours and hours of trying to fix this, I find its a freaking bug…sighs.

I hope this is fixed soon as well, it was driving me crazy, is it going to be fixed in 4.9?

Any news on this? I’ve just recently encountered this issue as well. Is this something that needs to be fixed in the engine, or can I fix it by modifying the animations (Blender is all I have)? If this can be fixed by the user, then can someone with the know-how please maybe post a short tut or video?

It is not a problem with the engine itself, but the way the animations with the new silver guy were rigged and exported for the Animation Starter Pack vs the way the animations were exported for the Third Person Blueprint Project. Neutronux has posted a feasible workaround above, for Maya. It is probably fixable in Blender as well but I do not have enough experience with that program to verify that it is.

I fixed this issue if anyone cares, simply download this zip file >>>https://drive.google.com/file/d/0B32snFZvDyv3OWlrRHd5QUFWbFU/view?usp=sharing

It has the default mannequin mesh and the animations from the thirdperson template and the animation starter pack properly retarggeted, import it to your project, the mesh and animations.

Then recursively set the skeleton all to skeleton, except root, pelvis, and all the IK’s, they need to be set to animation.

Boom! Fixed… No more weird dipping.

I can make a video if anyone has any trouble.

Just wanted to let you know, I fixed this issue, see the post I made in this thread about it.

Awesome work, IAmJohnGalt75! Hopefully this will be “officially” fixed soon but in the meantime I know a lot of users struggling with this that will appreciate your post.

Not a problem, I just fixed it and packed all the animations and mesh together so they can just download and import it no other software required.

If anyone needs further help with getting the fix in just let me know and I can make a video, with step by step instructions.

Just to show the difference:

Blender 2.75a FBX import without automatic bone rotation:

Blender 2.75a FBX import with automatic bone rotation:

Blender 2.75a DAE import:

Maya LT 2016 FBX or DAE import (both works well):

…and even parent and unparent with all it’s offset and so on works very well in Maya while it’s a pain with blender. So even if I like blender very much (and made way more with it than with Maya) it’s very frustrating to use it with imported UE stuff. Wished there was some blender import/export :wink:

Hi everybody,

IAmJohnGalt75 , I have a problem, I need your help please:

Your fix don’t correct the problem…

Here is a video of me fixing this >>>>http://www.twitch.tv/iamjohngalt75/v/12099332

Still waiting for a fix…

Thanks John, enjoyed your video. Verified that the fix is working now, at least for blending between Walk - JogFwdRifle - Run.

This has been marked fixed for the 4.11 Preview.

@Steve

The issue is with how the ThirdPersonTemplate animations were exported. TheAnimationStartPack ones are fine.

It is easily reproduced. You can see in the Animation Editor that the rotation is messed up on the TPP animations Idle, Jump_Start, Jump_End, Jump_Loop, Walk and Run.

It also still occurs in 4.11 Preview 1 but it looks like the fix was submitted on Jan 6th so preview 2 should get it.
Steps to reproduce
1.) Create a new TPP
2.) Import an animation from The StarterPack or Maya ART Tools
3.) Choose the Mannequin/Characters/Mesh/SK_Mannequin as the skeleton
4.) Create a Simple 1D Blendspace between any of the TPP Animations and the new animation.

You will see the Dip when blending.

Now if you did the same thing with say the Animation StarterPack and an animation exported from Maya Art Tools or Mixamo there is no dip.
It’s just the Idle, Jump_Start, Jump_End, Jump_Loop, Walk and Run that are the offenders.

** UPDATE **

Well I just downloaded the Master branch and created a new TPP project and it looks like

#jira UE-19659 Reimported Template Animations with Proper Skeletons

reimported them again the broken way.

I hope this will be fixed really soon… What about me I have not see big problem in this because I’m using the stock animations as I make my own…

My mistake, this has been Verified fixed for the official 4.11 Release [ChangeList:2819090], not the preview.

Hey Everybody,

As Steve just updated, it’s fixed in our internal 4.11 Release Stream, this fix is yet to be merged over to Main Stream yet. At the time of this post, you’ll only find it in 4.11 Release after CL:2817625.

It is a fix to the animations in the Third Person Template itself.

Confirmed Fixed in 4.11 Preview 2.

Thank you so much :slight_smile:

OMG! I just wasted a good 3 or 4 days on this. I got to go out side a let some frustration go. Do we have a list somewhere with all these major problems?

I’m afraid this was just considered as a minor issue. :smiley: - But I could feel your pain and I remember this damned my last summer holiday :wink: - But there was already lots of threads regarding that issue. The community in the animation subsection usually works very well (better than in some other subsections) and as already posted 4.11 fixed it. I think there is no such list with problems because everybody got other problems. Anyway the next “major” issue on my path (that consumed way more hours than that issue) was that “Always Tick Pose” vs “Always Tick Pose and Refresh Bones” of my skeletal mesh. I always though I did something wrong with spawning my projectiles (that just dropped around my body sometimes but not at my socket location). Many months later I finally found out that the (listening) server just did not update my bones if the server player does not look at the other player (feature - no bug).