Advanced Sessions Plugin

For the MakeArray node, the output when using the ‘Make Literal Session Property …’ stuff is an Array of Session Property Key pair structures. I was trying to make a macro to clean up the BP’s a bit… I have what is below, but can not seem to find any key pair structure to set for the ‘outputs’ node so I can connect it. Is it possible?


Well no, that appears to have been an over site of mine, that keypair and one other struct were declared with USTRUCT() instead of USTRUCT(BlueprintType) so they are not directly accessible with blueprints.

I have changed them so that they are accessible on the 4.9 version and am uploading it. However the 4.8 won’t be updated until tomorrow (I download older versions and delete them after compiling for updates and I’m on the way out of the office).

I needed to re-upload 4.9 anyway for the 4.9.1 hotfix that just came out today.

Edit 4.9.1 version Uploaded

Nice, thanks, I will be trying 4.9.1 with my project to see how it goes as well, maybe they fixed most of the issues that came out in 4.9.

4.8.3 Version uploaded

Working like a champ.

When you get to the Update Session part be sure to use the AddOrModifyExtraSettings node, I made it just for updating arrays of settings so that it wouldn’t have to be done manually in Blueprint.

Maybe I spoke too soon, it works like a champ in the editor. When packaged it can not create session.

And when I do my ‘join’ to find sessions, it always returns that it did find a session, never returns fail, even though I don’t have one running. Ugh, guess I will be digging into that for the next few hours.

Well, not sure WTF is going on, but switched to normal create session and packaged and it worked… figured I would start changing options on Advanced create session, and clicked off Allow Invites, rebuilt and it creates them fine now. Dunno, will leave it off for now. With that set to on (allow invites) I was getting a travel error

It always returns success because it technically “finds” the other steam sessions that other people are hosting under the same ID, this is how their default implementation works. I debated returning failed if none of the servers were yours but decided to keep it consistent with their way of handling it.

If you check if the returned results array is > 0 right now it works as you expected it to, also if you use your own exclusive steam id it should work as expected as well.

Ah, am not using steam.

I am starting to think a lot of the troubles are 4.9.1 … now when I build I am getting an uable to find package for one of my game modes… it’s looking in the wrong directory. I think I am gonna have to drop back to 4.8.3… so annoying.

Very interesting, thanks for sharing :slight_smile:

mordentral, I managed to get steam in there, and working. Hosts a server. If I go to Steam and look at their servers list, should that show up if I filter for spacewar? (that’s what the 480 app id is from what I have read)…

Not seeing it up there, and not finding it when I do a search for sessions.

I really doubt that they would show the app id 480 on their master server list, it is for WIP games after all, I realize that the option is there but I don’t think it populates. When searching for your servers with 480 it filters out a ton of active servers on steam that others are hosting to test with the ID.

When searching for your session do you have any filters set? You also have to make sure that the host is on the same build as you and the host CAN’T find sessions while hosting one it will just error out when searching if you are the host machine.

Really testing steam requires two computers or virtual machines as you can’t run two steam enabled instances off of the same steam account.

Makes sense. No, did not have any filters set. Will try on a different machine… maybe a good chance to try a build for Mac as well, and use that as my 2nd computer. Thanks.

I tried it a while back on two different windows machines, two different steam accounts. Worked great. Now I have tried with another person, and we are having the issue that it does not return/find the session either of us is hosting. Find " STEAM: Can’t start an online game for session (Game) that hasn’t been created" in the logs, not much searching google on that one…

I have the same problem and I think I know why this is happening.This problem is because of test id 480,when you get your own id this problem will go away.

I tested my game with two friends,first friend was able to find my session and the second on couldn’t find my session.

I too get this when trying with a Friend. If I host he can see the session but when he tries to join error. If he tries to Host while I’m already hosting he gets an error also. And Vice versa.

STEAM: Can’t start an online game for session (Game) that hasn’t been created
STEAM: Can’t start an online game for session (Game) that is InProgress

Any help would be appreciated.

Is he out of your country? I believe that the default steam app id is region locked unfortunately. People with their own App IDs don’t have that problem.

I don’t know your exact node setup but it sounds like you are not correctly setting up the nodes.

Thanks for replying Mordentral, My node setup is the same as you see above in Arbopa’s system. We actually tested with eachother which makes sense why we couldn’t see eachothers sessions cause of the Region Lock.