Download

Advanced Sessions Plugin

I’m all out of ideas, sometimes it works and sometimes it does not. The level inconsistency is so high I’m about to lose my mind. We’ve tried using VPN, we’ve spent some hours making sure everyone’s router settings are set up properly*(ports 27000-27050 and 7777,7778)*. We’ve tried DMZ mode on all ends. Nothing.

I’ve compared logs over and over, no errors, just warnings from unrelated games such as Stellaris and Hearts of Iron 4. It might be the region lock, it may not. I’ve tried it with 2 people with varying results, one from Norway and one from the UK*(I live in Sweden)*. I really can’t put my finger on what it may be, but my assumption is Steam’s test app ID just an utter mess.

If you ever get the time, would you mind taking a look at my project? It’s not too big at the moment as we haven’t started adding assets yet - it’s ~99.5MB when compressed in a .rar archive. I’d greatly appreciate it. :frowning:

You can PM a link to me, i can maybe look it over tonight. I know of one project that released out of greenlight with the plugin and didn’t seem to have session issues.

Rebuilt the plugin to 4.12.3 and re-uploaded it.

Hello, once again thank you for your work. This plugin is still amazing, but right now I’m stuck and I have no idea what the problem could be. I send an invite to my friend. He gets the steam invitation on Steam but in my game instance the two event does not get called. Neither of them prints anything :S. Any idea what could cause it?

48c6b58ac8086f6ad04f978ee80c68b8afbcef6b.png

Gabeee, you’ve got your answer just a few replies above you. Unfortunately it would seem Epic hasn’t implemented it yet. :frowning:

Not true, the On Session Invite Accepted event should work I believe, it is the on received one that will not work. Accepted has to work because that is how you implement joining the game off of the friends list invite.

Hi Mordentral! In my PC my project with the pluggin work exelent, but when I export to Android (ALL) in Log file I get this errors and then Package Failed…

MainFrameActions: Packaging (Android (All)): UnrealBuildTool: C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Source\AdvancedSessions\Private/AdvancedFriendsLibrary.cpp:39: error: undefined reference to ‘SteamAPI_Init’
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Source\AdvancedSessions\Private/AdvancedFriendsLibrary.cpp:43: error: undefined reference to ‘SteamFriends’
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Source\AdvancedSessions\Private/AdvancedFriendsLibrary.cpp:59: error: undefined reference to ‘SteamAPI_Init’
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Source\AdvancedSessions\Private/AdvancedFriendsLibrary.cpp:63: error: undefined reference to ‘SteamFriends’
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Source\AdvancedSessions\Private/AdvancedFriendsLibrary.cpp:80: error: undefined reference to ‘SteamAPI_Init’
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Source\AdvancedSessions\Private/AdvancedFriendsLibrary.cpp:92: error: undefined reference to ‘SteamFriends’
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Source\AdvancedSessions\Private/AdvancedFriendsLibrary.cpp:93: error: undefined reference to ‘SteamFriends’
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Source\AdvancedSessions\Private/AdvancedFriendsLibrary.cpp:100: error: undefined reference to ‘SteamUtils’
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Source\AdvancedSessions\Private/AdvancedFriendsLibrary.cpp:111: error: undefined reference to ‘SteamUtils’

I have the last version 12.3.
Thank for this exelent pluggin!!!

Just to make it sure. You accept it on Steam, and the event gets called right?

Yes, and it is working for others ATM and is implemented in the subsystem. The other event sadly is not implemented yet.

mmm, android doesn’t support steam as a subsystem. Since I have steam specific functions in it you are getting errors packaging for android. I can wrap the steam specific functions up in a platform check and it should be fine. I’ll release a new version in a little bit that you can try out.

Excelent!!! release the new version and I try again!!!

Thannnkkk! When you make a new realease I try this again. So many thanks!

It has been updated, it now skips all of the steam specific code when compiling for platforms other than linux/mac/windows. Let me know if that works for you.

Alright, I guess I’m going to find the reason it doesn’t want to work for me. Maybe something is wrong with my session.

I delete the folder in Pluggin folder, next copy the new one.

Now I have another different error:

MainFrameActions: Packaging (Android (All)): UnrealBuildTool: Reflection code generated for SuperSlughfest in 14,8313241 seconds
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: Performing 4 actions (2 in parallel)
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: [2/4] clang++.exe AdvancedSessions.generated.cpp [armv7-es2]
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: [1/4] clang++.exe Module.AdvancedSessions.cpp [armv7-es2]
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: clang++.exe: error: no such file or directory: ‘@C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Intermediate\Build\Android\UE4\Development\AdvancedSessions\Module.AdvancedSessions.cpp-armv7-es2.o.response’
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: clang++.exe: error: no input files
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: clang++.exe: error: no such file or directory: ‘@C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Intermediate\Build\Android\UE4\Development\AdvancedSessions\AdvancedSessions.generated.cpp-armv7-es2.o.response’
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: clang++.exe: error: no input files
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: ERROR: UBT ERROR: Failed to produce item: C:\Users\Koki\Documents\GitHub\UE4\Plugins\AdvancedSessions\Binaries\Android\UE4-AdvancedSessions-armv7-es2.a
MainFrameActions: Packaging (Android (All)): UnrealBuildTool: Total build time: 20,58 seconds
MainFrameActions: Packaging (Android (All)): CommandUtils.Run: Run: Took 20,7893605s to run UnrealBuildTool.exe, ExitCode=5
MainFrameActions: Packaging (Android (All)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Command failed (Result:5): C:\Program Files\Epic Games\4.12\Engine\Binaries\DotNET\UnrealBuildTool.exe SuperSlughfest Android Development -Project=C:\Users\K
MainFrameActions: Packaging (Android (All)): oki\Documents\GitHub\UE4\SuperSlughfest.uproject C:\Users\Koki\Documents\GitHub\UE4\SuperSlughfest.uproject -remoteini=“C:\Users\Koki\Documents\GitHub\UE4” -noxge -NoHotReloadFromIDE -ignorejunk. See logfile for details: ‘UnrealBuildTool-2016.06.17-12.49.34.txt’
MainFrameActions: Packaging (Android (All)): en AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, String Logfile, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary2 EnvVars) MainFrameActions: Packaging (Android (All)): en AutomationTool.CommandUtils.RunUBT(CommandEnvironment Env, String UBTExecutable, String CommandLine, String LogName, Dictionary2 EnvVars)
MainFrameActions: Packaging (Android (All)): en AutomationTool.UE4Build.BuildWithUBT(String TargetName, UnrealTargetPlatform TargetPlatform, String Config, FileReference UprojectPath, Boolean ForceMonolithic, Boolean ForceNonUnity, Boolean ForceDebugInfo, Boolean ForceFlushMac, Boolean DisableXGE, String InAddArgs, Boolean ForceUnity, Dictionary2 EnvVars ) MainFrameActions: Packaging (Android (All)): en AutomationTool.UE4Build.Build(BuildAgenda Agenda, Nullable1 InDeleteBuildProducts, Boolean InUpdateVersionFiles, Boolean InForceNoXGE, Boolean InUseParallelExecutor, Boolean InForceNonUnity, Boolean InForceUnity, Boolean InShowProgress, Dictionary2 PlatformEnvVars, Nullable1 InChangelistNumberOverride, Di
ctionary2 InTargetToManifest) MainFrameActions: Packaging (Android (All)): en Project.Build(BuildCommand Command, ProjectParams Params, Int32 WorkingCL, ProjectBuildTargets TargetMask) MainFrameActions: Packaging (Android (All)): en BuildCookRun.DoBuildCookRun(ProjectParams Params) MainFrameActions: Packaging (Android (All)): en AutomationTool.BuildCommand.Execute() MainFrameActions: Packaging (Android (All)): en AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands) MainFrameActions: Packaging (Android (All)): en AutomationTool.Automation.Process(String] CommandLine) MainFrameActions: Packaging (Android (All)): en AutomationTool.Program.MainProc(Object Param) MainFrameActions: Packaging (Android (All)): en AutomationTool.InternalUtils.RunSingleInstance(Func2 Main, Object Param)
MainFrameActions: Packaging (Android (All)): en AutomationTool.Program.Main()
MainFrameActions: Packaging (Android (All)): Program.Main: AutomationTool exiting with ExitCode=5 (5)
MainFrameActions: Packaging (Android (All)): Domain_ProcessExit
MainFrameActions: Packaging (Android (All)): copying UAT log files…
MainFrameActions: Packaging (Android (All)): BUILD FAILED
PackagingResults:Error: Error Unknown Error

Thank for the quick reply and the amazing job!

UPDATE: I delete some folders (SAVED, INTERMEDIATED and BINARI) and maybe I solve this last problem…

Solved!

I Delete the folders BUILD, INTERMEDIATE and SAVED and its work again.

I think the update is very necesary, and a little trick of delete this folders too.
Thanks again!

Yeah intermediate stores the auto generated files, it gets in the way when it doesn’t know you need to regenerate it. You can either delete the folder entirely or (in most cases, sometimes deleting is required) run a “clean” operation on the project.

It still had information from the last version of the plugin in it.

Ug, i’m going to have to revise the android fix and upload a new version. UFunctions inside of a preprocessor define check don’t ever compile out, even if the preprocessor check succeeded.

I’ll have the blueprint functions stay inside of the android builds but return null values instead. Don’t think there is an alternative without splitting it into another module or header.

Edit Uploaded the fix, someday i’ll make it cleaner

Trying to compile a WindowsServer build but I’m getting the following error

ERROR : UBT error : Failed to produce item: C:\Unreal Engine Projects\Dreadgrasp\DGP\Plugins\AdvancedSessions\Binaries\Win64\UE4Server-AdvancedSessions-Win64-DebugGame.lib

I’ve tried deleting the folders as suggested above, but to no avail. Any help is greatly appreciated.

Hi Again! I finish a tutorial and in the PC work really fine, but in android CREATE ADVANCE SESSION and JOIN ADVANCE SESSION failed everytime…
My DefaulEngine.ini its:

[OnlineSubsystem]
DefaultPlatformService=Null

This is the tutorial: https://www.youtube.com/playlist?list=PLLiI_CRDNPL95LQnS6PGjrWxHkWbHcjAl

Thats my blueprints en Game Instance:
214a7c262e81b686b089892e7c4ff73974c02839.jpeg
46a29e87af7c9031fd5bb536738768074671df0d.jpeg

I download the last version and have the issue with the above version (when I have a problem to compile the APK).
Sorry for my English! Thanks from Argentina!