Download

Advanced Sessions Plugin

What version of the engine are you using? Can you post a screenshot of your blueprint?

Edit: I’m pretty sure friend invites are broken for now until it’s fixed in a future engine release. I got friend search and join to work.

Those warnings are because of using the generic APP ID for Steam, it is filtering out other peoples games from the returned list for you and notifying you about it. I can’t help with your finding problems without seeing your blueprints.

The engine version is 4.12.3 (I had the same problem with the 4.10.4 and just converted my project) And of course I can show you my blueprints.
Creating the game session:
bp1.jpg
Searching for game sessions (resulting array length is always zero):
8ef37afa93a978a8de643c3484bc59747e9d1e46.jpeg
And here’s inviting friend to the game:
bp3.jpg

I hope this will help you.

Where is your friend located? App ID 480 is region locked so if he is across country bounds it may be blocking you two from seeing each other.

I say this because generally your implementation looks correct and that exact same issue has come up a million times here.

Worth noting that the region lock may be to EU, instead a country-to-country basis as I’ve been able to play with someone living in Britain as well as Norway. However, I have never been able to play with someone from the US. I wish Valve would make some more detailed information available as it’s causing quite a lot of confusion and frustration. :rolleyes:

My friend is located in Russia just like me. And now I’ve changed the AppID of my game to the AppID of one of my old projects. Will test now.

It didn’t work.


[2016.07.01-15.48.29:334] 13]LogOnline:Warning: Async task 'FOnlineAsyncTaskSteamJoinLobby bWasSuccessful: 0 Session: Game LobbyId: Lobby [0x18600008B140A35] Result: '3' k_EChatRoomEnterResponseNotAllowed (General Denied - You don't have the permissions needed to join the chat)' failed in 0.369664 seconds


And I can’t find my friend’s game session.

[UPDATE]
Okay, now it’s working. Problem has been solved in a very strange way: I’ve just created a new empty project and moved all my work into that project.

Curious, we had a similar issue and I sent that project to Mordentral hoping he might spot whether it was an error on my part - or some bug, maybe your project suffered a similar fate as mine had?

I was on 4.11.2 when it happened to my project, so I decided to upgrade to 4.12.3 and in doing so made a new empty project and mine started working again as well.

I think we’ll never know the source of this problem. But this is a very strange bug. By the way, I think it would be great if Mordentral will make a blueprint functions to interact with the Steam stats. Because I spent few weeks for that and still have a some troubles.

Out of curiosity, before your issue began to occur - had you been adding/removing plugins shortly before?

My project just started acting up again, it wouldn’t connect to Steam when launching as a Standalone anymore. All I can really think of is that yesterday I took a look at eXi’s sound visualization plugin - but later removed it after having tried it a bit. I’m thinking maybe that could have corrupted it?

It however seems like removing Binaries, Intermediate and Saved fixed the issue. It now connects to Steam when launching as a standalone. Mordentral said it seemed like some binaries were corrupted in the project I sent him earlier, so I guess he was right. Now I just need to figure out what actually breaks it so I can avoid it in the future.

Really all I remember doing as of lately is;

  1. Checked out eXi’s sound visualization plugin, later removed it.
  2. Worked with some logic in one of my gamemodes.
  3. Playtested in a different environment - use separate processes, launch as a listen server.

I’ll see if I can reproduce it :rolleyes:

Edit: Reproduction successful, at least in my case.

1. Untick Use Single Process
2. Change Editor Multiplayer Mode to Play as Listen Server
3. Change Number of Players to 2
4. Play and then close the game.
5. Revert the settings back to default; Use Single Process.
6. Steam no longer connects when launching as standalone, removing the folders Binaries, Intermediate and Saved is necessary to fix it.

Not sure if it’s logical why this happens, but it’s a 100% reproducible issue with my project which is unfortunate as I found playtesting in the above environment to be the most “accurate”. However, I now know what causes it and how I can fix it.

Just delete the Project/Saved directory, it saves your last settings and can get in the way sometimes of using new settings (was killing some of my VR experiments).

Got ya, you reckon this could be what messed up my previous project? Or did that thing just get possessed or something? :stuck_out_tongue:

It probably is what messed up your previous one yea, some of the settings get “stuck” on in saved and even make it through to packaged builds.

Hi,

Love the plugin, everything works perfectly. I was wondering if this adds any support for multiple voice channels within a session?

Nope, but you can fake it by muting and unmuting / registering and unregistering players.

Awesome plugin, is there any way to add support for finding out whether a certain (steam) playerID is VAC-banned or not? The Steamworks documentation tells us we should look for it ourselves in the game, I’m not sure how to though and it’s not currently supported in the plugin.

Have a nice day regardless!

Hello,

We have been using Advanced Sessions for some time now (since about 4.10). With 4.12, our project seems to no longer find any sessions, join sessions through steam invites, or anything (it was all working before 4.12).

I’ve noticed that the last posted version was for 4.12.3, though your changelog mentioned 4.12.4. Is there an issue with 4.12.5 or the plugin that caused it to break? Or any particular reason why it would stop working? We’ve checked our configuration files and everything is as it should be, so any suggestions would be helpful.

We used to have a similar issue, but after I learnt what was causing our issue*(me playtesting using separate processes)* we found out that removing the Saved folder fixed the issue for us. While I’m not on 4.12.5 myself yet, it could be worth a try perhaps.

Maybe it’s just a healthy thing in general to remove that folder and have it re-generate from scratch every now and then… :rolleyes:

Yeah it works fine for me in 4.12 (all versions), I am compiling the 4.12.5 version right now actually.

Edit 4.12.5 uploaded

This was it, deleting the Saved folder on all machines got it working again. I’m glad it was so simple. Thank you!