4.8.0 save button in skeleton editor does nothing

minor but the save button in the skeleton editor seems to do nothing.
work around is using save-all from the main page.


Are you trying to save an animation, skeletal mesh, or skeleton? When you do so, are you in the Skeleton, Mesh, or Animation section of Persona?

-Matt W.

just double click on any skeleton, move a socket so it’s newly saveable and press the save button. Something might flash but it doesn’t show on the tab or icon that it saved, still shows the *

Save-all from main menu seemed to save it though.

I’ve upgraded since then and it’s saving like it should on this version, I just tried it, so i guess its not an issue going forward. Thanks for the follow up.

Actually, looks like it’s still happening.

I’ve hit save like 15 times on this skeleton but it won’t seem to save. I managed to grab a snapshot while the save progress bar popped up. It pops up for less than a second. If I go to the main content browser and save all it pops up there as needing to be saved.

So I can see from your second screenshot that you’re not in the “Skeleton” mode of Persona (see the top right). “Save” will save whichever one you are currently editing. When you bring up the skeleton tree in mesh mode, it will still only save the mesh.

I generally find it to be good practice to stay in skeleton mode when modifying sockets. Simply click on “Skeleton” in the top right of Persona.

-Matt W.

EDIT: If you think it’d be good, I can put in a feature request for a “Save All” button, but there is also the Ctrl+S shortcut.

Ahh thanks. I understand what you were asking previously now. I know the difference between the tabs. I didnt realize it distinguishes saves based on the tab you’re in. Hence sometimes it worked for me and sometimes not maybe. Though I’m fairly certain in 480 i did directly open a skeleton. But maybe not.

In either case it’s working as designed. I dont think a save all is necessary here, however what might be good and less confusing is when one edits the skeleton while in animation mode, one should be able to hit save and assume those changes. I think its rare for people to play with animation scaled, skeleton retargeting options while in skeleton mode (unless they already know how their animations will look as a result. Unless they go to the animation, start it, then pause it, then go to skeleton to see their changes.

Right now if you click on (and stay in) the animation tab, then edit the skeleton retarget options on the left, the skeleton immediately says it needs to be saved since it’s been changed. There’s no obvious indication that I need to actively switch to the skeleton tab to make sure this takes affect.

Naturally I just assume if i CAN edit the skeleton while watching the animations in animation tab, when I hit SAVE it’s saving what I’ve done. In this case it isn’t which made me think its a bug. Maybe a feature where if in any of the three tabs and one of the others have been modified from there, it prompts “would you like to save your changes to the skeleton as well”.

Now that I know about it, I’ll pay attention to saving in the right tab. I have a habit of remembering that I DID save something, so if I get prompted when exiting the program 10 mins or hours later I’ll say no… which would be bad for me in the previous mindset.

So open a feature request if you think its warranted, otherwise no worries

Thanks again!

Cool. I didnt know the CTRL S worked for SAVE ALL from anywhere… I’ll use that for most changes now. I thought it defaulted to the SAVE button of whatever tab I was in so I never really used it.

I’m always super paranoid about saving everything. After making any significant changes, I go to the Content Browser and hunt for asterisks. I think that’s a result of my time in Engine QA working with unstable branches of the engine.

Anyways, I’ve entered UE-17638, which indicates that there is some confusion about the save button functionality throughout Persona.

-Matt W.

Being in Skeleton mode or whatever you call it doesnt do anything, still wont let me save